Avatar of hgpitdept
Flag for United States of America asked on

Power injector not providing proper power for Cisco 1240AG AP.

I have a few brand new Cisco 1240AG access points.  They work fine if plugged directly into AC power via the adapter but if I use the power injector that goes with this model the radios will not power up.  I get the following error message when connecting to the AP via HTTP.
"WARNING, All radios disabled due to insufficient inline power. Upgrade inline power source or install power injector."
I've tried other power injectors but get the same issue.  My test setup is only using 6 foot CAT5 patch cables so distance shouldn't be an issue.  What am I doing wrong?  I am using the correct Cisco brand power injectors.  
Wireless Hardware

Avatar of undefined
Last Comment

8/22/2022 - Mon

remember, when you switch to PoE on the AP, you need to configure the AP to use PoE.  I can't remember exactly where its at, but when you login to the web config of the AP, go to the system status.  I believe that is where the power setting is set.  switch it to PoE and the radios will turn on.

keep in mind that PoE works by tieing in the MAC of the switch port.  so if you move the AP to another port, you need to switch it back to AC power first, or you'll have to console in.  At least that's what I had to do.

I looked for this but found that it auto selects.  It doesn't even appear to be a setting that can be changed it just shows up as text saying either AC power or INJECTOR_CONFIGURED_ON_ANOTHER_PORT.  The MAC address does show up automatically when connected to the injector.  I do have the option to choose either Power Negotiation or Pre-standard Compatibility but I've tried both of these settings and neither of them seem to change anything.  Thanks.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

I entered the two commands below via telnet that I found in the above link.

no power inline negotiation prestandard source
power inline negotiation injector installed

This appears to of fixed the issue.  I still don't really understand why I even had the problem in the first place since I have other 1240s working fine with power injectors.  I didn't have to enter these commands on my other 1240s.  Thanks for your help.  I'll be testing it over the next few days to see how stable it is.  
Your help has saved me hundreds of hours of internet surfing.