Link to home
Start Free TrialLog in
Avatar of lagarwal
lagarwalFlag for United States of America

asked on

Java Web Start launches only once

We have a swing application that has a few libraries that are self-signed. The app was being deployed to user workstations using web-start. Since last few updates of java we have seen users complain about getting an "Unable to launch application" error with the following exception.

Java.lang.NullPointerException
      at com.sun.javaws.security.SigningInfo.verifyAllEntriesSigned(Unknown Source)
      at com.sun.javaws.security.SigningInfo.checkSigning(Unknown Source)
      at com.sun.javaws.LaunchDownload.checkSignedResourcesHelper(Unknown Source)
      at com.sun.javaws.LaunchDownload.checkSignedResources(Unknown Source)
      at com.sun.javaws.Launcher.prepareLaunchFile(Unknown Source)
      at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
      at com.sun.javaws.Launcher.launch(Unknown Source)
      at com.sun.javaws.Main.launchApp(Unknown Source)
      at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
      at com.sun.javaws.Main$1.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)

If the cache is cleaned and we go to the website to download the app again, it works fine once (sometimes twice). Then it starts throwing the exception. The only thread I found that matches my same issue is http://forum.java.sun.com/thread.jspa?threadID=5305952&tstart=0. The 'solution' mentioned in the thread does not help me. The app works fine on Linux. The client we are having problems with is on XP pro. Experts help is greatly appreciate it.

Thanks.
Avatar of MicheleMarcon
MicheleMarcon
Flag of Italy image

Did you try reinstalling Java and/or testing the issue with a different XP machine?
Avatar of lagarwal

ASKER

I have. Funny thing is it works on some machines with jre 1.6u7 just fine. One of my laptops had 1.6u3 and the app was working fine. To try and break it I installed 1.6u7 and it broke it immediately. I have also on the same laptop uninstalled u7 and installed 1.6.0 and that fixes it. That is the mode we are in right now. If a user is having trouble we recommend they downgrade to 1.6.0 and disable java updates. For the short term that is fine. For longer term may be Sun will fix the problem (seems like its a java issue, nothing to do with our app). Or we will have to look for alternative ways to deploy our app. Any suggestions in that regard? Alternative deployment tools I mean.
First of all, send a bug report to Sun.

Secondly, I would test the Java6 update10 beta

http://java.sun.com/javase/downloads/ea.jsp

ASKER CERTIFIED SOLUTION
Avatar of lagarwal
lagarwal
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
FYI, I had exactly the same problem.after the automatic install of update 7. Following the suggestion of Michele Marcon, I installed update 10 beta 25 and the problem was solved!
Thanks for the info Rene. Good to know that Sun has fixed it I will try the 10 beta. Hopefully it will be production ready soon.