Link to home
Start Free TrialLog in
Avatar of preshomes
preshomes

asked on

Routing DHCP / BootP

I have a main site (Site1) and a remote site (Site2).  I have successful communication between both sites.  I can access systems resources on both networks from each direction.

Site2  - Router  10.10.10.6   Gateway  10.10.10.5  Network 100.100.101.x
Site1 - Layer 3 Switch 10.10.10.2  Gateway 10.10.10.1 Network 192.168.0.x
Site1 Firewall  192.168.3.1   DNS 192.168.3.2

My Problem - At Site1 I have a DHCP server setup for the 100.100.101.x network. At Site2 my router has an ip helper that I have setup to point to 192.168.3.2 which is my DHCP server at Site1 but I can not seem to get assigned an IP from the scope on a machine in Site2. If I place a static ip on a machine at Site2 everything works beautifully but now I need it to get an IP from DHCP.

Please advise what changes I need to make.
Avatar of bkepford
bkepford
Flag of United States of America image

The "ip helper-address" command has to be configured on the "interface" of the LAN segment that is 100.100.101.x

for example

interface FastEthernet 0/0
description this is the Interface going out to the switch the ip helper-address does not go here
ip address 10.10.10.1

interface FastEthernet 0/1
description this is the LAN segment that needs a dhcp server
ip address 100.100.101.1 255.255.255.240
ip helper-address 192.168.3.2
Avatar of Qlemo
Did you configure a DHCP relay agent on site 2?
Avatar of preshomes
preshomes

ASKER

Yes...at site 2 my router 100.100.101.1 is setup like this

IP Interface

Name            IP Address               Netmask             Type  
ppp 1           10.10.10.6           255.255.255.252      PPP  
eth 0/1       100.100.101.1        255.255.255.0        Ethernet

UDP Relay / IP Helper

Interface - PPP1
IP Address - 192.168.3.2
UDP Forward  Protocol - bootps (67)
That looks like the IP helper-address is on the ppp 1 interface. It needs to be on the eth 0/1 interface

Can you do a show run on your router and post it?

Quickest way to find out what is going on: use WireShark (or similar) to record traffic on DHCP server, setting the filter to bootps (udp/67), and than forcing DHCP update (by ipconfig /renew or switching from static to dynamic ip) on remote site. That way, you will see whether the DHCP packets are relayed.
See the show run info below.  As far as testing I am at Site2 and have a machine setup for dynamic ip

no auto-config
!
event-history on
no logging forwarding
logging forwarding priority-level info
no logging email
logging email priority-level info
!
service password-encryption
!
username "xxxx" password encrypted xxxx
ip forward-protocol udp time
ip forward-protocol udp nameserver
ip forward-protocol udp tacacs
ip forward-protocol udp bootps
ip forward-protocol udp tftp
ip forward-protocol udp netbios-ns
ip forward-protocol udp netbios-dgm
!
banner motd #

                ****** Important Banner Message ******

Enable and Telnet passwords are configured to "password".
HTTP and HTTPS default username is "admin" and password is "password".
Please change them immediately.
The ethernet 0/1 interface is enabled with an address of 10.10.10.1
Telnet, HTTP, and HTTPS access are also enabled.
To remove this message, while in configuration mode type "no banner motd".

                ****** Important Banner Message ******

#
!
!
no ip firewall alg msn
no ip firewall alg h323
!
!
!
!
!
!
!
no dot11ap access-point-controller
!
!
!
!
!
!
!
!
interface eth 0/1
  ip address  100.100.101.1  255.255.255.0
  no shutdown
!
!
interface eth 0/2
  description test
  no ip address
  shutdown
!
!
!
!
interface t1 1/1
  description ZDES
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface ppp 1
  description ZDES PPP
  ip address  10.10.10.6  255.255.255.252
  ip helper-address  192.168.3.2
  no shutdown
  cross-connect 1 t1 1/1 1 ppp 1
!
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 ppp 1
ip route 192.168.0.0 255.255.0.0 ppp 1
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
!
line con 0
  login
!
line telnet 0 4
ASKER CERTIFIED SOLUTION
Avatar of bkepford
bkepford
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I changed the helper to eth 0/1 but still no ip address from DHCP
try adding this command in the global configuration mode ie. not under the interface

ip dhcp relay information option
I added the ip helper for 192.168.3.2 on both interfaces  ppp1 and eth0/1 and finally got an ip address on a machine at site2 via dynamic

Thank you for your help!


Thank you!!!!!!!!!!!!  You are a true routing expert!