Link to home
Avatar of Kyle Olderog
Kyle OlderogFlag for United States of America

asked on

Why won't this router talk to the WAN?

My router suddenly stopped working right.  I live in an apartment complex that offers free internet.  A local ISP proveds service to our apartment complex, which is then distributed to each building that has its own switch.  So when I plug my PC (set to DHCP) in to the wall-jack, it picks up a 10.107.128.x address and I can get out to the internet and everything works as it should.

If I plug my own home router (Netgear router, set up as a DHCP server) into that same jack and then my PC into the router, I get IP settings from the router but can't get internet service.  I log in to the router's web interface and check the status and see that the router is not picking up an address.  So I reboot the router.  No change.  I reset the router to factory defaults.  Still doesn't work.

I then remove that router and try a different one (my old Linksys, also set as a DHCP server).  Router works great - get's an IP address immediately, then gives my PC an address on my own home network, and I can surf the internet.  

I think maybe my Netgear router is being blocked based on it's MAC address.  I'm able to "change" my MAC address to look like it is my PCs MAC address, so I do this.  Router still can't get an IP address from the WAN side.  I also try to use the MAC address of my Linksys router on my Netgear router, but this also fails.  

I take note of the IP settings my LinkSys router is getting, then manually configure those settings on my Netgear.  It still will not connect to the internet.

At this point I'm thinking there's just something wrong with the router, maybe its WAN port is just broken.  So I do this test:  I plug my Linksys into the wall-jack, so it gets in IP address from the WAN.  Then I plug my Netgear into my LinkSys and expect it to fail.  Then I plug my PC into the Netgear and see that it gets an IP address from the Netgear (as expected).  I connect to the Netgear's web interface and check the status and yes, it got IP settings from the Linksys.  I test, and I can get to the internet on my PC through this ridiculous daisy-chain.

Can anybody expain this, or even offer a guess?   I don't want to exclusively use my old Linksys because it's only got wireless B, so it's slow when I use my laptop on WiFi.  And it's just stupid to have to use two routers.   Any suggestions on how to fix this?  
Avatar of donmanrobb
donmanrobb
Flag of Canada image

Don't plug the wall port into the WAN of the Netgear, instead try one of the 4 LAN ports
Avatar of Kyle Olderog

ASKER

No, plugging the wall port into the LAN ports didn't work.  I've always had it plugged in to the WAN port in the past and it used to work that way, so I wasn't expecting that the LAN port was going to help.  But thanks for the suggestion - I am willing to try anything.
ASKER CERTIFIED SOLUTION
Avatar of donmanrobb
donmanrobb
Flag of Canada image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Resetting to factory defaults was actually the first thing I did (I guess I forgot to mention that).  So I was just going to post that and wait for more suggestions.  But I decided to do it again, just for good measure and this time it worked!  I don't understand what is different about this time, because last time I did it I KNOW it reset to factory defaults because my LAN settings all went back to 192.168.1.1 and my old password didn't work anymore.   But I won't complain, as long as it's working!  Thanks.
Thanks for having me re-try the most obvious solution.  I would have been too stubborn to try it again had you not suggested it!