We have a 3 site private network with private T1 ATM connections between each site. We are having trouble with voice quality from our Shoretel VOIP server. The shoretel system tags the traffic with DSCP value of 48 and we wanted to setup COS on our border Cisco routers to properly queue the traffic. Below is an example of our current running config. I am just not certain if the c1 level queue is setup correctly. The devices set the DSCP bit and I am not sure if it is truly getting matched. Call quality is still bad (only a few users and not much traffic, but we have full T1's).
317596#show run
Building configuration...
Current configuration : 3033 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WH-317596
!
boot-start-marker
boot-end-marker
!
logging buffered 100000 debugging
no logging console
enable secret
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
network-clock-participate aim 0
network-clock-select 1 T1 0/0/0
!
ip cef
!
voice-card 0
no dspfarm
!
controller T1 0/0/0
mode atm aim 0
framing esf
linecode b8zs
!
class-map match-any ACL_111_C1
match access-group 111
class-map match-any ACL_112_C2
match access-group 112
class-map match-any ACL_113_C3
match access-group 113
class-map match-any ACL_114_C4
match access-group 114
class-map match-any ACL_115_C5
match access-group 115
!
policy-map Product5
class ACL_111_C1
bandwidth percent 15
set dscp ef
class ACL_112_C2
bandwidth percent 15
set dscp af41
class ACL_113_C3
bandwidth percent 15
set dscp af31
class ACL_114_C4
bandwidth percent 15
set dscp cs4
class ACL_115_C5
bandwidth percent 15
set dscp cs1
class class-default
fair-queue
!
interface FastEthernet0/0
description LAN
ip address 10.2.2.1 255.255.255.0 secondary
ip address 10.2.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no scrambling-payload
no atm ilmi-keepalive
service-policy output Product5
!
interface ATM0/0/0.38 point-to-point
mtu 1500
no snmp trap link-status
pvc 0/38
encapsulation aal5snap
protocol ppp Virtual-Template1
!
!
interface Virtual-Template1
ip address negotiated
ppp ipcp dns request
ppp ipcp route default
!
no ip http server
no ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
access-list 112 permit tcp any any eq 139
access-list 112 permit tcp any any eq 445
access-list 112 permit udp any any eq netbios-ns
access-list 112 permit udp any any eq netbios-dgm
access-list 112 permit udp any any eq 445
access-list 113 permit ip any host 10.0.1.11
!
control-plane
!
scheduler allocate 20000 1000
!
end
did our comments help you in achieving what you want?
Kurt