Link to home
Start Free TrialLog in
Avatar of CSRPhoto
CSRPhotoFlag for United States of America

asked on

How do I configure Apache to bind to a different IP that IIS on a Windows 2003 server?

I am trying to install Apache HTTP Server 2.2 on a Windows 2003 server with IIS 6 already existing. I have two IP's assigned to the NIC (xxx.xxx.xxx.78 for IIS & xxx.xxx.xxx.42 for Apache) I used httpcgf.exe to force IIS to listen to it's own specific address (xxx.xxx.xxx.78), and assigned the 42 address to port 80 in httpd.conf. But when I start Apache service it comes back with the following error:

(OS 10013) An attempt was made to access a socket in a wasy forbidden by its access permissions. : make_sock: could not bind to address xxx.xxx.xxx.42:80
no listening sockets available, shutting down
Unable to open logs

Can anybody help me figure out how to get Apache Services to start? I'm new to setting up a web server and am trying to figure this out.
Avatar of Michael Worsham
Michael Worsham
Flag of United States of America image

In the Apache httpd.conf file, look for 'Listen' and set it like: 'Listen xxx.xxx.xxx.42:80'
SOLUTION
Avatar of Michael Worsham
Michael Worsham
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of namol
namol

it sounds like your IIS is binding to all available IP addresses, there is a setting to disable called disablesocketpooling but sometimes in iis6 it still doesn't listen.

http://support.microsoft.com/kb/238131/EN-US/ <-- How to disable socket pooling
http://support.microsoft.com/kb/813368/EN-US/ <--- iis6 disable socket pooling
Avatar of CSRPhoto

ASKER

The httpd.conf file is set to 'Listen xxx.xxx.xxx.42:80' (and I don't have it commented out, #, in case you're wondering).

I had already looked at https://www.experts-exchange.com/questions/21757229/Apache-IIS-problems.html but none of the suggestions seemed to apply. For example, niether IIS or Apache are listening to 0.0.0.0, and the ListenOnlyList in the Registry key is correctly displaying the address for IIS.

Any other suggestions?
namol, I followed the KB 238131 but got this error:
ErrNumber: -2147463164 (0x80005004)
Error Trying To GET the Schema of the property: IIS://localhost/Schema/w3svc

KB 813368 I already did with the httpcfg.exe untility earlier (httpcfg set iplisten -i xxx.xxx.x.31).
You got anything else?
namol, I googled that error and found that I put a space where there wasn't supposed to be ine (re: KB 238131). I tried it again and got the (BOOLEAN) True response this time.

I tried to start Apache again but got the same error:
(OS 10013) An attempt was made to access a socket in a wasy forbidden by its access permissions. : make_sock: could not bind to address xxx.xxx.xxx.42:80
no listening sockets available, shutting down
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial