Link to home
Start Free TrialLog in
Avatar of techport13
techport13

asked on

Firefox windows open in background instead of foreground.

I used windowed browsing - haven't gotten into tabs and don't plan to.  I currently have Firefox set to open new windows when I go to a new page via Windows => Run command.

Problem is that recently, new windows are opening BEHIND existing windows.  I do not believe I've changed any settings that would affect this, and I haven't the slightest idea how to "fix" it.

Steps to Reproduce
1) goto Start => Run, type www.google.com, hit OK >> new firefox window will open
2) goto Start => Run, type www.msn.com, hit OK >> new firefox window will open behind window that opened in step 1
Avatar of MMDeveloper
MMDeveloper
Flag of United States of America image

if you go to Tools -> Options and click on Tabs.. do you have a checkbox checked that says "when I open a new link, switch to it immediately"? Even though it's in the tabs area, it may apply to window'd browsing as well. Also, have you been using TweakXP on your machine? If you run that, sometimes it will change windows settings that helps prevent new windows from stealing focus.
Avatar of techport13
techport13

ASKER

Tried setting "switch to it immediately" then restarted FireFox.  No luck.

I did not install or run anything out of the ordinary (ie TweakXP, etc) prior to this issue beginning to occur.
hmm ok try this.

in your address bar, type: about:config and hit enter

This will show raw configuration for your browser. In the filter line, copy/paste this:

browser.tabs.loadDivertedInBackground

make sure that is set to false. If not, just double click on it and it should invert the true/false value. After that, restart firefox and see if that does it.

If that doesn't do it then I'm out of suggestions
More research:

If I have an existing Firefox window open and then use the Windows Run dialog to execute the following commands, here's what happens:

command - result

firefox - on top
firefox www.google.com - on top
www.google.com - below existing
I tried setting the browser.tabs.loadDivertedInBackground equal to false in the about:config.  It was already false, but I made it true then false again then restarted.

Still no luck.
I have also tried the fix detailed below, but that has not worked either.  This is a problem I am experiencing on both my home desktop and work laptop.  Both seem to have started around the same time, and I'm using firefox 3 at home, so I'm beginning to believe that this is a Windows issue more than a firefox issue, but still don't have any idea.

http://support.microsoft.com/kb/886217/en-us
ASKER CERTIFIED SOLUTION
Avatar of techport13
techport13

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial