Avatar of rregall1

asked on 

Unable to browse/ping over wireless on laptop, can browse/ping on wired connection

I'm working on a Latitude D531.  AMD TL-56 1GB ram, Windows XP SP2, Uses Cisco VPN client software
Wireless card is Dell 1390.  The driver version installed currently is from 10/12/2006.  The driver on the Dell support site is from 10/20/2006 and a few versions newer.  Thing is, when I download the new driver, the installer says that it can't find a compatible device for the drivers it contains.  Huh?  

Here's what's goin on:
- Can connect to the internet over wired router connection.  
- Cannot browse internet nor ping anything when connected to wireless connection.   <-- main problem
- Can connect to the router and get an IP address from the DHCP server.
- Can /refresh wireless and pull same IP
- Pulls down a different IP address after reinstalling wireless card. ( instead of .5 etc.)
- Cannot ping router or othe rmachines on network when connected wirelessly.
- All other laptops can browse over both wired and wireless.

The plot thickens:
- Everything worked fine until recently: Verizon Access Manager Software was uninstalled. VZ Access Manager was unfortunately installed to control both WWAN and WiFi connections instead of only WWAN.  It was used over a business trip weekend and the card was returned at the end of the weekend.  The software was uninstalled and the wireless connection no longer worked from that point on.  Worked fine before VZAM, doens't work at all after uninstalling it.

Things I've tried:
- I've uninstalled and reinstalled both wired and wirelss devices many times.
- I've reinstalled TCP/IP stack.
- I've attempted to update the driver for the wireless card.
- I've uninstalled Dell Wireless Config Utility
- I ran Windows Installer Cleanup to make sure everything from VZAM was gone, cleaned out some leftover Pantech drivers
- A deep scan with BitDefender didn't find any threats.
- Did a scan with X-Clean Micro, out of habit.  Found nothing to remove

Finally, for full disclosure and all:
- Every time I uninstall and reinstall wireless card, the unsigned software dialog prompt shows up for Deterministic Network Enhancer Miniport.  This is some sort of VPN connection enhancer?
- When I choose to "Install Software Anyway" for the Deterministic Network Enhancer Miniport, the wired connection stops working as well.
- Cannot connect with Cisco VPN client at all, period.  Over wired nor wireless.  Cisco VPN client launches and throws an error dialog that says "a VPN subsystem is unavailable so you cannot  connect to the VPN server."

What I'm going to do:
- Install XP SP3
- Keep working on updating driver for wireless card
- Run Dell hardware diagnostic when I remember the boot-up key combination... Fn+F11?  Fn+Alt+Ctrl+F5?  I don't remember :(   Praise his noodliness for Google...

What I'm thinkin...:
- Wireless card is going out. I think this because the wireless connection can pull down an IP address but can't communicate with anything.  I also think this because the updated driver software installer doesn't recognize the card as the same card the 1390 driver was previously working for just fine.
- VZ Access Manager somehow FUBARED the wireless connection to the point where reinstalling the TCP/IP stack and the card itself couldn't resolve the issue.  Don't know how this could happen... just guessin at this point.
- Computers hate me <-- most likely.

Just thought I'd throw this out there.  Any thoughts?
Laptops NotebooksWireless HardwareWindows XP

Avatar of undefined
Last Comment

8/22/2022 - Mon