UHLS
asked on
lost dhcp in cisco871
I have a new Cisco 871 running on IOS 12.4(15)T4. this router is connected to my ISP on fe4 and the LAN side is connected to fe2 to a switch. fe1 connects to a 2600 router which provides an alternate path to other isp. fe0 and fe3 are not connected.
the router does NAT and DHCP. the config is working to my satisfaction. My problem is when this router restarts, it lost the dhcp. sh run will not dispaly the dhcp section. I am 100% sure i have wri mem before power cycling it. indeed, whenever i power cycle the router, it only lost that dhcp session but not other config. at one point, i change the hostname and power cycle it and the new hostname stays but not the dhcp. after i put the dhcp section in, it works the way i want.
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname public253
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret 5
enable password 7
!
no aaa new-model
clock timezone PCTime -5
clock summer-time EDT date Mar 9 2008 2:00 Nov 2 2008 2:00
!
crypto pki trustpoint TP-self-signed-4227215515
enrollment selfsigned
ip-address name-server 151.198.0.38
subject-name cn=IOS-Self-Signed-Certifi cate-42272 15515
revocation-check none
rsakeypair TP-self-signed-4227215515
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool sdm-pool1
import all
network 192.168.35.0 255.255.255.0
domain-name bethpublic.org
default-router 192.168.35.253
dns-server 192.168.5.253 192.168.5.250
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip bootp server
ip domain name bethpublic.org
ip name-server 151.198.0.38
!
!
!
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
!
!
!
interface FastEthernet0
!
interface FastEthernet1
description uplink to 2600 router
duplex full
speed 10
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description Verizon FIOS 20M line
ip address x.x.x.y 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
speed 100
full-duplex
!
interface Vlan1
description BETH public network
ip address 192.168.35.253 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 71.244.113.1
ip route 192.168.0.0 255.255.0.0 192.168.35.254
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 102 interface FastEthernet4 overload
!
logging trap debugging
access-list 102 remark SDM_ACL Category=2
access-list 102 permit ip 192.168.35.0 0.0.0.255 any
access-list 102 permit ip 192.168.5.0 0.0.0.255 any
no cdp run
!
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
password 7
login
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end
the router does NAT and DHCP. the config is working to my satisfaction. My problem is when this router restarts, it lost the dhcp. sh run will not dispaly the dhcp section. I am 100% sure i have wri mem before power cycling it. indeed, whenever i power cycle the router, it only lost that dhcp session but not other config. at one point, i change the hostname and power cycle it and the new hostname stays but not the dhcp. after i put the dhcp section in, it works the way i want.
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname public253
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret 5
enable password 7
!
no aaa new-model
clock timezone PCTime -5
clock summer-time EDT date Mar 9 2008 2:00 Nov 2 2008 2:00
!
crypto pki trustpoint TP-self-signed-4227215515
enrollment selfsigned
ip-address name-server 151.198.0.38
subject-name cn=IOS-Self-Signed-Certifi
revocation-check none
rsakeypair TP-self-signed-4227215515
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool sdm-pool1
import all
network 192.168.35.0 255.255.255.0
domain-name bethpublic.org
default-router 192.168.35.253
dns-server 192.168.5.253 192.168.5.250
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip bootp server
ip domain name bethpublic.org
ip name-server 151.198.0.38
!
!
!
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
!
!
!
interface FastEthernet0
!
interface FastEthernet1
description uplink to 2600 router
duplex full
speed 10
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description Verizon FIOS 20M line
ip address x.x.x.y 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
speed 100
full-duplex
!
interface Vlan1
description BETH public network
ip address 192.168.35.253 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 71.244.113.1
ip route 192.168.0.0 255.255.0.0 192.168.35.254
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 102 interface FastEthernet4 overload
!
logging trap debugging
access-list 102 remark SDM_ACL Category=2
access-list 102 permit ip 192.168.35.0 0.0.0.255 any
access-list 102 permit ip 192.168.5.0 0.0.0.255 any
no cdp run
!
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
password 7
login
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end
Also, do a show ver and show file sys to ensure your have enough memory to save the config. An IOS upgrade would certainly be good too.
Good luck.
Good luck.
ASKER
Hi Folks,
thanks for the lead, I am in touch with Cisco see if it is hardware issue. i have never seen this before.
thanks for the lead, I am in touch with Cisco see if it is hardware issue. i have never seen this before.
Really strange. I mean, as long as your saving properly it should be good. I would say a memory issue, either size or corruption, but you did say that it saved the hostname change. that being said, who knows when the memory started having the issue. good luck, please post your finds, I'm definately interested.
ASKER
I update the IOS to later version which fixes the problem
ASKER
problems fixed by applying new version of IOS
ASKER CERTIFIED SOLUTION
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
ASKER
i don't think it is an IOS bug. I have other routers (same model) running the same release of IOS that does not demonstrate the same problem. this is the only one that I am aware of. Since upgrading the IOS fixed it, I don't plan to pursue why it did not work in the first place.
Well just FYI
I work with Cisco routers everyday
and everyday we see bugs
IOSs that work on one router wont necessarily show the bug on it, because this involves the hardware running, you can ask Cisco themselves :) and thats why they call it a BUG
I work with Cisco routers everyday
and everyday we see bugs
IOSs that work on one router wont necessarily show the bug on it, because this involves the hardware running, you can ask Cisco themselves :) and thats why they call it a BUG
my opinion is to try to upgrade your IOS
usually this stuff are IOS bugs
try using 12.4 17a