Avatar of Gizneek

asked on 

Server 2008 core, trying to join domain get error... "The network path was not found"

Trying to join a domain with server 2008 enterprise core running in VMware esx.  Command:  netdom join servername /domain:sub.domain.com /userd:domain\user /passwordd:*    
It asks me for the password then it fails with:  "The network path was not found", "The command failed to complete successfully"
I can ping other machines from this machine so I do not understand what is going on.  Help?
Windows Server 2008

Avatar of undefined
Last Comment
Avatar of Rajith Enchiparambil
Rajith Enchiparambil
Flag of United Kingdom of Great Britain and Northern Ireland image

Does the account that you are using have necessary rights to add a machine to the domain?

Avatar of Gizneek


yes, domain admin account.
Is the IP settings correct. Is the DNS properly pointed?
Avatar of Gizneek


Yes and yes.
Can you ping the 2003 DC?
Avatar of Gizneek


Avatar of dwarren0940
Flag of United States of America image

You need to make sure everything in the 08 server is open. Like Vista is comes out of the box locked down. Check (if you haven't) the firewall settings and such.
Avatar of Gizneek


ran netsh firewall set opmode mode=disable
then ran the commmand to join again and failed still with same errors...
Is your domain in 2003 native mode?

Check this article http://cameronfuller.spaces.live.com/Blog/cns!A231E4EB0417CB76!1331.entry
Avatar of Gizneek


Avatar of Proliant400

I had the same problem and it turned out to be a DNS problem. I spent various hours trying to fix the problem.

I was able to ping every computer on the network via the fully qualified name, the domain name to join etc. hence everything appeared to be OK. Anyway as soon as I typed

netdom join servername /domain:win2K8test /userd:Administrator /passwordd:*
I got a network path not found message.

I did the following to solve
1) Renamed the computer to the computer name I want  in the new domain.
   netdom renamecomputer <ComputerName> /NewName:<NewComputerName>
2) Manually entered a Hostname and IP for this computer on the DNS server (on the relevant Domain zone) for this name exists on the DNS server
3) Joined the Domain with the same command at point 1 and it worked

Also Make sure that the DNS zone is set to Secure and Non-Sicure on the dynamic update tabs.
The problem seems to be that if you run the netdom join domain manually it fails to create a DNS entry on the DNS server for the new computer. If you have the DNS entry already set (manually then it works). At least it has worked for me.

Avatar of 1intelsys

check your services for a service called NetBIOS TCP Helper or something similiar to that.  Make sure this is on automatic and started, then try to add to the domain.
Avatar of Gizneek

Blurred text
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Avatar of t_hewlett
Flag of Canada image

Tiss strange I have the same issue, using esxi 4 with one DC and a member server both running 2008 r2 enterprise.
The DC is hosting dns and dhcp and I run out of ideas so tried the gui and the machine is now joined tot he domain no issues....

BUT using the netdom join server2 /domain:contoso /userd:tt /passwordd:Password100 /ou:ou=computers,dn=contoso,dn=internal /reboot

Is this just affecting vmware users I wonder...

I will test again tomorrow and try the manual dns host entery...
Avatar of TFHDIT

I was receiving this error code and what I found the culprit to be was I had run the netdom rename command and then attempted to join to the domain. Once I rebooted it completed with no issues.
Avatar of Redded

No this is not limited to vmware, this is effecting hyper-v users too. Me!!
Core server only. net dom on a full server runs fine, as does the gui.
Windows Server 2008
Windows Server 2008

Windows Server 2008 and Windows Server 2008 R2, based on the Microsoft Vista codebase, is the last 32-bit server operating system released by Microsoft. It has a number of versions, including including Foundation, Standard, Enterprise, Datacenter, Web, HPC Server, Itanium and Storage; new features included server core installation and Hyper-V.

Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews


IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo