Link to home
Start Free TrialLog in
Avatar of oldmuttonhead
oldmuttonheadFlag for United States of America

asked on

Computer won't boot to anything, memory tests ok

I'm about to pull my hair out.

I have a system that I can't get to boot to anything.  It is an HP Pavilion a1130n.  When I attempt to boot to the hard drive, the XP boot screen comes up and almost immediately freezes.  

When I attempt to boot into safe mode, I get to where it loads gagp30kx.sys then it stops.  

When I attempt to boot into my Ultimate Boot CD for Windows, I get to almost the exact same point as I do when I boot to the hard drive.

When I attempt to boot into the XP recovery console, I get to the point where it says "Setup is starting Windows" and it freezes.

I booted into the MemTest86 on the UBCD and the memory tests fine.  Even after doing that I tried one stick at a time for the memory and still got the same results with the attempted boots as above.

I removed ALL hardware except memory, hard drive, and CPU and got the same results.

I removed ALL hardware except memory, CD-ROM, and CPU and got the same results.

EDIT: I also tested the power supply and it was fine.  

I have no idea what to do next.   Any ideas?
Avatar of VortexAdmin
VortexAdmin
Flag of United States of America image

Did you try testing hardware like the hard drive or drive controllers?  Some times there are problems with the motherboard or other hardware that can cause freezes.  It's possibly there's a hairline crack in a connection or something else unseen.  I have had the same problem with a Sony PC that started happening shortly after it was purchased.  I did the same type of traces and in the end, could find nothing.  I assume the PC is no longer under warranty.  You can follow this thread for my question for various suggestions on troubleshooting.  There's some worthwhile suggestions I learned from there that I could type but it would be eaiser to point you to them with this link.   In the end, my issue was never resolved and I gave the points to everyone that participated for trying to help. However, one of the suggestions might help fix your issue.

https://www.experts-exchange.com/questions/21947397/Sony-Vaio-desktop-PC-will-not-load-or-run-an-OS.html

Good luck!

VA
Avatar of Al Jee
If you have a "regular" XP installation CD you can do a "repair reinstall" of XP.

I do not believe the restore CD will work.

Boot from the CD
Choose "To setup Windows XP"  **Don't choose "To repair a Windows XP installation using the Recovery Console, press  R"

Select the XP installation you want to repair and start the repair.
Setup will copy the necessary files to the hard drive and reboot.  
Do not boot from the CD again.
Setup will continue as if it were doing a clean install, but your applications and settings will remain intact.
This should get your system back.




1) your hairs are priceless. Keep your hands far :)

Come back to your question i have a couple of ideas.

Seems all related to graphic card, and this is enforced by the fact that memtest is a character app.

I can see on specs that this pc have an integrated card.
If you installed another graphic card detach it and try again.

if not try  these:

First step: reset bios to default settings

Now try to boot with:

1) set memory aperture for agp to the smallest value
2) set memory aperture for agp to the highest value
3) set in the bios that graphic bus is set to internal as first try
4) try with an additional graphic card. An old pci card is enough to make this. Remember to set in bios that the graphic bus must be Agp or Pci depending on the additional graphic card.



ooh, a fellow ubcd4win fan : ) not a day goes by I dont use that thing at least twice.
@stoneg- his problem will have nothing to do with his hard drive at all.  Using the ubcd requires no hd in the pc at all... I highly recommend every person that comes in contact with a pc have one of these boot disks!

@oldmuttonhead- Have you given a close look to the capacitors on the motherboard, that and look for scorch marks or bubbles on any of the on-board chips... The capacitors should be flat on the top and not bulging out, and certainly not leaking, any sign of 'creeping crud' (yeah its a technical term as far as Im concerned) and your board is a goner.
Do a google image search for faulty capacitors if your not sure what bad ones look like.
Avatar of oldmuttonhead

ASKER

Sorry I'm just getting back to you.  Bad storms blew through here and my power has been out.  :/

@Vortex, Dart is correct.  I eliminated the hard drive as the source of the problem when I couldn't boot to my ubcd.  I even tried it with the drive disconnected.

@Stone, I'm a little leary on trying to do a repair install because I'm not sure what SP is installed on the system.  I may be at the point where it doesn't matter though..

@Point, I'll dig up a video card from my "graveyard of forgotten computers" and give that a shot.  

@Dart, I LOVE ubcd4win.  I use it all the time.  It's almost to the point where I don't even boot to the hard drive on a computer I'm troubleshooting very often.  I have visually inspected the motherboard.  I had the same thoughts you did.  I saw no physical defects on the board at all.  (Well... unless you count the "VIA" listed on one of the chips as a "defect", then it has one.)

So, from here I'm going to try a new video card and if that doesn't work I'll probably try the repair install, although if the RC won't even boot, I wonder if setup will boot?  

Thanks!
New video card made no difference.  Also, I thought about the repair install and I don't think it's a software issue because ubcd won't boot either.
Did you try to upgrade the Bios ?

Another try is to change hard disk and cdrom data cables. Detach the floppy data cable if present.

No, I did not try to upgrade the BIOS.  That is a good suggestion.  

If the bios upgrade doesnt work, all I have left is try swapping the processor into another motherboard and see if the symptoms follow, and if possible try another processor in this motherboard... it seems all other possibilities have been eliminated.
You might want to try this before upgrading the bios if possible, because if you hang up during the flashing, you may wipe out the board and never really know what the real problem was... well you could technically still find out, but at that point I guess it wouldnt matter much anyway lol.
Dart, I'd love to do that, but I have nothing else around that has an AMD Athlon.  I have approximately 3 million computers here that have all sorts of Intel processors, but no AMD.  I think the answer is becoming "it's either the processor or the motherboard" and leave it at that..
Ok.. this is ticking me off now..  the only BIOS upgrade for download from the HP website is a windows flash utility, which would be great if I could boot to windows.  :/
Well, BIOSs don't go bad by themselves, not very often they don't... Did you try a CMOS reset? Unless the computer has been "touched" by lightning, I doubt the BIOS itself is involved here.

Does the unit have a FDD controller? Can you try booting to DOS with a boot floppy?
/RID
rid:

No floppy in the system.  I do have a USB floppy though.  Although I did boot using the MemTest boot..
Like I said before, I had the same problem and ultimately it became "either the processor or the motherboard" and now I have a foot rest under my desk that looks like a Sony PC with all the hardware stripped out of it.  Many of these same suggestions were in the link I sent to when I had asked about it.  You might want to check through and see if there are any suggestions from that other question that you haven't tried, but other than that, it's probably in the board.
Well.. to add another twist to this sorry tale, it boots to Knoppix.  I've never used Knoppix before and on a scale from 1 to 10 I'm about a 4 when it comes to Linux.  Any ideas on what I might be able to do in Knoppix to check the status of the hardware?
That's funny, I was going to mention that I did the same thing and it worked in Knoppix as well. I didn't suggest it because you tried UBCD instead.  Mine works as well with Knoppix so don't know if that gives you any straight answers.  You could try formatting the drive and installing Linux to it if you don't care about the current drive.  There's got to be some tiny component that Linux doesn't access or something. Ultimately I ran a few tests and then stripped it for parts and moved on.
If this was my computer it would be in the deep end of my swimming pool right now..  :)

I just hate admitting defeat, but this computer has definitely defeated me.
can you boot into any other linux live cds (fedora,etc.)?  Im curious as to if there is something to what vortex mentioned about a component that linux might not access that a windows based would....
*gonna be up all night wondering about that*
On mine, I've booted up an Ubuntu Live CD a couple times without issue.  I was going to just load Linux on it permanently but I used the HD and some other parts in another system and didn't really need the extra PC laying around.  Plus, I needed the foot rest....
AHA!!  

When booting to Ubuntu LiveCD I get this several times:

[XXXXXXXXX] hub 3-0:1.0: hub_port_status failed (err = -32)
[XXXXXXXXX] hub 3-0:1.0: Cannot enable port 7. Maybe the USB cable is bad?
[XXXXXXXXX] ehci_hcd 0000:00:13.1: port 7 reset error -110

One other thing I didn't mention before is that the computer doesn't recognize my USB keyboard and mouse that are connected via a KVM switch, but that isn't too unusual for a computer to not see those but since I'm getting this error it makes me wonder..
Oh... on the previous comment "XXXXXXXXX" is a string of numbers that is different each time the error comes up.
Was doing a little more research on this and found that this is the board hp used... not exactly a solution, but having this info may help track down other reported issues/fixes.
Well you may have a little bit of an option here if your willing to risk it... as mentioned in the previous post your pc should be using an msi motherboard model 4802m2-IL....
I checked around on msi's site and of course there was no way of bring up docs and drivers for the model number as listed.... there is a RS482M2-IL/ L and there is a RS480M2... almost sounds like bad news until I looked closer and they seem to be identical (at least quick glance anyway... my eyes hurt atm).... the better news is that for the bios downloads, they both use the exact same file... so the only problem I see is if hp has done anything to the bios (besides tatooing) that might prevent or corrupt a standard msi flash.
If its something your willing to risk, you may first want to make sure the pc wont crash booting from a 98/me boot floppy.
Thanks, Dart.  I'm going to talk to the owner tomorrow and tell him where I'm at and if he's ok with me risking it, I'll probably try the new BIOS on the MSI site.  

Thanks!
No prob... just let me know how you make out one way or the other, for some reason this ones just been really rattling my brain... whats left of it anyway
ASKER CERTIFIED SOLUTION
Avatar of VortexAdmin
VortexAdmin
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thanks, guys.  I'm calling it dead and moving on.  :)  I'm still having nightmares though!