Avatar of ADX39655

asked on 

How can I enable NFSv3 over TCP?


I am trying to setup a SAN attached to a Red Hat 9 server to be used with ESX as an NFS datastore.  I beleive I have everything setup correctly on the linux box so that the /datastore folder is mounted on the SAN, and shared correctly via the /etc/exports file.  When I mount the share from other linux boxes everything works as it should; however, when I try and add the shared space in ESX 3.02 I get an error message telling me it was unable to be mounted as the NFS server did not support NFS over TCP.  I am using a dated copy of RedHat but I had no luck installing more current versions on my PowerEdge 2450 for some reason.  I am a complete linux newb and have been working a lot more with Debian based systems.  I thought I'd give Red Hat a shot as it seems more popular among the server crowd but I have gone from a world of apt-get to a world of rpm's and yum which I am unfamiliar with.  If anyone could either inform me how to use my exisitng NFS server software to work with ESX's requirement or provide some detailed instruction on how to upgrade the NFS server I would appreciate it.  I have already tried to yum install nfs-utils; but I still received the same error on ESX.  
Linux DistributionsVMware

Avatar of undefined
Last Comment

8/22/2022 - Mon