Link to home
Start Free TrialLog in
Avatar of astasolutions
astasolutions

asked on

Unable to send emails to a particular domain

Hi,

In brief - we are having some trouble sending emails to a particular domain, and the messages remain in the queue with specific error messages.

The bounce message we get via email contains some generic info and the main message is:
#550 4.4.7 QUEUE.Expired; message expired ##

In the Exchange message queues - the messages appear with the following error message:

'421 4.4.1 Connection timed out. Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

What I have checked so far:

- Our firewall is open and not set to block SMTP traffic
- I can successfully telnet to the recipient domains mail server on port 25 and nslookup returns the normal information
- I have checked configs in Exchange 07 and don't really see any discrepancies but may have missed something of course
- We are not on any blacklists and MX records are ok - I can also resolve recipient MX record
- Have checked with the recipient end about their configuration and they say we are the only ones having an issue sending to them.
- We don't experience this issue with other recipients
- Attempted to add the recipient domain name to Accepted domains in EMC - no success

If anyone could shed some light on this that would be great - Thanks!

SOLUTION
Avatar of Philip Elder
Philip Elder
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of astasolutions
astasolutions

ASKER

All telnet tests were indeed performed from the Exchange server.

This is the bounce message we get via email:

Diagnostic information for administrators:
 
Generating server: A*****-EXCHANGE.****.local
 
h*****@*****.com
#550 4.4.7 QUEUE.Expired; message expired ##
 
Original message headers:
 
Received: from A****-******* ([192.168.10.222]) by  A*****-******** ([192.168.10.222]) with mapi; Tue, 22 Jul 2008
 10:43:52 +1000
From: Amber ****
To: "h*****@******.com"
Date: Tue, 22 Jul 2008 10:43:50 +1000
Subject: Test
Thread-Topic: Test
Thread-Index: AcjrlAJ/Ag2y/F3rRVKH8oigZ7I2RA==
Message-ID:
Accept-Language: en-US, en-AU
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: en-US, en-AU
Content-Type: multipart/related;
        boundary="_005_AA6A24406CE6E84AAD5B2865B2814AC80F20C75BA7A***EXCHANGE_";
        type="multipart/alternative"
MIME-Version: 1.0

And in queue in EMC - I can see the message stuck there with error message:

421 4.4.1 Connection timed out. Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial