Avatar of David Schmalzer
David Schmalzer
Flag for United States of America

asked on 

Site to Site Tunnel - Help

I have a main site using an Cisco ASA 5505 and a remote site using a Cisco Pix 506e. I need to create a site to site tunnel between the two. I have no idea how to do this. I tried the wizards but I didn't understand everything they were asking and i couldn't get it to work. I kept losing my internet connection. At the main site which will call Site1, we have a cisco 2800 router connected to a T1 line, then the lan switches and the ASA5505. On the remote site which we'll call Site2, I have a DSL line (With a block of 5 public IP addresses), a westell modem which is then connected into the pix506e . The Site1 already has some existing tunnels for other sites which are working fine. I just need to get the pix506e connected so I need to know step by step what to do at each end. I do not know command line too well.  Below are the configurations: I blocked out important ip's.

Site1:
-------
 : Saved
:
ASA Version 7.2(2)
!
hostname MyHostName1
domain-name MyDomain1.com
enable password 2KFQnbNIdI.2KYOU encrypted
names
name 7.127.252.57 hlx_citrix01
name 192.xxx.xxx.92 Mexxxxxxxxx
name 205.xxx.xxx.99 Staxxxxxxxx
name 205.xxx.xxx.81 NAH-Axxxxxx
name 205.xxx.xxx.95 NAH_Txxxxxx
name 205.xxx.xxx.0 NAHxxxxxxxxx
name 10.xxx.xxx.0 yoxxxxx
name 10.xxx.xxx.0 Stewxxxxx
name 10.xxx.xxx.0 Greenxxxxx
name 10.xxx.xxx.0 Manchxxxxx
name 10.xxx.xxx.0 Shrexxxxxx
name 10.xxx.xxx.0 Sitexxxxxx
name 10.xxx.xxx.0 TSxxxxx
name 10.xxx.xxx.0 Susxxxxxxxxxxxx
name 10.xxx.xxx.53 NAH2xxxxxxxx
name 151.xxx.xxx.74 Caroxxxxxx
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.109.10 255.255.255.0
 ospf cost 10
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 12.xxx.xxx.162 255.255.255.240
 ospf cost 10
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
 domain-name mcbllc.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list in-out extended permit ip any any
access-list out-in extended permit tcp any host 12.xxx.xxx.163 eq telnet
access-list out-in extended permit tcp any host 12.xxx.xxx.163 eq ssh
access-list out-in extended permit tcp any host 12.xxx.xxx.166 eq ftp-data
access-list out-in extended permit tcp any host 12.xxx.xxx.166 eq ftp
access-list out-in extended permit tcp any host 12.xxx.xxx.165
access-list out-in extended permit esp any host 12.xxx.xxx.167
access-list out-in extended permit ip any host 12.xxx.xxx.164
access-list out-in extended permit icmp any any echo-reply
access-list out-in extended permit icmp any any unreachable
access-list out-in extended permit icmp any any time-exceeded
access-list out-in extended permit ip any host 12.xxx.xxx.168
access-list out-in extended permit ip any host 12.xxx.xxx.170
access-list outside_cryptomap_10 extended permit ip host 12.xxx.xxx.164 host hlx_xxxxix01
access-list inside_outbound_nat0_acl extended permit ip any 192.168.110.0 255.255.255.224
access-list inside_outbound_nat0_acl extended permit ip 192.168.109.0 255.255.255.0 NAH 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any york1 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any Stewartstown 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any Greensprings 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any Shrewsbury 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any Manchester 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any TSI 255.255.0.0
access-list inside_outbound_nat0_acl extended permit ip any SusquehannaTrail 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip 192.168.109.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip any host NAH2
access-list inside_outbound_nat0_acl extended permit ip host 12.xxx.xxx.162 host 70.xxx.xxx.2
access-list inside_outbound_nat0_acl extended permit ip any host 151.xxx.xxx.75
access-list inside_outbound_nat0_acl extended permit ip any host Cxxxxxxxye
access-list outside_cryptomap_dyn_20 extended permit ip any 192.168.110.0 255.255.255.224
access-list outside_cryptomap_30 extended permit ip 192.168.109.0 255.255.255.0 NAH 255.255.255.0
access-list outside_cryptomap_50 extended permit ip any york1 255.255.255.0
access-list outside_cryptomap_70 extended permit ip any Stewartstown 255.255.255.0
access-list outside_cryptomap_90 extended permit ip any Greensprings 255.255.255.0
access-list outside_cryptomap_170 extended permit ip any Manchester 255.255.255.0
access-list outside_cryptomap_130 extended permit ip any Shrewsbury 255.255.255.0
access-list outside_cryptomap_190 extended permit ip any TSI 255.255.0.0
access-list outside_cryptomap_210 extended permit ip any SusquehannaTrail 255.255.255.0
access-list outside_cryptomap_11 extended permit ip host 12.176.25.168 host hlx_citrix01
access-list outside_250_cryptomap extended permit ip 192.168.109.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list outside_270_cryptomap extended permit ip host 12.176.25.162 host 70.22.63.2
access-list outside_310_cryptomap extended permit ip any host CarxxxxxxEye
pager lines 24
logging timestamp
logging standby
logging console debugging
logging monitor errors
logging buffered notifications
logging trap notifications
logging history debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN-Pool 192.168.110.1-192.168.110.25
ip verify reverse-path interface outside
no failover
monitor-interface inside
monitor-interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 12.xxx.xxx.168 netmask 255.0.0.0
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 12.xxx.xxx.167 192.168.109.107 netmask 255.255.255.255
static (inside,outside) 12.xxx.xxx.166 192.168.109.125 netmask 255.255.255.255
static (inside,outside) 12.xxx.xxx.163 192.168.109.9 netmask 255.255.255.255
static (inside,outside) 12.xxx.xxx.165 192.168.109.140 netmask 255.255.255.255
static (inside,outside) 12.xxx.xxx.170 192.168.109.5 netmask 255.255.255.255
access-group out-in in interface outside
route outside 0.0.0.0 0.0.0.0 12.xxx.xxx.161 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry citrix
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
group-policy mcbllc internal
group-policy mcbllc attributes
 dns-server value 216.xxx.xxx.2 216.xxx.xxx.2
 vpn-idle-timeout 30
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value inside_outbound_nat0_acl
username lichtenstein password UG1bxDY9Wg0R40rf encrypted
username ofcstaff password 1jXE/9jS32puwt7A encrypted
username rkhan password kQ/GODF/q0SaXxXX encrypted privilege 15
username leslie password 9p7LkZJh8kCMTfyC encrypted privilege 15
username akafaji password ijnXaZRexiJr0TWx encrypted
username rick password ReLDd3rSDL6e4bqH encrypted privilege 15
username mrice password SB9vMhVmgJ7farIH encrypted
http server enable
http 192.168.109.0 255.255.255.0 inside
http 71.xxx.xxx.23 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set myset
crypto map mymap 10 match address outside_cryptomap_10
crypto map mymap 10 set peer 198.xxx.xxx.28
crypto map mymap 10 set transform-set myset
crypto map mymap 11 match address outside_cryptomap_11
crypto map mymap 11 set peer 198.xxx.xxx.28
crypto map mymap 11 set transform-set myset
crypto map mymap 30 match address outside_cryptomap_30
crypto map mymap 30 set peer 65.xxx.xxx.5
crypto map mymap 30 set transform-set myset ESP-3DES-MD5
crypto map mymap 50 match address outside_cryptomap_50
crypto map mymap 50 set peer 64.xxx.xxx.130
crypto map mymap 50 set transform-set myset
crypto map mymap 70 match address outside_cryptomap_70
crypto map mymap 70 set peer 209.xxx.xxx.130
crypto map mymap 70 set transform-set myset
crypto map mymap 90 match address outside_cryptomap_90
crypto map mymap 90 set peer 74.xxx.xxx.177
crypto map mymap 90 set transform-set myset
crypto map mymap 130 match address outside_cryptomap_130
crypto map mymap 130 set peer 71.xxx.xxx.172
crypto map mymap 130 set transform-set myset
crypto map mymap 170 match address outside_cryptomap_170
crypto map mymap 170 set peer 74.xxx.xxx.137
crypto map mymap 170 set transform-set myset
crypto map mymap 190 match address outside_cryptomap_190
crypto map mymap 190 set peer 68.xxx.xxx.194
crypto map mymap 190 set transform-set myset
crypto map mymap 210 match address outside_cryptomap_210
crypto map mymap 210 set peer 75.xxx.xxx.173
crypto map mymap 210 set transform-set myset
crypto map mymap 250 match address outside_250_cryptomap
crypto map mymap 250 set pfs
crypto map mymap 250 set peer 12.xxx.xxx.130
crypto map mymap 250 set transform-set ESP-3DES-SHA
crypto map mymap 270 match address outside_270_cryptomap
crypto map mymap 270 set pfs
crypto map mymap 270 set peer 70.xxx.xxx.2
crypto map mymap 270 set transform-set ESP-3DES-SHA
crypto map mymap 290 set pfs
crypto map mymap 290 set peer 151.xxx.xxx.75
crypto map mymap 290 set transform-set ESP-3DES-SHA
crypto map mymap 310 match address outside_310_cryptomap
crypto map mymap 310 set pfs
crypto map mymap 310 set peer CarollEye
crypto map mymap 310 set transform-set ESP-3DES-SHA
crypto map mymap 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map mymap interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group mcbllc type ipsec-ra
tunnel-group mcbllc general-attributes
 address-pool VPN-Pool
 default-group-policy mcbllc
tunnel-group mcbllc ipsec-attributes
 pre-shared-key *
tunnel-group 198.xxx.xxx.28 type ipsec-l2l
tunnel-group 198.xxx.xxx.28 ipsec-attributes
 pre-shared-key *
tunnel-group 65.xxx.xxx.5 type ipsec-l2l
tunnel-group 65.xxx.xxx.5 ipsec-attributes
 pre-shared-key *
tunnel-group 64.xxx.xxx.130 type ipsec-l2l
tunnel-group 64.xxx.xxx.130 ipsec-attributes
 pre-shared-key *
tunnel-group 209.xxx.xxx.130 type ipsec-l2l
tunnel-group 209.xxx.xxx.130 ipsec-attributes
 pre-shared-key *
tunnel-group 74.xxx.xxx.177 type ipsec-l2l
tunnel-group 74.xxx.xxx.177 ipsec-attributes
 pre-shared-key *
tunnel-group 71.xxx.xxx.131 type ipsec-l2l
tunnel-group 74.xxx.xxx.137 type ipsec-l2l
tunnel-group 74.xxx.xxx.137 ipsec-attributes
 pre-shared-key *
tunnel-group 68.xxx.xxx.194 type ipsec-l2l
tunnel-group 68.xxx.xxx.194 ipsec-attributes
 pre-shared-key *
tunnel-group 24.xxx.xxx.30 type ipsec-l2l
tunnel-group 24.xxx.xxx.30 ipsec-attributes
 pre-shared-key *
tunnel-group 12.xxx.xxx.146 type ipsec-l2l
tunnel-group 75.xxx.xxx.173 type ipsec-l2l
tunnel-group 75.xxx.xxx.173 ipsec-attributes
 pre-shared-key *
tunnel-group 71.xxx.xxx.172 type ipsec-l2l
tunnel-group 71.xxx.xxx.172 ipsec-attributes
 pre-shared-key *
tunnel-group 12.xxx.xxx.130 type ipsec-l2l
tunnel-group 12.xxx.xxx.130 ipsec-attributes
 pre-shared-key *
tunnel-group 70.xxx.xxx.2 type ipsec-l2l
tunnel-group 70.xxx.xxx.2 ipsec-attributes
 pre-shared-key *
tunnel-group 151.xxx.xxx.75 type ipsec-l2l
tunnel-group 151.xxx.xxx.75 ipsec-attributes
 pre-shared-key *
tunnel-group 151.xxx.xxx.74 type ipsec-l2l
tunnel-group 151.xxx.xxx.74 ipsec-attributes
 pre-shared-key *
telnet 192.168.109.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.109.0 255.255.255.0 inside
ssh 71.179.126.23 255.255.255.255 outside
ssh timeout 5
console timeout 0
dhcpd address 192.168.109.11-192.168.109.100 inside
dhcpd dns 12.xxx.xxx.68 12.xxx.xxx.72 interface inside
dhcpd lease 259200 interface inside
dhcpd domain mcxxxxc.com interface inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:387596749b83c707638f15a9bb74fb65
: end
asdm image disk0:/asdm-522.bin
no asdm history enable



Site2:
------
Building configuration...
: Saved
:
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password wmBJ6LNXJIOG32gm encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname MyHostName2
domain-name MyDomain2.com
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 151.xxx.xxx.xxx 255.255.255.0
ip address inside 192.168.1.10 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 151.xxx.xxx.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.100-192.168.1.254 inside
dhcpd dns 71.xxx.xxx.one 71.xxx.xxx.two
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:59c29da3bff131a9ce3cfeb151f5b60c
: end
[OK]

CiscoVPNSoftware Firewalls

Avatar of undefined
Last Comment
David Schmalzer

8/22/2022 - Mon