Link to home
Avatar of eMicros
eMicros

asked on

Please help with correct configuration of SMTP authentication in Exchange 2003

Hi

My sbs2003 server is on so many blacklists its clear it has been working as an open relay for some time.
I have been through all the KB articles I can find and as far as i can ascertain, i've done everything required.  However, I can still connect to my server from another computer (a mac) and send mail through SMTP without any authentication and it sends it quite happily.  This may be because the mac sits on the same network so it trusts the IP, I'm not sure.  One thing I have found though is that if i turn off accepting anonymous connections, it forces the email client to have to authenticate which is great, but then not only can no-one use my server to relay email, but i can't receive anything either!

I need some help to get this configuration nailed down properly.

Thanks
eMicros
Avatar of BBRazz
BBRazz
Flag of United Kingdom of Great Britain and Northern Ireland image

If you go to the properties of your Default SMTP Virtual Server and look at the access settings.

Under Authentication, Anon needs to be selected to "Receive Email" and Basic and Integrated should also be selected.

Under Connection, select "only the list below" and remove all entries, including the server itself and your local network.

Exchange users will be authenticated in the next step.

Uner Relay Restrictions, select Only the List below and again remove ALL entries and tick "Allow all computers which sucessfully authenticate to relay, regardless of the list above".

This way, the only users able to send emails are local, authorized users and the exchange server itself, but you will be able to recieve without issue.

Regards,
Martin
Once you complete the above, test yourself on the link below.
http://www.abuse.net/relay.html
Avatar of eMicros
eMicros

ASKER

Thanks BBRazz.

I made the changes you made and then i could no longer send or receive. I changed the settings back, except for adding in the list of ip addresses i had cleared (i hadnt noted what they were), and i can once again send and receive.  Problem is, that abuse.net link you told me about reports i'm an open relay.

Need better instructions :(

This is what i've done

>If you go to the properties of your Default SMTP Virtual Server and look at the access settings.

>Under Authentication, Anon needs to be selected to "Receive Email" and Basic and Integrated should also be selected. YES. Also ticked "resolve anonymous"

>Under Connection, select "only the list below" and remove all entries, including the server itself and your local network.. NO - have had to select "all but the list below" - the list is empty.

>Uner Relay Restrictions, select Only the List below and again remove ALL entries and tick "Allow all computers which sucessfully authenticate to relay, regardless of the list above". NO - have selected "all except list below"


The connection and Relay Restrictions are why you are an open relay.

I have checked 8/9 of the deployed 2003 Exch under my control and checked a few things.

Set both to only the list below, and add the local IP of the server and 127.0.0.1
Avatar of eMicros

ASKER

if i change connection control to the settings you recommend, i cannot receive any external email
Can you try disabling the Default SMTP Virtual Server and creating another with Standard Defaults?

WIth that enabled does mail flow?
Avatar of eMicros

ASKER

No, but then I may have done it incorrectly ...

I couldnt work oput how to disable the default server, so stopped it and tried to create another, but that wouldn't let me create same with defaults as it ealready exists on port 25.  I tried changing the ip address from "all unassigned" to the server ip, but i couldnt get mail flowing either direction.

Driving me mad this is :)
eMicros,
    Can you contact me via email and I will help further.

-BBRazz
Avatar of eMicros

ASKER

where do i get that from? cant see it in your profile
Never Mind. Lets move forward here.
Avatar of eMicros

ASKER

Agreed, would rather resolve through this forum if you don't mind.  
Avatar of eMicros

ASKER

Is there  any way I can see what is being relayed via my server? I can no longer send emails to btinternet, btconnect or hotmail via my server due to the level of spam that is going through it, but it is all invisible to me.  And any restrictions i try to implement just serve to prvent me from sending anything also.

Need some help pretty fast please! Can anybody help me with the necessary settings?
Avatar of eMicros

ASKER

listed on spamhaus.org too, so theres a load of commercial email i can no longer send either.  I need help to prevent this relaying asap , then i'm guessing i can fix it with an ip change - hope so anyway.
Avatar of eMicros

ASKER

Anybody? Is there nobody other than BBRaz who knows the correct settings for exchange.  Believe me I've googled and tried a number of things but any restrictions just prevent me from sending email too.

Please assist
ASKER CERTIFIED SOLUTION
Avatar of BBRazz
BBRazz
Flag of United Kingdom of Great Britain and Northern Ireland image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Avatar of eMicros

ASKER

will check it out and get back to you.

thanks bbrazz
Avatar of eMicros

ASKER

I made the changes you suggested and got in touch with my provider (BT) to setup reverse dns record as per the following link :

http://btbusiness.custhelp.com/cgi-bin/btbusiness.cfg/php/enduser/cci/bt_adp.php?p_sid=UFWugqdj&cat_lvl1=368&cat_lvl2=953&cat_lvl3=1212&cat_lvl4=1217&p_cv=4.1217&p_cats=368,953,1212,1217&p_faqid=8763

... haven't had any problems since doing this, so presumably its all good now.  Thanks for your help!

eMicros
Avatar of eMicros

ASKER

Cheers martin