Link to home
Start Free TrialLog in
Avatar of inteq
inteq

asked on

Cisco Router script to 3 Com router

Hi Experts,

Currently, we are using Cisco 1721router in a network and we need to change our router to 3com 5012 router. We are pretty new to 3com routers. Can any experts help us convert existing cisco router script to 3 com 5012? Or a step by step guide line to get Internet connection on 3 com router with featues as close as possible to existing cisco router.

Thank you for quick responses!

version 12.3
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service udp-small-servers
service tcp-small-servers
service sequence-numbers
!
hostname Cisco-1721
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$ZlbR$7OmjyZDdmeO8ojjc2Bm7
!
username user privilege 15 secret 5 $1$ieid$G49e.OZ53MaFaHc7omc3
username user1 password 7 131516000A080D2
clock timezone PCTime 8
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip gratuitous-arps
ip cef
!
!
ip finger
ip tcp synwait-time 10
!
ip domain name example.com
ip name-server 165.21.*.*
ip name-server 165.21.*.*
no ftp-server write-enable
!
!
!
!
interface Ethernet0
 description $ES_WAN$$FW_OUTSIDE$
 ip address *.*.68.150 255.255.255.252
 ip mask-reply
 ip directed-broadcast
 ip nat outside
 full-duplex
 no cdp enable
!
interface FastEthernet0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-10/100 Ethernet$$ES_LAN$$FW_INSI
DE$
 ip address *.*.127.209 255.255.255.248
 ip mask-reply
 ip directed-broadcast
 ip nat inside
 speed 100
 full-duplex
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 *.*.68.149
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
logging trap debugging
access-list 100 permit ip any any
access-list 100 permit tcp any any
access-list 100 permit udp any any
access-list 100 permit icmp any any echo-reply
access-list 100 permit esp any any
access-list 100 permit tcp any any eq telnet
no cdp run
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 password 7 021605490A02062641
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 4000 1000
scheduler interval 500
!
end

Open in new window

ASKER CERTIFIED SOLUTION
Avatar of bkepford
bkepford
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of inteq
inteq

ASKER

Hi BkepFord,

Thanks for quick reply. I took your advice and tried configuring the router. But I am not 100% sure it'd work or not, so can you please look at below 3com scrip and let me know if i missed out anything.?

Thanks!

#
#3Com Router Software V3.12
#
 sysname 3COMM
#
 super password level 3 simple <password>
#
 configure-user count  2
#
 cpu-usage cycle 1min
#
 web set-package force flash:/http.zip
#
radius scheme system
#
domain system 
#
local-user User
 password simple <password>
 service-type telnet terminal
 level 3
 service-type ftp
#
interface Aux0
 async mode flow
#
interface Ethernet0/0
 duplex full
 ip address *.*.127.209 255.255.255.248 
#
interface Ethernet2/0
 duplex full
 ip address *.*.68.150 255.255.255.252 
#
interface Serial0/0
 clock DTECLK1
 link-protocol ppp
 ip address dhcp-alloc
#
interface NULL0
#
 FTP server enable
#
 ip route-static 0.0.0.0 0.0.0.0 *.*.68.149 preference 60
#
user-interface con 0
user-interface aux 0
user-interface vty 0
 user privilege level 3
 set authentication password simple <password>
 protocol inbound telnet
user-interface vty 1 4
 authentication-mode scheme 
#
return

Open in new window

Everything looks good. your interfaces match the router settings except it looks like you added a serial on the 3com.
From what I see it looks like it should work fine.