Link to home
Start Free TrialLog in
Avatar of nigelbeatson
nigelbeatsonFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Our server network card keeps reporting that the cable has been disconnected.

we have a single microsoft small business 2003 server with a single network card connecting it to our local switch. We keep getting a reported error that the cable has been disconnected, and of course no one can access the server.
We have tested the cable connections and they are all fine.
Just by chance we found that id we run the reset the server IP address wizard, and jus ener the same IP address to change to, it actually resolves the issue. However, we did this about a week ago, and the same thing has just happened again. The same reset IP address wizard resolved the problem straight away.
Does anyone have any suggestions as to what is going on, and how we can stop this from happening? We have already ordered a second matching network card to team them togethr to provide us with redundancy in this area, but I am a little concerned that this problem keeps appearing.
Avatar of Nitin Gupta
Nitin Gupta
Flag of United Kingdom of Great Britain and Northern Ireland image

Hi Nigel,
Did you verify the Switch Port that your server is connected to. Try changing that.
Also the Patch Cable itself
Thanks
Nitin
Also look at the Switch Logs, I am not sure what make is it, maybe it could throw some light.....!
ASKER CERTIFIED SOLUTION
Avatar of Rob Williams
Rob Williams
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
One other thought; you said you tested the wiring. How? 80% of network issues are due to bad cabling. A cable can look good and test OK with a basic continuity tester but fail when tested with a network certification meter. These units run about $8000 but any good cable installer has one and can test for you and provide a full certification report.
Avatar of nigelbeatson

ASKER

we currently have on board our server the intel pro 1000 nic. we have looked at the power options, but unlike other network cards we have looked at, it does not simply have an option to dissable the power management.
we have things like :-

Power Saver Options :-
reduce speed to save power
reduce link speed during standby

Wake on LAN :-
Wake on directed packet
wake on magic packet
wake on magic packet on power off state
wake on link

These can all be selected or unselected but it was not clear to me which we should use, if any.

Any  ideas?
oh, i forgot to add that the $8000 dollars is a little rich for our blood! you are right we have just tested the cable with a basic continuity tester. however we have tried different cables from connections that we know to be working. in addition I am a little confused as to why reseting the server ip address would resolve a cable error? please advise.
we have tried a different port on our switch, swapping it with a connection that we know to be working, but only the resetting of the ip address seems to work.
Not all have the power options, though most Intels do.
I would disable both:
Power Saver Options :-
reduce speed to save power
reduce link speed during standby

The WOL settings should not affect it unless your sever is configured to go into standby mode, but that would be very unusual. (see power management in Control panel)

You could also try turning off autonegotiation on the server and also on the switch.  Occasionally that messes with things.  When you get the new card, I would try swapping the existing one out with that first as a hardware test as it could be a flakey NIC.  If you have not done so already, I would also check for driver updates.

The last thing may sound a little weird, but make sure that there are not any sources for electrostatic interference near the cable - this includes neon or flourescent lighting, strong magnets (including speakers), power runs, motors, etc.  If it crosses a ceiling light in parallel that could be a problem, if you can change it so it is not within a couple of feet and/or run perpendicular to the light.  If it is 'kinda close' to one of these it could cause an occasional problem due to buildup or spikes in the interference.
We are coming to the conclusion that we have a faulty network card. We have now replaced this, and awaiting developments. Will keep everyone informed. Thanks.
Sounds good, let us know how it goes.

I had missed one of your posts earlier:
>>"oh, i forgot to add that the $8000 dollars is a little rich for our blood!"
Yes  :-)  I was suggesting calling a cabling company with one. They will usually charge about $50 for 1 network drop, or buy the hour for multiples. Some software vendors will not install their software until you have had the entire network certified.

>>"I am a little confused as to why reseting the server ip address would resolve a cable error?"
Sometimes with a flaky connection, for whatever reason, a NIC will decide it is a bad link and stop trying to use it. Running the wizard or right clicking and choosing repair forces it to try again.
Replaced NIC- OK now - many thanks