We help IT Professionals succeed at work.

Sybase ct_connect error

3,444 Views
Last Modified: 2013-11-15
I just installed ASE 15.0.2 on Linux, and created an "interfaces" file with two server entries in it:
CHI_IRPTRACKER_PRD
        query tcp ether 171.188.69.123 50000
        master tcp ether 171.188.69.123 50000

CHI_IRPTRACKER_DEV
        query tcp ether 171.188.119.39 50000
        master tcp ether 171.188.119.39 50000

However, when I try to run isql with the following command, it gave me the error:
ct_connect(): directory service layer: internal directory control layer error: Requested server name not found.

The "isql" command I was using:
isql -S CHI_IRPTRACKER_DEV -U trackerUpdate -P sybase -I "/opt/sybase/interfaces"

Sybase is installed in directory "/opt/sybase", and I have two env. variables defined:
SYBASE=/opt/sybase
SYBASE_OCS=OCS-15_0

What could have caused this problem? Is there a debug flag to show more detailed information for either "isql" or the "ct" library?

Thanks
Comment
Watch Question

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks for the information.

I don't see ENV.sh in "/opt/sybase" and I am using bash shell. Those two ASE servers defined in the interfaces file are running on separate Solaris machines and out of my control. I don't have ASE configured on the Linux and only want to be able to run isql to connect to those remote ASEs.

I am also confused by the ct error message. Does it mean the ct library is having trouble to find the definition of server "CHI_IRPTRACKER_DEV", or it is having trouble to connect to that server?
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I do have the whole ASE package installed, for the reason you mentioned.

After executing "SYBASE.sh", run isql still gave me the same error.

Is there a way to turn on some debug or trace information of the open client or "ct" library?
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I fixed the problem, even though not sure what caused the problem exactly.

I just manually typed a separate copy of the interfaces file with vi, and it worked. Not sure what was wrong with the first one, as I also opened it with vi but didn't see anything wrong.

Thanks again. I appreciate your help.

Commented:
If you created the file on Windows and them FTPed it to Linux, you will have CR/LF line terminators when you really only want LF terminators.  That confuses a lot of Linux programs.  There is a utility, DOS2UNIX that strips the CRs for you.

Just a thought.
Bill

Author

Commented:
I thought about that, and opened the file with vi but didn't find any ^M which used to be the culprit.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.