Link to home
Start Free TrialLog in
Avatar of GFCU
GFCUFlag for United States of America

asked on

Internet Explorer Trusted Sites

I would like to know if it is possible to add sites to the trusted sites on workstations through group policy.  If so, how?  I tried going to User Configuration>Windows Settings>Internet Explorer Maintenance>Security>Security Zones and Content Ratings, properties, under the security zones and privacy section, import the current security zones and privacy settings, modify settings, trusted sites, sites, and added sites.  And that did not work for the test OU that I was using and for the default domain ou.
Avatar of tigermatt
tigermatt
Flag of United Kingdom of Great Britain and Northern Ireland image

Yes, there's a policy sitting there to do exactly what you want. It's location and how to use it is detailed at http://windowsitpro.com/article/articleid/78049/jsi-tip-6644-how-can-i-use-group-policy-to-add-a-site-to-the-trusted-sites-zone.html.

-tigermatt
Avatar of GFCU

ASKER

I had tried this previously and then ran a gpupdate /force on the client computer and this didn't add any sites.  Any thoughts?  Is there some thing that I may be doing wrong?  I did these configurations in a test ou that contains the test user account used to login.  (all within the same domain)
First, let's check to see if the policy is even being applied. Open a command prompt and type rsop.msc, browse to the location of the policy the MMC window and see if it is configured.

That will give us a starting point for troubleshooting.

-tigermatt
Avatar of GFCU

ASKER

The results are greyed out when I go to that "Security Zones and Content Ratings "dialog box and the radio button IS selected where it says "Do not customize security zones and privacy.  I went to the next tab (Security Zones Precedence) and It said "GPO's higher in the list have the highest priority"  And there were two GPO's listed above that, my main policy and the default domain policy.  And as I said before, I made these same modifications in the default domain policy that is enforced and then I did a gpupdate /force to force the update and still I had no sites.  Do all of the GPO's have to be configured in the same way?
ASKER CERTIFIED SOLUTION
Avatar of tigermatt
tigermatt
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of GFCU

ASKER

I don't have the "Site to Zone assignment list" policy under the Internet Control Panel.  See the attached file
Internet-Control-Panel.doc
So you don't have the ones which I've indicated in the attachment below? What machine are you doing this from, what OS & Service Pack is it running, and which version of Internet Explorer?

-tigermatt
ie.JPG
Avatar of GFCU

ASKER

No, I do not.  (See screenshot)  I am doing this from the DC.  Windows Server 2003.  I am not running Service Pack 2 yet.  I am in the process of creating backups (for all of my servers that need it)  prior to doing that as we speak.  I am running IE 6.0 on the DC.  The majority of clients have ie 7 but some still have 6.  I assume that I need to update ie to 7 and install sp2?
gp.JPG
That's unusual - thanks for clarifying with the screenshot.

Unfortunately all our DCs are currently running IE7, so I can't check whether that policy isn't present when IE6 is installed. If you could upgrade to IE7, check again, and if not, upgrade to SP2, and then do another check.

Also, have you looked in other policies, just to make sure it's not a problem whereby it doesn't exist in this one.

-tigermatt
Avatar of GFCU

ASKER

Do you mean other policies in a different ou?
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of GFCU

ASKER

That worked!!  The test ou that I was using didn't have the full capability to do this function.  I don't know why, but it's working now.  Thank you very much for your help.
Thanks, you're welcome!