Avatar of hallkeith1
Flag for Canada

asked on 

Windows XP SP2/3 Cannot Connect to WPA2 Network with Cisco 1200 AP

I cannot connect to my wireless network with a WPA2 client. WPA works against the network but as soon as WPA2 is used Windows XP cannot connect. I have not tried to connect with a different OS or with a different NIC as I do not have those at my disposal. The NIC in my machine is an Intel PRO/Wireless 3945ABG running with the latest drivers.

Originally, my machine was Service Pack 2 without the WPA2 hotfix and connectivity worked perfectly. Upon installing it, Windows started to recognize the network as a WPA2 network instead of a WPA network. All devices involved claim to support WPA2 so this was not a concern for me. Until I attempted to connect and it would rapidly fail in the connection attempt. I have attached the last connection attempt from the eapol.log file. From what I can see, there is a function that is failing with error 50 or "The request is not supported."

I have tried installing SP3 as last ditch effort. So far this has not made anything better or worse.

The access point is a Cisco 1200 AP running IOS 12.3. I have attached the radio configuration for it. While connected to the console, during a connection attempt, all I see is the following three times:

Jul 22 20:36:58.801: %DOT11-6-ASSOC: Interface Dot11Radio0, Station bldg1-ap1
<MAC Address> Associated KEY_MGMT[WPAv2]
Jul 22 20:37:00.803: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
Station <MAC Address> Reason: Disassociated because sending station is leaving
(or has left) BSS

On the RADIUS side, I can see that the athentication attempts are occuring and are successful.

If anyone has an insight into what is happening here with WPA2 connectivity to this network it would be greatly appreciated.

Thank you.
Wireless NetworkingWindows XP

Avatar of undefined
Last Comment

8/22/2022 - Mon