We help IT Professionals succeed at work.

ping/IE does not resolve DNS names, but nslookup does

esmith69
esmith69 asked
on
2,054 Views
Last Modified: 2012-05-05
Basically I have a member server that is pointing to DC for its primary DNS server.  The member server can ping by IP address and can connect to web sites using the IP address.  I can also run nslookup and it resolves DNS queries immediately.  If I try to ping by DNS name or browse websites though, it fails saying it can't connect to the host.

Any ideas?  I have already tried running NETSH INT IP RESET RESETLOG.TXT per this article (http://support.microsoft.com/kb/317518/).  Didn't help at all.

I ran network monitor and it looks like the DNS queries are not even leaving the local server, which is very odd.  Oh and I've already tried clearing out the HOSTS file.
Comment
Watch Question

Does this server have a static IP? If it does what it sounds like is the gateway isnt correct. If your DC and DNS are on the same subnet as the member server they will talk but without a correct gateway address it will not leave the network.
Is DNS installed on the member server?

Author

Commented:
Just FYI, I've even gone so far as to install the windows DNS service on the member server and set its NIC configuration to point to itself for primary DNS...and I still have the same problem with ping not resolving the DNS queries.

Author

Commented:
Clarification: at one point DNS was installled, then windows updates were run and I believe I also uninstalled DNS from the member server.  Then the aforementioned problem seemed to start happening, so I put DNS back on and made sure it was configured correctly as a stub zone for the DC.  Could view all the zone data just fine, but again it would not resolve Pings.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Can you post a complete ipconfig and sample nslookup outputs?
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.