We help IT Professionals succeed at work.

Event ID: 13508  Source: NTFRS W2K3 and W2K Servers

2,921 Views
Last Modified: 2013-12-05
I have A/D running on both a WIN2K server and WIN2K3 Server.
The following error shows up in the event viewer under File Replication Service.
Event Type:      Warning
Event Source:      NtFrs
Event Category:      None
Event ID:      13508
Date:            7/20/2008
Time:            1:52:15 PM
User:            N/A
Computer:      MY2K3SERVER
Description:
The File Replication Service is having trouble enabling replication from MY2K1SERVER to MY2K3SERVER for c:\winnt\sysvol\domain using the DNS name my2kserver.mydomain.local. FRS will keep retrying.
 Following are some of the reasons you would see this warning.
 
 [1] FRS can not correctly resolve the DNS name ddcstxdc1.douglassdist.com from this computer. (OK)
 [2] FRS is not running on my2kserver.mydomain.local.
 [3] The topology information in the Active Directory for this replica has not yet replicated to all the Domain Controllers.
  This event log message will appear once per connection, After the problem is fixed you will see another event log message indicating that the connection has been established.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: d5 04 00 00               ...    
<<<<<<<<<<<<<<<<<<<<<<<<<<END EVENT ERROR>>>>>>>>>>>>>>>>>>>>>>>

On my Win2K Server, I stopped and started the file replication service and received this error under File Replication Service
The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.
 
 Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"
 Replica root path is   : "c:\winnt\sysvol\domain"
 Replica root volume is : "\\.\C:"
 A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons.
 
 [1] Volume "\\.\C:" has been formatted.
 [2] The NTFS USN journal on volume "\\.\C:" has been deleted.
 [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal.
 [4] File Replication Service was not running on this computer for a long time.
 [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:".
 Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state.
 [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service.
 [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set.
 
WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again.
 
To change this registry parameter, run regedit.
 
Click on Start, Run and type regedit.
 
Expand HKEY_LOCAL_MACHINE.
Click down the key path:
   "System\CurrentControlSet\Services\NtFrs\Parameters"
Double click on the value name
   "Enable Journal Wrap Automatic Restore"
and update the value.
 
If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.

Suggestions?
mc
Comment
Watch Question

Commented:
You are currently in Journal Wrap:

Journal wrap is a partial replication. To resolve this you must first fix your DNS configuration and then force replicate. Since it has been a long time since you were able to replicate, you may have to resort to the burflag method of rebuilding your replication set instead of traditional means.
_____________________________________________________________
Fist step is to straighten up DNS:
You will want to make sure DNS settings are straight. Check the preferred DNS settings on the servers and make sure they point to their IP first and another DNS server next. Make sure they don't point to outside servers.
Then go to the command prompt and type DCdiag /fix:DNS to reregister the SRV records.
____________________________________________________________________________
Journal Wrap is easy to fix. Usually, you can fix journal wrap by traditional means of replication. This article tells you how to register your HOST A and SRV records in DNS. Then, as a follow up, it also tells you how to force replicate. This is somewhat of a traditional means to replicate.

https://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23356031.html

If this fails to resolve replication, then you might have to use the Burflag method to fix your replication set.

A journal wrap is when you have a lot of replication to be done and the replication process gets interupted or stopped. This can causes Events 1030 and 1058. This also may cause FRS or SysVol errors in the event logs that have the event ID of something like 13565 or 13568 indicating that sysvol or some other service will not work until replication is done. Furthermore, it can knock down the netlogon services and also give you LSA warnings. All problems that you are seeing are indicating you are in journal wrap. So, in this case the usual replications methods, as in the above secion of this post, may not suffice. You will want to probably use the Burflag method to restore your replication set.

NOTE: As recommended in this article, do a D4 (Authoritative) for a single DC or D2 (non authoritative) replication for multiple DCs.
http://msmvps.com/blogs/bradley/archive/2007/12/27/help-i-ve-lost-my-sysvol-and-can-t-get-up.aspx


Remember fixing journal wrap comes after fixing your DNS configuration issues on both servers. So far, I only see one of the servers NIC settings. I also don't know if your Postoffice server is a DNS server. If so, disable the gateway from being a DNS server because you have two good servers that provide DNS. There are limits of what a router can do in comparison to a server for DNS. This is why I recommended DNS on both servers.

Author

Commented:
DCdiag /fix:DNS doesn't run on my windows 2000 Server SP4

Commented:
You can move on to the Journal Wrap section. The first link will tell you how to re-register the HOST A and SRV records. Then, it tells you how to attempt to replicate between servers on the very bottom of that thread.

If replication still has problems, try the burflage method. If still no go, we may need to go back to DNS and troubleshoot it.

Author

Commented:
OK.   I have to go for the day but I'll try this tomorrow.  
Thank you!!

Commented:
It's been a couple days and I wanted to see how you were doing.

Author

Commented:
I'm on site today.  Just kind of swamped at the moment.  Thank you for the reminder.  I'll move this up on my task list.  :)

Commented:
No worries:

Just wanted to see how you were doing.

Author

Commented:
OK.  sorry for the extreeme delay.  Been really busy and this hasn't been a show stopper.
I tried the fix dns sytax that you sent me on my 2000 server but it didn't like that command.
So, I just typed in dcdiag /fix and received the following error.
This is the part that shows an error so I ran a test against it.
C:\Program Files\Support Tools>dcdiag /test:frssysvol

Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\DDCSTXDC1
      Starting test: Connectivity
         ......................... DDCSTXDC1 passed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\DDCSTXDC1
      Starting test: frssysvol
         Error: No record of File Replication System, SYSVOL started.
         The Active Directory may be prevented from starting.
         ......................... DDCSTXDC1 passed test frssysvol

Commented:
Could you look in Event logs for this error:

http://support.microsoft.com/kb/887440

I am thinking a creation or deletion of a new file in the replication set may be causing you problems.

Author

Commented:
Hi Chief,
I went through the event log and only found the original error that I posted.
13508
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.