troubleshooting Question

L2TP VPN to ASA5505 works only with XP not with Vista

Avatar of ensermo
ensermo asked on
VPNWindows VistaCisco
5 Comments1 Solution4566 ViewsLast Modified:
Running ASA Version 7.2(3)
Used the setup from Cisco Document ID: 71028
L2TP Over IPsec Between Windows 2000/XP PC and PIX/ASA 7.2 Using Pre-shared Key Configuration Example
Also noticed the comment from Cisco and implemented it.
Vista PC Not Able to Connect
If the Windows Vista computer is not able to connect the L2TP server, then verify that you have configured ONLY mschap-v2 under the ppp-attributes on the DefaultRAGroup.

I can connect to the VPN with L2TP/IPSEC Pre-Shared Key from a Windows XP machine using the standaard Windows VPN Client.

But Connecting from a Windows Vista VPN Client is not working.

The debug infromation on the ASA 5505 shows these errors when the connection is started.

6      Aug 06 2008      07:22:00      302015      131.211.123.123      81.93.111.111       Built inbound UDP connection 11211 for outside:131.211.123.123/500 (131.211.123.123/500) to NP Identity Ifc:81.93.111.111/500 (81.93.111.111/500)
3      Aug 06 2008      07:22:00      713048                   IP = 131.211.123.123, Error processing payload: Payload ID: 1
3      Aug 06 2008      07:22:00      713902                   IP = 131.211.123.123, Removing peer from peer table failed, no match!
4      Aug 06 2008      07:22:00      713903                   IP = 131.211.123.123, Error: Unable to remove PeerTblEntry
3      Aug 06 2008      07:22:01      713048                   IP = 131.211.123.123, Error processing payload: Payload ID: 1
...
...

Vista VPN settings are setup identical to XP VPN settings with
Require Encryption
Allow these Protocols (MS CHAP V2)
Networking L2TP IPSec VPN
IP Sec Settings Preshared Key
PPP Settings
Enable LCP Extensions
Enable Software Compression
No Negotiate Multi link for single link connections

I have attached the relevant configuration

Can anyone tell me if I am missing something or is it just a new "feature" of Vista not to connect to the ASA? !
ASA Version 7.2(3) 
!
hostname asa
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.147.200 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 81.93.111.111 255.255.255.240 
 
access-list inside_access_in extended permit ip any any 
access-list DefaultRAGroup_splitTunnelAcl standard permit 192.168.147.0 255.255.255.0 
 
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
 
ip local pool clientVPNpool 192.168.147.225-192.168.147.250 mask 255.255.255.0
 
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
 
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 81.93.111.250 1
 
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set TRANS_ESP_AES_SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_AES_SHA mode transport
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set TUNN_ESP_AES_SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set TUNN_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_MD5 TRANS_ESP_AES_SHA TRANS_ESP_3DES_SHA
crypto map outside_map 20 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
 
 
dhcpd auto_config outside
!
dhcpd address 192.168.147.201-192.168.147.232 inside
!
 
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 vpn-tunnel-protocol IPSec l2tp-ipsec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
 
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec 
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
 
tunnel-group DefaultRAGroup general-attributes
 address-pool clientVPNpool
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 isakmp keepalive disable
tunnel-group DefaultRAGroup ppp-attributes
 no authentication chap
 no authentication ms-chap-v1
 authentication ms-chap-v2
prompt hostname context 
Cryptochecksum:afbb1245454ew5e4v5w4
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 5 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros