Link to home
Start Free TrialLog in
Avatar of diegomirner
diegomirnerFlag for Switzerland

asked on

network bandwidth issue between my actual 2950

Dear Experts,

I need help in order to troubleshoot a network bandwidth issue between my actual 2950 access switches that connects interface giga 1  2 of my  Cisco core switch 2970 by trunk port. I have done same bandwidth testing between the 2950 against 2970 using windows and speed test tools and I see the highest transfer speed between them its 3.5 mb .

Here the actual config of switches:

2970 :


interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/3
 switchport access vlan 91
 switchport mode access
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/4
 switchport access vlan 91
 switchport mode access
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!


2950

!
interface FastEthernet0/1
 switchport access vlan 100
 switchport mode access
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 mls qos cos override
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/2
 switchport access vlan 100
 switchport mode access
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 mls qos cos override
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!


Any help its well come.
Thanks in advance

Avatar of RPPreacher
RPPreacher
Flag of United States of America image

Is that 3.5 MB/s or 3.5Mb/s?  If 3.5MB/s, that is 28 Mb/s.  If 3.5mb/s, that's super slow.

Also how did you actually test this?  Windows file transfers aren't a great measurement.  Internet speed tests are not reliable.  Just curious.
Avatar of diegomirner

ASKER

I have use :

http://dast.nlanr.net/Projects/Iperf/

I will do it again to answer you, do you see all ok in the config of ports ?
hi!
you have mentioned gig connection from 2950 to 2970, however pasted configs of fastethernet ports

please show also shot int  output of corresponding uplink/downlink ports
and please provide also output of iperf
It would also be wise to statically configure the speeds on the ports to match.
when i try to fix speed and duplex on trunk ports of 2950 switches the port got down, os the only way to make it work its with out speed and duplex config on all 2950 swit.amy idea way ?
im in my way to post all info
what type of media do you use?
are both ports copper?
i mean when i try to fix the trunks ports between Cisco 2950 ( port Gigabit 0/1 and port Giga bit 0/1 on switch 2970.
please, what type of media do you use?
in case both ports are copper use
speed 1000
duplex full on both sides

please also provide output of
show run <trunk ports>
show int <trunk ports>
He can't use speed 1000.  It's FE on the 2950, not Gi
sorry , but its a Gi port , i have to Gi ports
so, can you provide me with the information I request?
ok , here the show run on all switches :

Core 2970 switch :
port gigabit 0/1 connects to switchA 2950 on port Gi0/1
port gigabit 0/2 connects to switchB 2950 on port Gi0/1
Runing config

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!

show interface 0/1

GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.9d60.a501 (bia 0016.9d60.a501)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 27000 bits/sec, 36 packets/sec
  5 minute output rate 1133000 bits/sec, 83 packets/sec
     10528735 packets input, 2479404477 bytes, 0 no buffer
     Received 1877747 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 1775241 multicast, 0 pause input
     0 input packets with dribble condition detected
     20669039 packets output, 4077887046 bytes, 0 underruns
     0 output errors, 0 collisions, 21 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out



Switch A 2950


!
interface GigabitEthernet0/1
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point

GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.47ff.2f71 (bia 0016.47ff.2f71)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:23, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 878000 bits/sec, 58 packets/sec
  5 minute output rate 15000 bits/sec, 24 packets/sec
     21421691 packets input, 4169502421 bytes, 0 no buffer
     Received 8338755 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     1 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 3733718 multicast, 0 pause input
     0 input packets with dribble condition detected
     10911273 packets output, 2545433761 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Switch B 2950


!
interface GigabitEthernet0/1
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point
!

GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.9d18.d1f1 (bia 0016.9d18.d1f1)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 39000 bits/sec, 10 packets/sec
  5 minute output rate 1000 bits/sec, 2 packets/sec
     105553404 packets input, 1362808853 bytes, 0 no buffer
     Received 9570733 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 4919906 multicast, 0 pause input
     0 input packets with dribble condition detected
     81115807 packets output, 2217469356 bytes, 0 underruns
     0 output errors, 0 collisions, 10 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out



I cant fix speed and full duplex on all port becouse if i do so , all trunks port goes down, i dont know way.
Any help its wellcome
sorry , i for got to post port 0/2 of 2970 core switch , here is :

CoreSwitch_A#show interfaces gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.9d60.a502 (bia 0016.9d60.a502)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:16, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 7000 bits/sec, 9 packets/sec
     81033437 packets input, 2207704468 bytes, 0 no buffer
     Received 81720 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 46492 multicast, 0 pause input
     0 input packets with dribble condition detected
     105007639 packets output, 1320183681 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
ok, the main thing, I wanted to check - input error counters on interfaces
there are non, so the transmission is ok.

However I can see, that ports on 2950 are configured with speed nonegotiate - it means to use 1000full
and ports on 2970 are left with auto.

if all medias are rj45 (no fiber) you can try to configure ports on 2970 with speed 1000full also. or in the other way - configure 2950 to use auto.

and, please paste here screenshot of iperf test
ok , i have try it , and i cant manage to put up again the conection between 2970 and 2950A

here the actual config :

2970:
running
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 1000
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point

interface:
GigabitEthernet0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 0016.9d60.a501 (bia 0016.9d60.a501)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 05:48:52, output 05:49:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     11038285 packets input, 2623601987 bytes, 0 no buffer
     Received 2138195 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 2021457 multicast, 0 pause input
     0 input packets with dribble condition detected
     21091568 packets output, 4113007423 bytes, 0 underruns
0 output errors, 0 collisions, 25 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
CoreSwitch_A#0 output errors, 0 collisions, 25 interface resets



Switch 2950A

running

!
interface GigabitEthernet0/1
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point
!

GigabitEthernet0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 0016.47ff.2f71 (bia 0016.47ff.2f71)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is RJ45
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 05:50:05, output 05:49:55, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     21843650 packets input, 4204577650 bytes, 0 no buffer
     Received 8615053 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     1 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 3743339 multicast, 0 pause input
     0 input packets with dribble condition detected
     11420222 packets output, 2689479033 bytes, 0 underruns
 0 output errors, 0 collisions, 10 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Access_Switch_A#

so this happens after i have set 2970 port 0/1 woth 1000 and full duplex , and i have set auto speed and auto duplex on 2950.

when i try to shutdwon and no shutdown the port i get this :
CoreSwitch_A(config-if)#no shutdown
2w0d: %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to administra
tively down
CoreSwitch_A(config-if)#no shutdown
CoreSwitch_A(config-if)#
2w0d: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to down
CoreSwitch_A(config-if)#

any idea ????


sorry i forgot , :

2970 , last config :

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex full
 speed 1000
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point

and what about with auto negotiation from both sides?
btw, can you describe, how you performed iperf test?
so , i have change the setings on 2970 to duplex and speed all to auto , and the link its up again, and conect pc 1 to 2970 , and pc 2 to 2950 A , and i get this results:

------------------------------------------------------------
Client connecting to 192.168.91.112, TCP port 5001
TCP window size: 8.00 KByte (default)
------------------------------------------------------------
[1920] local 192.168.91.144 port 1192 connected with 192.168.91.112 port 5001
[ ID] Interval       Transfer     Bandwidth
[1920]  0.0-10.3 sec  3.35 MBytes  2.73 Mbits/sec

any help its wellcome
thanks in advance
and what about with auto negotiation from both sides?
 , should i take it out ?
you leave them as they are, because it is not correct, when one side is set to nonegotiate, but the second one is set to auto

so as for performance, do you have any antivirus and or firewalls on place on any no test pcs?
on both pc's i have running windows firewall and sophos antivirus.
hmm, please, turn off boths :)
and test again
same result.

Im lost
what kind of OS do you have on test pcs?
can run ping -t simultaneously during iperf test?

don't panic, will find a solution!
 
xp spk3

yea , i just run it again , same result , 4 ping wit >1ms each one ttl:128
Please run ping with -t flag in order to see how latency changes before, during and after test.
then please connect two pcs together using direct cable (possibly crossover cable is not needed)and run  tests, to be sure that pcs are ok
so , i have done same test :

i have connect both pcs on same switch 2950A and i got same speed avarage. 3.4mbit

then i have connect boths pcs with cross over , and i got 94.5 mbits (fine)

now , here the config of fastethernet ports where boths pcs where connected :

interface FastEthernet0/7
 switchport access vlan 91
 switchport mode access
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 mls qos cos override
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable

please remove the following lines from ports used for tests and run tests again, please:
switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 mls qos cos override


to remove them enter 'no' statement before each line
So , i try it , and if i connect boths pc's on switch 2950A with new config , its work at 94.5 Mbits.
But when i connect one pc to 2970 and other to 2950 im still getting same low rates them befour with new config

so , actual config on boths pcs :

2950 :

interface FastEthernet0/39
 switchport access vlan 91
 switchport mode access
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!

2970 :

interface GigabitEthernet0/19
 switchport access vlan 91
 switchport mode access
 duplex full
 speed 100
 macro description cisco-desktop
!

ok, now it is rather clear: QoS commands are an issue.
please paste full configs from 2950 and 2970
I suppose you are allocating  to voip and no room is left for data
switch 2970

Current configuration : 8239 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CoreSwitch_A
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 spanning-tree link-type point-to-point

!
interface Vlan1
 ip address 192.168.0.10 255.255.255.0
 no ip route-cache
!
interface Vlan91
 ip address 192.168.91.240 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.91.1
ip http server
!
control-plane
!
banner motd ^CC
************************

DO NOT LOGON

************************^C
alias exec s show ip interface brief
!
line con 0
 exec-timeout 30 0
logging synchronous
 login
line vty 0 4
 exec-timeout 240 0
logging synchronous
 login
line vty 5 15
 exec-timeout 240 0
logging synchronous
 login
!
!
end


Switch 2950A

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Access_Switch_A
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
!
interface FastEthernet0/39
 switchport access vlan 91
 switchport mode access
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
!
interface GigabitEthernet0/1
 switchport mode trunk
 speed 1000
 duplex full
 macro description cisco-switch
 spanning-tree portfast disable
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 192.168.10.11 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan30
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan91
 ip address 192.168.91.241 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.91.1
ip http server
banner motd ^C
************************

DO NOT LOGON

************************^C
alias exec s show ip interface brief
!
line con 0
 exec-timeout 30 0
logging synchronous
 login
line vty 0 4
 exec-timeout 240 0
logging synchronous
 login
line vty 5 15
 exec-timeout 240 0
logging synchronous
 login
!
!
end


I have aboid others interfaces lines whicht we dont uses for the moment.


do you have voip in place?
if not, you can safely remove all
mls qos trust cos
lines
done , but problem persist
ok, please provide current configs of both switches and point to which ports test pcs are attached.
ok , here is :

Cisco 2070

Running config :

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CoreSwitch_A
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 192.168.0.10 255.255.255.0
 no ip route-cache
!
interface Vlan91
 ip address 192.168.91.240 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.91.1
ip http server
!
control-plane
!
banner motd ^CC
************************

DO NOT LOGON

************************^C
alias exec s show ip interface brief
!
line con 0
 exec-timeout 30 0
logging synchronous
 login
line vty 0 4
 exec-timeout 240 0
logging synchronous
 login
line vty 5 15
 exec-timeout 240 0
logging synchronous
 login
!
!
End

CoreSwitch_A#show interfaces gi
CoreSwitch_A#show interfaces gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.9d60.a501 (bia 0016.9d60.a501)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 131000 bits/sec, 4 packets/sec
  5 minute output rate 3000 bits/sec, 5 packets/sec
     11705827 packets input, 2933004254 bytes, 0 no buffer
     Received 2422772 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 2304753 multicast, 0 pause input
     0 input packets with dribble condition detected
     21637106 packets output, 4158949642 bytes, 0 underruns
     0 output errors, 0 collisions, 39 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

CoreSwitch_A#show interfaces gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.9d60.a502 (bia 0016.9d60.a502)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 117000 bits/sec, 8 packets/sec
     81830414 packets input, 2530226407 bytes, 0 no buffer
     Received 174588 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 138409 multicast, 0 pause input
     0 input packets with dribble condition detected
     106751554 packets output, 1668400152 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


------------------------------------------------------------------------------------------------------

Cisco 2950A

Current configuration : 16554 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Access_Switch_A
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
!
interface FastEthernet0/39
 switchport access vlan 91
 switchport mode access
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet0/1
 switchport mode trunk
 speed 1000
 duplex full
 macro description cisco-switch
 spanning-tree portfast disable
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 192.168.10.11 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan30
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan91
 ip address 192.168.91.241 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.91.1
ip http server
banner motd ^C
************************

DO NOT LOGON

************************^C
alias exec s show ip interface brief
!
line con 0
 exec-timeout 30 0
logging synchronous
 login
line vty 0 4
 exec-timeout 240 0
logging synchronous
 login
line vty 5 15
 exec-timeout 240 0
logging synchronous
 login
!
!
end

Access_Switch_A#show interfaces gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.47ff.2f71 (bia 0016.47ff.2f71)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:05, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 4000 bits/sec, 5 packets/sec
  5 minute output rate 78000 bits/sec, 5 packets/sec
     22390448 packets input, 4250630529 bytes, 0 no buffer
     Received 8937847 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     1 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 3754790 multicast, 0 pause input
     0 input packets with dribble condition detected
     12089199 packets output, 2999326128 bytes, 0 underruns
     0 output errors, 0 collisions, 12 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Access_Switch_A#show interfaces fastEthernet 0/39
FastEthernet0/39 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0016.47ff.2f67 (bia 0016.47ff.2f67)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 3000 bits/sec, 5 packets/sec
     94863 packets input, 142590825 bytes, 0 no buffer
     Received 163 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     118470 packets output, 8663219 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


Cisco 2950B

!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Access_Switch_B
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
!
interface FastEthernet0/39
 switchport access vlan 91
 switchport mode access
 speed 100
 duplex full
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
!
interface GigabitEthernet0/1
 switchport mode trunk
 speed 1000
 duplex full
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 192.168.0.12 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan91
 ip address 192.168.91.242 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.91.1
ip http server
banner motd ^CC
************************

DO NOT LOGON

************************^C
alias exec s show ip interface brief
!
line con 0
 exec-timeout 30 0
logging synchronous
 login
line vty 0 4
 exec-timeout 240 0
logging synchronous
 login
line vty 5 15
 exec-timeout 240 0
logging synchronous
 login
!
!
End

Access_Switch_B#show interfaces gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0016.9d18.d1f1 (bia 0016.9d18.d1f1)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is RJ45
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 41000 bits/sec, 9 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     107302903 packets input, 1711473081 bytes, 0 no buffer
     Received 10809169 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 5464463 multicast, 0 pause input
     0 input packets with dribble condition detected
     81914943 packets output, 2541035987 bytes, 0 underruns
     0 output errors, 0 collisions, 12 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Access_Switch_B#show interfaces fastEthernet 0/39
FastEthernet0/39 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0016.9d18.d1e7 (bia 0016.9d18.d1e7)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb

just a remainder :

Core switch 2970
interface Giga 0/1 - Switch 2950A gigaport 0/1
interface giga 0/2 - switch 2950B gigaport 0/1

Switch A
interface fe 0/39 PC1

switchB
interface fe 0/39 PC2

hope this helps
interface FastEthernet0/39
 switchport access vlan 91
 switchport mode access
 speed 100
 duplex full
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
have you configured your pc to use 100 full also? (just for check)
as for configuration, please remove macro commands from ports. why do you need them?
ok , so from switch A & B i have remove macros , but still same problem
and also i have set up boths pc on 100 full
I suppose it is time to summarize all what we have here:
within 2950 switch we can archive desired performance.
can you test 2970 in the same way, please? with both ports within 2970
if you'll get 94 mbps, then possible problem is in gig ports on 2950 or just cabling between switches...

and please sorry so long time it takes to find a solution
ok , so , i have try already speed between 2970 and i have good performance.
regarding cabling im using 5e twisted pair calbes.
What its strange its that was working fine befour i have reset all config to create a new config with vlans.
means that was working fine with same clabes connected to same ports.what i have change its switches configs.
any idea ?
hm, strange.....
this problem  is blowing my mind!

please, add the following line to trunked ports:

switchport trunk allowed vlan 91 (and only this one for now, if you need any other vlan, just add it after "91, ")
done , but no change, problem still persist.
next thing to do:

configure port gi0/1 on 2970 in access mode
connect your test PC instead of 2950 switch and run test
if the test will be ok, then run the same test against 2950
sorry , idont get it , whar exactly you whant me to do ?
I want you do place pc instead of one of the switches in order to test gig ports + gig lines.

for that purpose you should reconfigure ports as access
ok , i got it, keep you inform
so , i manage , and i got 83.4 mbits
sorry , 69.7 mbits
sorry , i will be more precise:

connect pc 1 to switch 2950 b and pc2 to 2970 port 1 access mode:

69.7 mbits

---------------

connecting pc1 to 2950a port 39
connection pc2 to 2950a Gi 0/2 access mode vlan91
2.52 mbits

so , what you think about it
can we say, that we have localized problem to the 2950a switch?
in my opinion its related to trunk ports on 2950 and maybe 2970 also.just for your info , i have made yestarday a new test:

switch 2950A :
FE port 0/1 on trunk port connected to port 0/1 turnk port of 2970

Switch 2950B:
FE port 0/1 on trunk port connected to port 0/2 turnk port of 2970

pc 1 connected to port 0/39 switch A
pc2 connected to port 0/39 switch B

speed of test : 2.6mbits

so , in my opinion its related to config of trunk ports, but i dont know waht its wrong.
ASKER CERTIFIED SOLUTION
Avatar of from_exp
from_exp
Flag of Latvia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
its free ?
i find it , im inmy way , keep you inform
no :(
but possibly you can find one in the internet
please post show ver, I'll look if I have something at home.
System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4a.bin"

strange , i just download a new version free from cisco
have you installed the latest one already?
nop , im stack on tftp server , jeje
i want to backup first the actual ios
a bit lost now,

when i try to update switch A 2950 , from file :

c2950-i6k2l2q4-tar.121-22.EA12.tar

with cisco network assistent , im geting an error.
it has solve the probem . just updating the switch solved the problem
thanks a lot
you can do everything from console
to copy out existing ios, just copy tar file from device to tftp

as for upgrading procedure, take a look here:
http://www.cisco.com/warp/public/473/36.shtml
nice!!!
but it really took as so long to find the problem!

in most cases - installing latest (drivers/bios/firmware) is the very first step to do.
However, in case of cisco, you suppose the ios is goog enough and look somewhere else :P
hey , you there ?

could you please help me with this :

https://www.experts-exchange.com/questions/23650666/need-help-to-setup-VPN-to-connect-offices.html

thanks in advance