Link to home
Create AccountLog in
Avatar of JosephGreenwald
JosephGreenwald

asked on

Unable to stop McAfee Virus Scan Enterprise Access Protection

I cannot stop McAfee Virus Scan Enterprise 8.5i "Access Protection."  It is preventing my GFI FAXMaker program from sending email to users via my Exchange server.

The problem is, everytime I stop it, it starts right back up again after like 5 minutes.  I've even right clicked on it from the console and unchecked the "Prevent McAfee services from stopping" box and it still happens.  Somehow that box rechecks itself as well.  I am logged in as Domain Admin and it still happens.  I've tried removing and reinstalling the program and this makes no difference.

Anyone have a solution?
Avatar of c_ross
c_ross
Flag of United Kingdom of Great Britain and Northern Ireland image

Start > Run Services.msc and disable the McAfee Services that should stop it in its tracks.

If not remove it completely > https://knowledge.mcafee.com/article/688/612722_f.SAL_Public.html and purchase a decent AV product like NOD32.
Avatar of JosephGreenwald
JosephGreenwald

ASKER

Thanks, but that is not a solution.  I want to keep the product, just turn off Access Protection.

I am perfectly happy with McAfee and have been for a few years now.  I just need to turn off this one component.
ASKER CERTIFIED SOLUTION
Avatar of lamaslany
lamaslany
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
PS:  If you use Protection Pilot or ePO you need to ensure that it doesn't overwrite your locally defined exception.  Alternatively you can simply push the policy change from the PP/ePO console.
D@mn; forgot to say that the exception you need to add is the filename of the file that tries to establish the SMTP connection.  It should be easy enough to check the AccessProtectionLog.txt file to see which file was being blocked.
That worked, thanks!  I was actually looking for that setting earlier but I must've totally overlooked it :)

I am not running Protection Pilot so that is not a concern.

As a side note, I can get Access Protection to turn off and stay off on my workstation, but on the server it will not turn off?  Oh well, issue is solved, thanks.
Re: side note

I think you just needed to disable Access Protection

VirusScan Console
    Access Protection
        Untick 'Prevent McAfee services from being stopped'
        Untick 'Enable Access Protection'

If you read my first post, I already tried that.  The box rechecks itself and turns back on 5 minutes later.  I tried it at least a dozen times.
To allow the user to stop the McAfee services, you will need to modify the relevant registry key:
Select Start, Run and type regedit.
Click OK.
Locate:

HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\VSCore

In the screen on the right locate the key: LockDownEnabled.
To allow the services to be stopped, change the value for LockDownEnabled to 0.
To not allow the services to be stopped, set the value to 1.
FYI -- I have the same issue whereby when I perform a net stop command or using services.msc stop the service 'McAfee McShield' the service basically restarts automatically.
The registry key is set to value of 0
The check marks on the 'Enable Access Protection' and 'Prevent McAfee services from being stopped'  are off.

In my case I am looking to stop the services during backup operation. I use Computer Associates Brightstor. When the AV is running I loose significaint throughput.

I realize that their is an accepted soluiton, however, I do not believe that the problem was resolved with the solution accepted based on my results.
Found the magic fix you were looking for.

Mystery solved - others will find this information resourceful.

uncheck in General tab of On-Access Scan Properties 'Enalbe on-access scanning at system startup'
Make note that when the service is stopped the state is paused, you can use resume from the services.msc or use net continue command 'service'.
Just untick all the reports in there