We help IT Professionals succeed at work.

DCOM error accessing SQL Server after reinstall of NIC

373 Views
Last Modified: 2011-08-18
I had to uninstall and reinstall my NIC card to clear up an issue with remote desktop connection. My system worked fine otherwise before the reinstall.

Now my connection into SQL Server (actually SSMS) is terribly slow. I checked the event log and I get the error "DCOM was unable to communicate with the computer APPL2900 using any of the configured protocols."

I have searched the web, trying many things to correct this problem, but so far nothing has worked. It appears things like the rpc keys in the registry are ok.

Not sure if it is related, but SMTP throws an error that it gets hung up while starting. I think this started after the NIC reinstall too.

I do not want to do a repair of XP (I have heard horror stories about that), so I'll try any other solution!
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2014

Commented:
I would first double check speed and duplex settings of your NIC.

Do you have a managed switch?  If so check its settings.  If not, then your NIC should hopefully be set to auto speed and auto duplex.

If you have a switch that properly support auto speed and duplex you should hopefully be connecting and 100 Mbps and Full duplex.    This sounds like it could be a duplex mismatch.  Your NIC and the switch port should be configured the same.  That is either both are auto/auto or they are both 100/full.

Author

Commented:
I really don't know much about network stuff - on my computer I can see that under the controller properties is has the speed/duplex settings are set to auto. I have checked other computers on our network including one that is identical to mine (the network controller is the same and the settings are the same).  So, I do not think it is a speed/duplex issue.  The other computers appear t be fine.

When my application connects through odbc, there is no visible slowing of processing. It only happens when I use SQL Server Management Studio connecting to a database on a server on the network. As I said, I get the DOM errors when connecting to SSMS and trying to perform any actions.

Is there anything else I can check to see what may be happening?
CERTIFIED EXPERT
Top Expert 2014

Commented:
Do you know how you were communicating with the SQL server before?  IP, NETBIOS, something else?

After re-reading your issue it seems that when you re-installed your NIC you did not  configure one of the protocols you had before.

Author

Commented:
I have no idea.  I assume that I was using the default set up on the computer or from the installation of SQL server. I reinstalled sql server but that did not resolve the problem.  Are there standards for setting up protocols I can follow to see if that will fix the problem?

CERTIFIED EXPERT
Top Expert 2014

Commented:
By chance when you re-installed the NIC did the firewall get turned back on?

Author

Commented:
No, the firewall is off. That was the first thing I checked. Right now I am debating on whether or not I should try to repair XP. I am not sure what other software would reset the DCOM protocols. I have tried reinstalling SQL server, but that did not work. I was hoping to find something that would act as a DCOM reinstall to put it back but so far I have not found anything that works.
CERTIFIED EXPERT
Top Expert 2014

Commented:
Well, one thing you may want to try is to run a packet capture from your computer and see if you are making a request that never gets a response.  I would suggest wireshark, http://www.wireshark.org.

Author

Commented:
While I have not corrected the DCOM error, I have improved the processing speed of SSMS by logging into it with the IP address instead of a text name for the server I am trying to connect to. I would like to solve the problem at some point in time, but for now I am back to working at a normal speed.
CERTIFIED EXPERT
Top Expert 2014
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
After realizing the name was the problem, I went into the hosts file (in the windows\system32\drivers\etc directory) and added the ip address and name of the system I was trying to connect to with SQL Server.  Now that it is in the hosts file, the system is fast again and no more DCOM errors!
CERTIFIED EXPERT
Top Expert 2014

Commented:
Thanks for the points.  Of course what I would strongly suggest is you figure out why the host name you are using is note in your DNS.

If the IP address of your server were change the DNS entry would (should) get updated, but your hosts file would not.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.