troubleshooting Question

Cisco 1811w trying to route between vlans + access internet

Avatar of justin_smith
justin_smithFlag for Australia asked on
Routers
8 Comments1 Solution610 ViewsLast Modified:
Hi everyone.

Im having a few issues at the moment. i need to access everything between the vlans on my router but i also need to access the internet from each vlan ( 192.168.1.0/24, 192.168.5.0/24, 10.0.1.0/24)

the internet connection is through 192.168.1.89 on vlan2 and is a cisco asa 5520

Thanks
Building configuration...
 
Current configuration : 4266 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
!
!
aaa session-id common
!
crypto pki trustpoint TP-self-signed-295350064
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-295350064
 revocation-check none
 rsakeypair TP-self-signed-295350064
!
!
crypto pki certificate chain TP-self-signed-295350064
 certificate self-signed 01
  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 32393533 35303036 34301E17 0D303830 36313730 31353232 
  345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F 
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3239 35333530 
  30363430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100 
  DA6FA8A8 D4095047 0917A8C6 12054F27 4D9B41CE C12D19BE C2D5ACE4 C1719D77 
  7D689605 1515AA83 5FBB196F 1356267A C02C9841 9B740516 AFE6FCC5 AF46B8B2 
  0CC67CA1 BEC59631 7719F556 55CCC795 8CB2488A 05D528EE 01FB724B 2A22880D 
  46F33388 CD094B0D DFA36537 EED71F0B 2E8D29B4 00BA5666 C5154188 45BBE143 
  02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D 
  11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F 
  0603551D 23041830 1680140C CBC8DC56 286D55D8 D2C5C5C0 17D2643A 5ECF7B30 
  1D060355 1D0E0416 04140CCB C8DC5628 6D55D8D2 C5C5C017 D2643A5E CF7B300D 
  06092A86 4886F70D 01010405 00038181 005F5A9F 7093E988 A234C0D5 8A5666F5 
  9F696312 2B8C15F6 CC5B5318 02195273 99A9F81A 9AB9C48F 658F197C DD4292ED 
  0ED9BE51 00D5A0CF 4C94AD15 2739482B 3870ECDF DD031D2D 78A29CAC 9AB61B92 
  22AD04D3 75A44964 FAB84548 2A7C8A71 97790233 22CF045D 5201B5F3 591E6A3F 
  C8235CDD 09E11D16 AD1AD7C2 AABDE214 5B
  	quit
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1 
   lease 0 2
!
!
no ip domain lookup
ip domain name yourdomain.com
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username admin privilege 15 secret 5 $1$AsxG$u4y/R9CVETuNE2bmn2hUJ1
! 
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2
 switchport access vlan 2
!
interface FastEthernet3
 switchport access vlan 3
!
interface FastEthernet4
 switchport access vlan 4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Dot11Radio0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio1
 no ip address
 shutdown
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 description $ES_LAN$
 no ip address
!
interface Vlan2
 ip address 192.168.1.180 255.255.255.0
 ip nat outside
 ip virtual-reassembly
!
interface Vlan3
 ip address 192.168.5.60 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan4
 ip address 10.0.1.200 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Async1
 no ip address
 encapsulation slip
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.89 permanent
ip route 10.0.1.0 255.255.255.0 Vlan4 permanent
ip route XX.XX.XX.0 255.255.255.0 Vlan3 permanent
ip route 192.168.1.0 255.255.255.0 Vlan2 permanent
ip route 192.168.2.0 255.255.255.0 Vlan2 permanent
ip route 192.168.5.0 255.255.255.0 Vlan3 permanent
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
no cdp run
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
 modem InOut
 stopbits 1
 flowcontrol hardware
line aux 0
line vty 0 4
 transport input telnet ssh
line vty 5 15
 transport input telnet ssh
!
end
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 8 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 8 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros