Configure Exchange 2003 ActiveSync with iPhone 3G

I'm trying to get an iPhone 3G to sync with my Exchange 2003 SP2 server using Activesync, and I'm running into some problems.  I've read a lot of other posts on this site and none of the solutions have worked.  Here's where I am:

Going to https://mydomain.com/oma results in an error (both internally and on the iPhone) of "A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator."  This also results in the following error in the Event Viewer:

Event Type:      Error
Event Source:      MSExchangeOMA
Event Category:      (1000)
Event ID:      1503
Date:            8/7/2008
Time:            10:51:03 AM
User:            N/A
Computer:      Server
Description:
An unknown error occurred while processing the current request:
Message: The remote server returned an error: (501) Not Implemented.
Source: Microsoft.Exchange.OMA.ExchangeDataProvider
Stack trace:
   at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
   at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
   at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
   at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
   at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
   at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Also, whenever my phone tries to sync and check email, a different error is created in the Event Viewer:

Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            8/7/2008
Time:            10:51:10 AM
User:            Domain/User
Computer:      Server
Description:
Unexpected Exchange mailbox Server error: Server: [diserver.DI.local] User: [user@domain.com] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.


Here's some other things I've tried:

- I have an SSL cert installed and it works fine with OWA.  SSL is enabled (but not required) for OMA.
- I've checked that IP security is granting access to all IP's for all relevant Exchange, OMA, and Activesync sites.
- I've installed service pack 2 for exchange.

Any ideas?
Amit82Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wolfcamelCommented:
ok..
until you can get http:\\localhost\oma to work on the server there isnt much point playing with the phone.
forget the https it is typically not turned on for oma

I had this recently at one client and SP2 solved it.

If this is SBS I would rerun the internet connection wizard as this will reset most of the IIS settings.
0
ach_patilCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Amit82Author Commented:
Ok, I've made some progress using the first link that ach_patil posted (KB898131).  I added a multiple identity for the default web site (port 80) with my server's NetBIOS name.  Now when I go to http://mydomain.com/oma on my PC, I get the following message:

The device type you are using is not supported. Press Ok to continue.

Ok
Ok, and do not warn me again

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16


This is a step in the right direction, I think.  However, I get the same message when I go to mydomain.com/oma on the iPhone's web browser.  Also, the iPhone is still not syncing with Exchange.  I continue to get the error 3005 in the Event Viewer whenever my phone tries to sync.

I'm going to try the second KB article now.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Amit82Author Commented:
Hmm, the second KB article doesn't seem to be relevant, now that I've fixed the problem with accessing mydomain.com/oma.  Like I said before, the iPhone is still not syncing, and I'm still getting error event 3005 (see original post above) in the event viewer.  Any further ideas on resolving this?
0
ach_patilCommented:
0
wolfcamelCommented:
have your tried a different user?
I had this with one user that had hit their quota - oma doesnt like this, even after increasing the quota I needed to restart exchange before the phone would connect.
0
Amit82Author Commented:
I tried KB 883380 as suggested (using method 2), and it didn't seem to change anything.

Also, I tried a different user and got the same 3005 error in the Event Viewer for that user.

Any other ideas?
0
dmf415Commented:
Is your Sync directory empty? i have this problem:
im getting a null error on my exchange 2003 server, the sync directory is empty

on my exchange 2007 server the iphone works and the sync directory has files in it.

0
Amit82Author Commented:
I assume you mean this directory:

C:\Program Files\Exchsrvr\OMA\Sync


And yes, it is completely empty.  Is that a problem?
0
dmf415Commented:
If anyone here knows, let us both know.
I can get my iphone working on exch 2007 but not 2003 (tried a 2007 acct and then a 2003 acct)
0
dmf415Commented:
I got it working guys, just follow the activesync white paper!

If you are using a single Exchange 2003 server:

       Verify that Exchange 2003 Outlook® Web Access is working.
       If you are using devices with Windows Mobile 2002 software or using devices with Windows Mobile 2003 software with SSL, make sure that a certificate is installed on the Exchange server unless the SSL session is terminated before the Exchange server.

       If you are not using SSL, launch Internet Explorer on the desktop and verify that http://servername/Microsoft-Server-ActiveSync returns Error 501/505 - Not implemented or not supported. Verify the same from the device.

       If you are using SSL, launch Internet Explorer on the desktop and verify that https://servername/Microsoft-Server-ActiveSync returns Error 501/505 - Not implemented or not supported. Verify the same from the device.
       Verify that massync.dll is listed as an Application map on the Microsoft-Server-ActiveSync virtual directory on the Exchange server.

       Verify that Exchange ActiveSync is enabled globally using Exchange System Manager. This is the default setting.
       Verify that the user is enabled for Exchange ActiveSync using AD Users and Computers. This is the default setting.

       On the Exchange server, verify that the authentication settings on the Exchange virtual directory include Integrated Windows Authentication.

Exchange ActiveSync uses Kerberos authentication when communicating with the Exchange server and therefore requires that Integrated Windows authentication be checked on the Exchange virtual directory.

       If you are using a single Exchange 2003 server and have either configured your Exchange virtual directory to Require SSL or have turned on Forms Based Authentication (FBA), then follow the procedure below to create an alternate Exchange virtual directory for ActiveSync to use.

The new virtual directory needs to be created through Internet Services Manager for Exchange ActiveSync to work.
If you are using Microsoft Windows Server" 2003 or later, follow these instructions:
1.      Start Internet Information Services (IIS) Manager

2.      Locate the \exchange virtual directory (default location is Web Sites\Default Web Site\Exchange)

3.      Right click on the Exchange virtual directory, choose All Tasks, Save Configuration to a File.

4.      Type a name in the File name: text box (for example, ExchangeVDir).

5.      Click OK.

6.      Right click the root of this Web site (Default Web Site), choose New, Virtual Directory (from file).

7.      On the Import Configuration dialog box, select the Browse button and locate the file from step #4, then click Open.

8.      Next, select the Read File button.

9.      In the Select a configuration to import text box, select Exchange and press OK.

10.      A dialog box will appear stating the virtual directory already exists. In the Alias text box, type a name for the new virtual directory that you want the Exchange Server ActiveSync and Outlook Mobile Access processes to use. For example, type Exchange-OMA.

11.      Click OK.

12.      Right click on the new virtual directory and choose Properties, in this example, Exchange-OMA.

13.      Select the Directory Security tab.

14.      Click the Edit button in the Authentication and access control section.

15.      Verify only the following authentication methods are enabled:
"      Integrated Windows authentication
"      Basic authentication

16.      Click OK.

17.      Click Edit under IP address and domain name restrictions.

18.      Click Denied access, and then click Add.

19.      Click Single computer (if this option is not already selected), type the IP address of the server that you are configuring, and then click OK.

20.      Click the Edit button in the secure communications section.

21.      Verify require secure channel (SSL) is not enabled and click OK.

22.      Click OK, and then quit IIS Manager.

23.      Click Start, click Run, type regedit in the Open box, and then click OK.
24.      Locate the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
25.      Right-click Parameters, point to New, and then click String Value.

26.      In the New Value #1 box, type ExchangeVDir, and then press ENTER.

27.      Right-click ExchangeVDir, and then click Modify.

28.      In the Value data box, type a forward slash (/) followed by the name of the new virtual directory that you created in step 10. For example, type /Exchange-OMA.

29.      Click OK, and then quit Registry Editor.

30.      Restart the IIS Admin Service. To do this:
"      Click Start, click Run, type services.msc in the Open box, and then click OK.
"      In the Name list, right-click IIS Admin, and then click Restart.
0
Amit82Author Commented:
Which part of this solution solved your problem?

 I checked everything on my server and it all seems to jive with the information above.  I've seen the instructions for creating a new virtual server, but in the KB articl with these instructions, at the end it says that the new virtual server has to be named exchange-oma if you are using SBS2003 (which I am), and there is already a virtual server named exchange-oma, and an entry in the registry equivalent to the one the instructions are telling me to create.
0
dmf415Commented:
i deleted my exch activesync virutal server and started from scratch
0
Amit82Author Commented:
Well, I deleted the exchange-oma virtual server and recreated it according to the instructions above.... and no change.  Still getting the 3005 error.  Frustrating.  *sigh*
0
Amit82Author Commented:
I noticed that Apple's configuration instructions include this tidbit:

"On the ISA Server, create a Web listener as well as an Exchange Web client access
publishing rule according to Microsoft documentation. This is a necessary step in enabling Exchange ActiveSync."

I have no idea what this means, but I don't even have an ISA Server installed... Is that a problem, and if so, how do I fix it?
0
dmf415Commented:
no, i dont have an ISA server either.
I received that 3005 error once during the whole process.

are you rebooting IIS admin when you removed the activesync virtual server? and when you re-add it you need to reboot IIS admin again.
0
Amit82Author Commented:
Yes, I've rebooted IIS Admin after every change I make.  I've done it a dozen times today alone.  I just wish there was somewhere I could look up and see precisely what error 3005 means.  I've already followed Microsoft's directions for resolving error 3005 and it didn't work.  Although, Microsoft also lists an alternate solution for this error, in case the other solution didn't work.  It might be the only solution that ends up working:

"If these user actions do not let the user synchronize calendar items, move the mailbox of the user specified in the event description to a different Exchange Server computer."

If only I had another Exchange Server computer at my disposal.

But seriously though, can anyone think of anything else I can check that might be triggering this error?
0
dmf415Commented:
Does your iphone display any errors when you are trying to configure it for your exchange server?

settings for the iphone:
email: username@yourdomain.com
server: yourdomain.com
username: yourdomain\username
0
Amit82Author Commented:
If I try to send an email from my iPhone, it just gives a generic error like "An error occured while delivering this message."  However, it just silently fails when trying to sync.

There were no errors displayed when I was configuring the iPhone.  I don't put the domain in front of my username though.  I've tried it before, but everytime I do that it gives me an error saying that my username or password is incorrect and asks for the correct password.  I took that as a sign that it didn't like the domain in front of my username.

I noticed that you used a backslash between your domain and username, so I just tried that and it doesn't give me an incorrect username/password error, but it still fails like before (and still generates a 3005 error in the event viewer).
0
dmf415Commented:
Ya, you need to have the yourdomain\username exactly the way i typed it.  it even shows you to type it that way on the iphone itself.
Delete your exchange email account and try again. Do not just edit your settings on the iphone.  After each step pay close attention to the message at the top of the screen every time you hit "next".

The exact same thing was happening to me to where you just get an inbox with nothing in it until i followed the 30 steps I sent you.

I think you are very close to solving it.  

Mine is working with a self-signed certificate, make sure your self-signed is current. I am getting mine using the microsoft cert server.
0
Amit82Author Commented:
I tried recreating my account on the iPhone instead of just modifying it, and I used the domain\user format for my username.  The messages at the top of the screen said that the exchange account was verified, no errors, everything is great.  But, still no sync when I go to the mail program.  And, still a 3005 error in the event viewer.

I'm wondering... the iPhone is using wifi right now, and the wireless router it's connecting to is on the same local LAN as the mail server... could that be a problem?  I'm going to try turning off wifi on the iPhone and see if that makes a difference.
0
Amit82Author Commented:
Interestingly enough, the last message on the top of the iPhone during configuration is "Configured sync for (null)"  ...  Not sure what that means.
0
Amit82Author Commented:
FYI - turning off wifi made no difference.
0
wolfcamelCommented:
to recap?
is http:\\localhost\oma  working
is http:\\mail.company.com\oma working from another site - out side of your office?
stupid question perhaps but..i assume you phone can browse the internet?
is outlook web access working - i have read rumours that the iphone uses web access - but i doubt this - but you may as well confirm this functionality.
0
Amit82Author Commented:
All of the following sites work, both from inside and outside the network:

http://mail.domain.com/oma
https://mail.domain.com/oma
http://mail.domain.com/exchange    (OWA)
https://mail.domain.com/exchange     (OWA)

The phone definitely can browse the internet.  I've tried configuring the phone's exchange account while connected to wifi and while connected to 3G.

Everything results in the same error:  3005.
0
dmf415Commented:
I got the "Configured sync for (null)" error also.  did you make the registry change you were suppose to make?
0
Amit82Author Commented:
I read somewhere that the "Configured sync for (null)" message only happens if you delete your email profile and then immediately create it again.  If you wait a few minutes after deleting, it will say "Configured sync for Exchange".  I confirmed this on my phone.
0
Amit82Author Commented:
I have resolved this issue.  For future reference, here are the instructions I followed (after following all of the KB articles noted above):

http://www.ureader.com/message/47285.aspx
0
dmf415Commented:
nice!
0
aratcliffeCommented:
Just in case anyone else finds the same problem, I followed the directions above and in doing so found the IP address that was already configured in (see step 19) was wrong - once corrected everything worked immediately. My mistake, as  I built the server with a different IP then changed it to it's production IP - leaving the incorrect IP address in certain IIS default settings.

Andy

12.      Right click on the new virtual directory and choose Properties, in this example, Exchange-OMA.
 
13.      Select the Directory Security tab.
 
14.      Click the Edit button in the Authentication and access control section.
 
15.      Verify only the following authentication methods are enabled:
"      Integrated Windows authentication
"      Basic authentication
 
16.      Click OK.
 
17.      Click Edit under IP address and domain name restrictions. 
 
18.      Click Denied access, and then click Add. 
 
19.      Click Single computer (if this option is not already selected), type the IP address of the server that you are configuring, and then click OK.

Open in new window

0
scashman1Commented:
I added an iPhone 3GS to our SBS 2003 network with Exchange Server 2003 SP2 and struggled at first to get the iPhone to work. I had other Windows phones working fine. For me, the issue was the configuration on the phone - in particular the "Domain" entry. When I entered the Domain, not luck. When I left it blank, everything works. Hope this helps.
iPhone 3Gs settings:
Email: username@domainname.com
Server: mailserver.cashmanstahler.com
 Domain: (No entry)
 Username: (network user name)
Password: (Current network password)
 Description: Whatever
Use SSL: On
Good luck.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.