We help IT Professionals succeed at work.

Remote Web Workplace and ClientHelp display "404 NOT FOUND" when connecting externally

886 Views
Last Modified: 2008-11-17
I am trying to setup RWW to connect externally.  I've been doing pretty good lately and have OWA and OMA working.

I am able to connect to my internal website by using:  https://mail.mycompanyname.com/

This takes me to default.aspx and inside I click Remote Management and it comes up with a login box and I put my credentials in and it displays again and I repeat the credentials and then a blank page appears that says, "404 NOT FOUND" and that's it.  The same thing happens if I try and click anything that links with ClientHelp.

I am able to get to clienthelp and RWW internally and everything else is working fine.  I have all the necessary ports open in ISA 2004 and I'm running SBS 2003.  I think it's a problem with authentication in ISA 2004, but everything I've tried hasn't worked.

Thanks.
Comment
Watch Question

should be..
https:\\mail.mycompany.com\remote

from external
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I get the same thing when I type:
https://mail.mycompanyname.com/remote/

internally that address works fine and I get the RWW front page with login there, instead of the login box.

I have port 4125 open

I reran the wizard and it still didn't work.

Thanks for the help.

Author

Commented:
I need some help?

The Windows diagnosis says that my home is not blocking 4125 so it has to be something else.  Basically I think its something with authentication since the login popup boxes are appearing.   Anyone got any ideas?

Please!  

Author

Commented:
Hi Wolfcamel,

I got RWW to work externally, but now when the client pops up to connect it tries to connect and won't go in.

I have watched ISA logging simultaneously and it is blocking all unrecoginized IP addresses.  I want it to allow all addresses in as long as you have credentials.  I thought I had all the rules to allow external in, but maybe not?
is port 4125 open at the work end? ie is your work router forwarding port 4125 traffic to the ISA server?

Author

Commented:
I have TCP 4125 open inbound and outbound on ISA 2004 and also on client computers.
and is your router forwarding all traffic to the isa server?
or is your isa server directly connected (ie has an internet address on one network card)

there is also a known issue with rww and xp sp3 client (on the outside) where it disables the rww active x component addin. The RWW page thinks the addin is there so it doesnt prompt, but XP wont start it up.
tools, internet options, programs, manage addon, make sure the remote desktop addon is enabled.

Author

Commented:
Yea I made sure the ActiveX was working correctly.

I'm on a single server with 2 NIC's that runs sbs 2003, isa 2004, and exchange 2003.

I have OWA and OMA working great.  I can remote desktop connection into the server no problem, but with RWW and VPN it's not recognizing the IP address even though it should allow all in?

I'm going to check my router at home and allow all traffic to my server.
sometimes move the rule up the list - another rule could be blocking first

quickly double checked on my isa server..
sbs rww web publishing rule
allow, http and https, sbs web listener,
from: anywhere
to: publishing.server.local. forward original host head, requests from original client

also have a sbs rww inbound access rule

Author

Commented:
I have the inbound access rule for TCP 4125.
Everything is in place except my
RWW Publishing Rule has
to:  mail.mycompanyname.com, forward original host, fronm original client

when I view it in logging.  the rule blocking is the last rule:  default rule
it should be forwarding to the internal ip - such as localhost - it looks like it is forwarding to the same name it is listening on

Author

Commented:
I mean the rule is definitely setup correctly.   I can RWW internally and connect fine, that's why it's something with the the firewall blocking the IP's.

Author

Commented:
Ok.  I just ran home from work and I enabled all ports into my ISA Server as well and it still didn't work.  It's something with ISA, but I can't figure it out.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.