troubleshooting Question

Cisco ASA 5505 Messagelabs mail and a VPN

Avatar of jeffwingo
jeffwingo asked on
VPNHardware FirewallsCisco
13 Comments1 Solution709 ViewsLast Modified:
I saw a post in January that attempted to answer this question and I followed the advice, but to no avail.

Here is my configuration. I have 5 public IPs (.248 subnet). The outside interface is set as xxx.xxx.xxx.37. I have an internal network 192.169.15.0. My exchange server is 192.168.15.2 and its Public IP is xxx.xxx.xxx.36.

I want accept smtp only from Messagelabs that directs our email to the .36 address.

Right now every thing works except incoming e-mail and the VPN. Any suggestions would be helpful. Here is my config.



ASA Version 8.0(2)
!
hostname kwcc-asa
domain-name kingsway.local
enable password hdkjhahhfjhR encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.15.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xxx.xxx.xxx.37 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 68.87.73.242
 name-server 68.87.71.226
 domain-name kingsway.local
access-list kwccvpn_splitTunnelAcl standard permit any
access-list outside_access_in extended permit tcp 193.109.254.0 255.255.254.0 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp 194.106.220.0 255.255.254.0 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp 195.245.230.0 255.255.254.0 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp 216.82.240.0 255.255.240.0 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp 85.158.136.0 255.255.248.0 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp 117.120.16.0 255.255.248.0 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp host 195.216.16.211 host xxx.xxx.xxx.36 eq smtp
access-list outside_access_in extended permit tcp host 212.125.74.44 host xxx.xxx.xxx.36 eq smtp
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool vpnpool 192.168.15.151-192.168.15.180 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
global (outside) 2 xxx.xxx.xxx.36 netmask 255.255.255.248
nat (inside) 2 192.168.15.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0 dns
static (inside,outside) xxx.xxx.xxx.36 192.168.15.2 netmask 255.255.255.255
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.38 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
eou clientless username xxxxxxx
eou clientless password xxxxxxxxxx
http server enable
http 192.168.15.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.15.2-192.168.15.129 inside
!

threat-detection basic-threat
threat-detection statistics
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
group-policy xxxxxx internal
group-policy xxxxxx attributes
 wins-server value 192.168.15.2
 dns-server value 68.87.73.242 68.87.71.226
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value kwccvpn_splitTunnelAcl
 default-domain value kingsway.local
username....
 vpn-group-policy xxxxxx
tunnel-group xxxxxx type remote-access
tunnel-group xxxxxx general-attributes
 address-pool vpnpool
 default-group-policy xxxxxx
tunnel-group xxxxxx ipsec-attributes
 pre-shared-key *
prompt hostname context
Cryptochecksum:17bdf7e9966fd53c17a97e015c0c4d66
: end
asdm image disk0:/asdm-602.bin
no asdm history enable

Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 13 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 13 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros