We help IT Professionals succeed at work.

Error installing Oracle Grid Control 10R2 on W2K3 x32

1,006 Views
Last Modified: 2013-12-18
I am having issues with the installation of Oracle Grid Control 10gR2 on a clean Windows 2003 x32 Platform. The installation type selected has been to use an 'existing database' located on a separate Oracle server. *There are no Oracle databases installed on the application server I am attempting the 10g2 Grid Control installation on.

When the installation progresses to the 'OMS Configuration' stage of the installation, it fails and will not progress any further. It appears that the installation is writing to the database correctly as the 'sysman' schema is being successfully populated with various database items. I am unsure whether certain permissions or parameters are incorrectly configured causing some of the objects to compile but not others. I am also having some trouble identifying which of the errors detailed in the error log are the ultimate cause of the OMS Config failing during the installation.

Relevant error log files are attached. Any help that can be provided here would be greatly appreciated. Thanks.
emca-repos-create12-00-28.log
CfmLogger-2008-08-11-11-46-13-AM.log
configToolFailedCommands
emoms.log
Comment
Watch Question

TolomirAdministrator
CERTIFIED EXPERT
Top Expert 2005

Commented:
Well I did setup gridcontrol on windows 2k3 and on Linux SLES 10.

Each time I did setup gridcontrol with it's own database. Even then I had some minor issues, that I could cope with.

Well I suspect you try to install the repository on the wrong database version.

As far as I know Grid Control 10GR2 can only be installed in an oracle 10.1 database.

So I suggest you try to install grid control with it's own database - doesn't need too much space and should be tested by oracle.

Tolomir

Author

Commented:
I'm running Oracle 10.2.0.1.0 64-bit on an AIX platform. I can see releases up to version 10 Patch 4 but they don't seem to contain the base install of the grid control software. Is there a more recent version of Grid Control for Oracle 10g that I should be using for Oracle 10.2.0.1.0??
Thanks.
TolomirAdministrator
CERTIFIED EXPERT
Top Expert 2005

Commented:
Well you would use this:

Oracle Enterprise Manager 10g Grid Control Release 2 (10.2.0.2) for Microsoft Windows (32-bit)

and later upgrade to this:

Oracle Enterprise Manager 10g Grid Control Release 3 (10.2.0.3) for Microsoft Windows (32-bit)

---

During setup of the grid control you are asked to

* make a full installation including database setup
* make an installation and use a predefined database

At least that is what I had on windows and Linux-64

Sorry I cannot deal with screenshots, since I'm at home.



Author

Commented:
I've selected the option to 'use an existing database'. The database is Oracle 10.2.0.1.0. This seems to work fine for the most part but error's out during the 'OMS Setup' during the final stages of the installation (see the error logs attached to the original post).
TolomirAdministrator
CERTIFIED EXPERT
Top Expert 2005

Commented:
Regarding the oms I only had an issue with the service opmn already running, I did simply stop and restart the service. Then the issue was solved. (Ignore might even work)

So do you miss anything after the setup?





TolomirAdministrator
CERTIFIED EXPERT
Top Expert 2005

Commented:
Oh I see the setup did not finish.

Well if you got the time I suggest you try to use the create own database option. Of cause you can open a ticket on metalink (with a valid support contract).

I did install grid control serveral times now, and in the end I did use that setup that worked for me, regardless if on windows or unix in the end.

Last time I've tried the new software install on 10.2.0.3 (for linux 64 bit) and then patched with the new 10.2.0.4 - I did it three times every time I had some library, compiling errors. In the end we stuck with the working grid control 10.2.0.3 and everything is working safe and sound.

Sorry but I cannot help you any further as it seems,
Tolomir

Author

Commented:
None of the Oracle services are started at the point at which the OMS Configuration fails. I have verified that my database is configured with the appropriate initialisation parameters as per the Oracle Installation guide.
OMS-Configuration-Error-Message.JPG
TolomirAdministrator
CERTIFIED EXPERT
Top Expert 2005

Commented:
Yes, I checked the log files - my problem here: I see only warnings no errors even though, oracle setup calls warnings errors...

Errors for PACKAGE BODY MGMT_PREFERENCES:

LINE/COL ERROR
-------- -----------------------------------------------------------------
581/12   PLW-07202: bind type would result in conversion away from column
         type


From metalink:

Cause

The cause of the warning is due to Bug <5895688>  PLW-07202 BIND TYPE WOULD RESULT IN CONVERSION AWAY FROM COLUMN TYPE.

The data type 'timestamp with time zone' used in the PL/SQL Stored Procedure (returned by systimestamp) has a different internal representation then in SQL.  The SQL engine sees the difference and has to generate a conversion to the SQL representation of 'timestamp with time zone' which is used for the column.  This conversion generates the warning message.

The warning message indicates that the column type and the bind type do not exactly match and will result in the column being converted to the type of the bind variable. This type conversion may prevent the SQL optimizer from using any index the column participates in which may adversely affect the execution performance of this statement.

Solution

The warning can be ignored so long as the column does not participate in an index.
Administrator
CERTIFIED EXPERT
Top Expert 2005
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.