troubleshooting Question

Outlook Web Access 'Bad Request' When Viewing Emails

Avatar of comphil
comphilFlag for United Kingdom of Great Britain and Northern Ireland asked on
ExchangeSBS
6 Comments1 Solution5703 ViewsLast Modified:
Hi there,

I am supporting a server which is about 1 year old and runs Windows Small Business Server 2003 (fully up to date).  Normally it behaves fine but recently a new problem has emerged:

When using Outlook Web Access, you can log in fine, but any user I've tried has problems opening/replying/forwarding emails which have long subject lines (such as the Working Remotely with Windows Small Business Server email) or contain characters like : (colon) .  There doesn't appear to be one defining characteristic with all the affected emails.

When opening them, instead of the message pane on the righthand side, I get an error page stating:

Bad request
The page that you are looking for might have been removed, had its name changed, had its content expired, or is temporarily unavailable.

Please try the following:

    * Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
    * If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
    * Click the Back button or open the home page for this Web site and look for other links to the information that you want.

HTTP Error 400 - Request is badly formed.
Internet Information Services (IIS)

Technical Information (for support personnel)

    * Go to Microsoft Product Support Services and perform a title search for the words HTTP and 400.
    * Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Web Site Administration, and About Custom Error Messages.

One-word subject emails seem to be fine.  I've tried everything I can think of but have had no joy.  It doesn't appear to have any relation to a similar problem on an MS KB where the HTTP Error is to do with the URL being too long.  I've tried the 3 registry fixes as suggested anyway with no luck.  Have also downloaded .NET Framework 1.1 SP1 but it won''t apply so I appear to have the latest version.

Can anyone help?

Thanks in advance.

Phil

Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 6 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 6 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros