troubleshooting Question

Problem with wsus 3.0 on windows 2003 server can not remove or reinstall

Avatar of BarepAssets
BarepAssetsFlag for Ireland asked on
Server HardwareOS SecurityMicrosoft Forefront ISA Server
1 Comment1 Solution1732 ViewsLast Modified:
HAving a problem with wsus 3.0. After a reboot there was a failure in connection to the database when opening the wsus admin console. I noticed under task mgr that sqlserver.exe ( it is instance of sql on the server it does not access a remote sql server) was not running when i tried to restart the exe it gave an error that sql could not be started reinstall mssql. I decided to go ahead with a reinstallation of wsus altogther  When i reinstalled it gave an error in installation below are the log files

setup log file

2008-08-12 16:23:22  Success   MWUSSetup          Validating pre-requisites...
2008-08-12 16:23:23  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed. Assuming it is not... (Error 0x80070002: The system cannot find the file specified.)
2008-08-12 16:23:23  Error     MWUSSetup          Failed to open C:\Program Files\Update Services\Setup\Eula.rtf file for reading (Error 0x80070002: The system cannot find the file specified.)
2008-08-12 16:23:32  Success   MWUSSetup          Initializing installation details
2008-08-12 16:23:32  Success   MWUSSetup          Installing ASP.Net
2008-08-12 16:24:07  Success   MWUSSetup          ASP.Net is installed successfully
2008-08-12 16:24:07  Success   MWUSSetup          wYukon is already installed on this machine
2008-08-12 16:24:07  Success   MWUSSetup          Installing WSUS...
2008-08-12 16:24:07  Error     MWUSSetup          InstallWsus: MWUS Installation Failed (Error 0x80070003: The system cannot find the path specified.)
2008-08-12 16:24:07  Error     MWUSSetup          CInstallDriver::PerformSetup: WSUS installation failed (Error 0x80070003: The system cannot find the path specified.)
2008-08-12 16:24:07  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070003: The system cannot find the path specified.)

setup msi log file


=== Verbose logging started: 12/08/2008  16:24:07  Build type: SHIP UNICODE 3.01.4000.4042  Calling process: C:\Program Files\Update Services\Setup\WusSetup.exe ===
MSI (c) (9C:74) [16:24:07:835]: Resetting cached policy values
MSI (c) (9C:74) [16:24:07:835]: Machine policy value 'Debug' is 0
MSI (c) (9C:74) [16:24:07:835]: ******* RunEngine:
           ******* Product: C:\Program Files\Update Services\Setup\SUS\WUSSetup.msi
           ******* Action:
           ******* CommandLine: **********
MSI (c) (9C:74) [16:24:07:851]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (9C:74) [16:24:07:851]: Grabbed execution mutex.
MSI (c) (9C:74) [16:24:07:897]: Cloaking enabled.
MSI (c) (9C:74) [16:24:07:897]: Attempting to enable all disabled priveleges before calling Install on Server
MSI (c) (9C:74) [16:24:07:897]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (14:24) [16:24:07:929]: Grabbed execution mutex.
MSI (s) (14:90) [16:24:07:929]: Resetting cached policy values
MSI (s) (14:90) [16:24:07:929]: Machine policy value 'Debug' is 0
MSI (s) (14:90) [16:24:07:929]: ******* RunEngine:
           ******* Product: C:\Program Files\Update Services\Setup\SUS\WUSSetup.msi
           ******* Action:
           ******* CommandLine: **********
MSI (s) (14:90) [16:24:07:929]: Note: 1: 2203 2: C:\Program Files\Update Services\Setup\SUS\WUSSetup.msi 3: -2147287037
MSI (s) (14:90) [16:24:07:929]: MainEngineThread is returning 3
MSI (c) (9C:74) [16:24:07:944]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (9C:74) [16:24:07:944]: MainEngineThread is returning 3
=== Verbose logging stopped: 12/08/2008  16:24:07 ===

I noticed that the sqlserver.exe is back running fine now though but still error in connection to database i decided to go ahead with a removal of wsus and then reinstall. when i tried to do it in add remove programs it is giving me an error command line parameters not valid

check log file below is the

2008-07-31 16:37:26  Success   CustomActions.Dll  The system language ENI is not supported. Using English resources...
2008-07-31 16:37:26  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
2008-07-31 16:37:26  Error     CustomActions.Dll  SetUninstallProperties: Failed to open WSUS registry key: SOFTWARE\Microsoft\Update Services\Server\Setup (Error 0x80070002: The system cannot find the file specified.)
2008-07-31 16:57:03  Success   CustomActions.Dll  The system language ENI is not supported. Using English resources...
2008-07-31 16:57:03  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
2008-07-31 16:57:03  Error     CustomActions.Dll  SetUninstallProperties: Failed to open WSUS registry key: SOFTWARE\Microsoft\Update Services\Server\Setup (Error 0x80070002: The system cannot find the file specified.)
2008-08-06 18:30:01  Success   CustomActions.Dll  The system language ENI is not supported. Using English resources...
2008-08-06 18:30:01  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
2008-08-06 18:30:01  Error     CustomActions.Dll  SetUninstallProperties: Failed to open WSUS registry key: SOFTWARE\Microsoft\Update Services\Server\Setup (Error 0x80070002: The system cannot find the file specified.)
2008-08-11 10:19:17  Success   CustomActions.Dll  The system language ENI is not supported. Using English resources...
2008-08-11 10:19:17  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
2008-08-11 10:19:18  Error     CustomActions.Dll  SetUninstallProperties: Failed to open WSUS registry key: SOFTWARE\Microsoft\Update Services\Server\Setup (Error 0x80070002: The system cannot find the file specified.)


SO appears having issue finding reg keys So i installed a fresh copy on another server and imported the hkey_local_machine\software\microsoft\update services reg key. still will not let me uninstall

When i go into the console now it is not giving an error it just has no listing of servers to manage when i try to add my server it is giving error cannot connect to server maybe using a different port. I know i am using port 80.

I then checked services the update service will not start it is giving the error

could not start start update service on local computer error 1067 service terminated unexpectly

I am bit lost on how to proceed it will not let me unistall or reinstall i would prefer not to go down the route of rebuilding the whole server if all possible anyone got any ideas?????
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 1 Comment.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros