We help IT Professionals succeed at work.
Get Started

Need Help Setting up QoS on a Cisco Catalyst 2950

1,542 Views
Last Modified: 2012-06-27
In this environment there is a Cisco Catalyst 2950 which needs to have QoS implemented on it as there will soon be VoIP traffic traveling on it.  I have implemented and verified QoS settings, etc. on all devices except this Catalyst switch.  The IP Phones will mark the voice packets with a DSCP of 46.  The phones do not mark any other fields such as the CoS, IP precedence, and so on.  With that said, any packets which traverses the switch with a DSCP of 46 need to receive priority over all user traffic.

Below youll find the Version, CoS and DSCP mappings (should be 5-to-46 and 46-to-5), and the running configuration.  I started to setup the WRR queuing, where a CoS of 5 is put in the highest priority L2 Queue.  However I do not have a good comfort level with this switch.  

Please let me know if you need more information

Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(13)EA1b, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Tue 15-Apr-03 12:25 by yenanh
Image text-base: 0x80010000, data-base: 0x805A8000
 
ROM: Bootstrap program is CALHOUN boot loader
 
cisco2950 uptime is 35 weeks, 6 days, 20 hours, 42 minutes
System returned to ROM by power-on
System image file is "flash:c2950-i6q4l2-mz.121-13.EA1b.bin"
 
cisco WS-C2950-24 (RC32300) processor (revision L0) with 20839K bytes of memory.
Processor board ID FOC0802T188
Last reset from system-reset
Running Standard Image
24 FastEthernet/IEEE 802.3 interface(s)
 
32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0F:23:0B:66:40
Motherboard assembly number: 73-5781-12
Power supply part number: 34-0965-01
Motherboard serial number: FOC08021VFX
Power supply serial number: PHI075106PG
Model revision number: L0
Motherboard revision number: B0
Model number: WS-C2950-24
System serial number: FOC0802T188
Configuration register is 0xF
 
cisco2950#sh mls qos maps dscp-cos
 
   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7
 
 
cisco2950#sh mls qos maps co
cisco2950#sh mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56
 
cisco2950#sh run
Building configuration...
 
Current configuration : 3233 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco2950
!
aaa new-model
enable password 7 0110120D0253
!
username admin password 7 094F5A00405D
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 3
wrr-queue cos-map 3 4
wrr-queue cos-map 4 5 6 7
ip subnet-zero
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/2
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/3
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/4
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/5
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/6
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/7
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/8
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/9
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/10
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/11
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/12
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/13
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/14
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/15
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/16
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/17
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/18
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport mode access
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport access vlan 10
 switchport mode access
 no ip address
 duplex full
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/21
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/22
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/23
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface FastEthernet0/24
 no ip address
 mls qos trust cos pass-through dscp
 spanning-tree portfast
!
interface Vlan1
 ip address 10.0.0.22 255.255.255.0
 no ip route-cache
!
ip http server
!
!
line con 0
line vty 0 4
 password 7 070C35451751
line vty 5 15
 password 7 070C35451751
!
end
 
cisco2950#

Open in new window

Comment
Watch Question
Systems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE