resycled\boot.com is not valid win32 application when i cick my drive

hi,
recently i had virus in my comp called win32.worm.autorun.MQ i restored my windows through restore after cleaning up when i click on my drive it gives me error saying "resycled\boot.com is not valid win32 application" when i right click the drive the frist option is autorun is use to be open ....the 2nd option is open..when i click open option i get error win32 is not valid application ..3rd option is search n 4th is explorer however i can acces my drive through explore option ..
can anyone plss tell how can i restore this plssssss

Im using Windows Xp Sp2
Antivirus Bitdefender total security 2008
spybot search and Destroy 1.6
mohamednanabhaiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mohamednanabhaiAuthor Commented:
sorry i made a mistake the first option when i right click my drive is not Autorun its AutoPlay
0
mohamednanabhaiAuthor Commented:
ok i got the answer here is the solution..

If your hard drive right-click menu has an "autoplay" option,it maybe some Trojan horse on your hard drive.

First,reboot your system and get into the safe mode.
Second,change setting to show all files on your hard drive
Then,if there is a file which name is "autorun.inf"under your hard drive's root directory,delete it.
You must delete the Trojan horse under the hard drive's root directory and delete the start-up option of it
After that,reboot your computer.
All done!
Now look at your hard drive right-click menu,the "autoplay" option is disappeared.
Post Reply
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mohamednanabhaiAuthor Commented:
or the solution is

Most of my friends on my network always has this problem.Yesterday this problem even creeped into my PC.So,I did some search about this thing and found the solution.This problem is named as "Hacked by Godzilla Virus " by the people.It creates a auto play option on the right click menu of your hard disk drives making you unable to open them by double clicking.However you can open them by rightclick -->Open or Explore.It changes the text of Internet Explorer title bar to "Hacked by Godzilla".Now here is the solution :

    * Go to any folder.In that on the top menu go to Tools--> Folder Options , which will be beside File,Edit,View,Favourites.
    * A window pops up after you click on folder options.In that window go to View tab and select the option Show hidden files and folders.Now uncheck the option Hide protected Operating system files.Click Ok
    * Now Open your drives (By right click and select Explore. Don't double click!) Delete autorun.inf and MS32DLL.dll.vbs or MS32DLL.dll (use Shift+Delete as it deletes files forever.) in all drives include Handy Drive and Floppy disk.
    * Open folder C:\WINDOWS to delete MS32DLL.dll.vbs or MS32DLL.dll (Use Shift+Delete )
    * Go to start --> Run --> Regedit and the Registry editor will open
    * Now navigate in the left pane as follows: HKEY_LOCAL_MACHINE --> Software --> Microsoft --> Windows --> Current Version --> Run .Now delete the entry MS32DLL (Use Delete key on keyboard)
    * Go to HKEY_CURRENT_USER --> Software --> Microsoft --> Internet Explorer --> Main and delete the entry Window Title Hacked by Godzilla
    * Now open the group policy editor by typing gpedit.msc in Start --> run and pressing enter.
    * Go to User Configuration --> Administrative Templates --> System . Double Click on entry Turn Off Autoplay then Turn Off Autoplay Properties will display.Do as follows:
          o Select Enabled
          o Select All drives
          o Click OK

    * Now go to start --> Run and type msconfig there and press Enter.A system configuration utility dialogue will open.
    * Go to startup tab in it and uncheck MS32DLLNow click Ok and when the system configuration utility asks for restart ,click on exit without restart.
    * Now go to Tools --> Folder Options on the top menu of some folder again and select the Do not show Hidden files and check Hide operating system files.
    * Go to your recyclable bin and empty it to prevent any possiblity of MS322DLL.dll.vbs lying there.
    * Now restart your PC once and you can now open your hard disk drives by double clicking on them.

If you have any tips & tricks,Don't forget to send me along with your link,So that I can link you back.
If you want more tips & tricks ,subscribe to this blog or click here to get email updates.
0
frenchbrochierCommented:
Thanks This worked for fro me on my tablet.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.