We help IT Professionals succeed at work.

PC won't boot with USB MyBook connected but will if it's not connected

davidcowler
davidcowler asked
on
4,222 Views
Last Modified: 2013-11-14
Hi Experts

I have just bought a 1TB WD MyBook Essential Edition (USB) but if I boot the PC with it connected, it hangs. I get the message 'Auto detecting USB mass storage devices... Device #01 STG12002 1AS... Device #02.... 0078'

The device 01 is my exisitng USB drive which has always worked fine and still does. The 02 is the MyBook. The 0078 appears in the very bottom right corner of the screen, after which the computer will not respond to anything, not even ctrl+alt+del.

WD support told me to switch off USB Legacy support in the BIOS, which I did, but it stil does the same thing. I should point out that before rebooting the PC after initial installation, I reformatted the drive to NTFS (was FAT32) and changed the drive letter initally assigned by Windows (XP SP3). I tried to reformat it to FAT32 but Windows won't let me, not even if I delete and recreate the partition.

I do not want to have to keep disconnecting and reconnecting the drive, so if anyone knows of a surefire way of solving this I would be eternally grateful :)

Otherwise it's going back to the shop!!

Thanks.
Comment
Watch Question

Retired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Hi

Before I fiddle with the BIOS, if it was trying to boot from the WD drive, why has it never attempted to boot from my other USB drive? The reason I was trying to reformat to FAT32 was because I found an answer to this query where someone had totally restored their drive to 'out of the box' status and got it to reboot successfully like that BEFORE changing the drive letter and formatting. Do you know if FAT32 formatting takes longer than NTFS? Because that took about 3 to 4 hours after recreating the partition.

Thanks
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
It depends on how the partition structure is "seen" by the BIOS --> whether it's active; whether or not it has the appropriate boot flags; etc.

You simply need to adjust the way the BIOS looks for its boot volumes and all will be fine.   If you're uncomfortable making BIOS changes, just be sure you WRITE DOWN exactly what a setting WAS before you change it (and also write down what you changed it to) ==> then if you make any errors (unlikely) it will be simple to restore it back to the way it was.   But what you need to change is very innocuous -- and very simple.
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
... Formatting a 1TB drive will take a long time no matter which format option you use.   You can, however, select "quick format" and it will be very quick [It will just write the headers and won't check every sector].

Author

Commented:
OK, I've checked the BIOS and it seems ok. I have two identical SATA drives in the computer, not set up for RAID though, just separate drives.

My BIOS has a USB Configuration screen with three options:
  USB Controller [Enabled]
  USB 2.0 Support [Enabled]
  Legacy USB Support [Disabled on Western Digital's advice]

The boot sequence only shows three devices. These are currently set to:
  1 - RAID (that's what it calls the SATA drive but as they are identical I'm not sure which one it refers to here)
  2 - RAID
  3 - USB drive (my existing one which works fine)

I can change the sequence of these, and the choice is RAID, RAID, USB, Disabled.
Does this help you at all?
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
Are you sure there's no "drive order" option in the BIOS?

I suspect the only thing you need to do here is change the "active" flag on the MyBook --> it's most likely flagged as Active ... and your system is attempting to boot from it.

Go to Disk Management and right-click on the current partition for the MyBook.   If the "Mark Partition as Active" option is "greeked out" (not available) then it's already active -- and that's most likely the problem.

I believe Swiss Knife (the tool I suggested above) will let you change that (Disk Management will not).   If not, I can detail another way to do it ... but I'm heading out the door as I write this and will be gone until late tonight.

Author

Commented:
There is an available option of 'Mark partition as active' so it would seem it's not 'active'. Only my C: drive has this greyed out.
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
In that case this must simply be some setting in the BIOS.   By the way, I would leave legacy USB support enabled -- if you ever need to use a USB keyboard or mouse they'll be much more reliable with that setting (and it's unlikely this is the issue here).   Look VERY carefully to see if you can find a "drive order" setting "hidden" in the BIOS ... unfortunately these are not always very intuitive.

If that doesn't work, try deleting the partiiton on the drive and re-formatting it.   If you want to try using FAT32 you can use Swiss Knife ... but that shouldn't be necessary.   In fact ... it would be instructive to know if this is the partition or something about the MBR that's causing the issue => to find that out, delete the partition ... and then try booting & see if it still hangs with no partitions on the drive.   If THAT is a problem, then you need to wipe the MBR as well.

Author

Commented:
OK, will try those suggestions. Just got in from work and have to go straight back out again so won't be tonight (tonight being UK time). I have already tried deleting the partition and reformatting (but still to NTFS) and that obviously didn't help. Is there any way I can view the MBR info?
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
I do all my partition work with Boot-It NG [http://www.terabyteunlimited.com/bootit-next-generation.htm ], which easily lets you see and/or modify the MBR -- but it's a bit "geeky" ... and I'm going to be gone the rest of the day so won't be able to walk you through it.

I don't recall whether or not Swiss Knife allows manipulating the MBR or not (haven't used it in a while) ... but have a look at the menus and see if you can reset the MBR.   In any event, I'd try a FAT32 format and see if that resolves things.

Author

Commented:
Hi there

Thanks for all your help but it isn't working and I've wasted too much time on this and had too many late nights! I'm exhausted! I'm sure the BIOS holds the secret somewhere but I can't make it work so I'm taking it back to the retailer later today. I'll give you the points anyway.

Cheers
D

Commented:
I'm actually having a similar issue with my MyBook.  Mine is a 320GB, connected via Firewire to a relatively beefy system.  The thing is, my system will boot but it hangs on the XP loading screen and the progress meter just loops infinitely.  If it's disconnected, it boots right up in about four passes, connected it hangs forever so it isn't a matter of boot order, just something causing the system to not boot.  Unplugging it during the process doesn't help, but if it's unplugged from the get-go things are fine.  Annoying to be sure.  I'm going to look for answers, just found this thread first and figured I'd chime in :D

Commented:
I've had the same problem with a 1TB WD MyBook Essential connected to my HP pavilion desktop. Plugged it in, partitioned it and formatted with ntfs with no problems, however .... when I re-booted PC just hung at the bios setup screen. Already had a WD 320g MyBook which I've had connected for a couple of years with no probs. Tried connecting the 1TB to my laptop and it booted ok so a pc problem rather than the drive.

The boot order in the BIOS was all correct. So i tried setting the "USB Legacy Mode Support" from "Auto" to "Disabled" and this fixed the problem (well its been fine the last couple of days touch wood). My keyboard and mouse have PS/2 connectors so this is not a problem for me.

Just thought I'd post this in case anyone else is having the same problem ... obviously it's not the solution in all cases.
Same issue here with a 500GB MyBook Essentials and Windows 7.  I actually had boot to USB devices disabled but my Intel motherboard supports a boot optimization mode that I had enabled (it skips booting optical devices for example, but doesn't skip USB devices).

The solution for me was to disable the boot optimization mode and enable boot to USB devices, then set the MyBook in the boot order after my hard drive.

I'm sure curious why this affects WD MyBook devices.  If I had to guess I'd say this problem has more to do with their built-in controller than what's on the drive itself.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.