Gigabit ethernet slow performance

Hello,

I'm trying to setup a NAS box and i'm experiecing slow performance. Here is my setup

Dell 2950 running debian etch attached to a 24port Gigabit HP Procurve Switch
PC Quad Core phenom with Ubuntu 8.04 attach to the same switch with on board pcie lan adapter (Realtek 8111/8168B)
I was using cat5e patch cords but change them to cat6 just in case.

Using iperf i get a throughput of 936-940Mbits/sec. This being very close or confirming the theoretical 1000Mbits/sec.

I've also tried Ixia testesting software giving me simular results.

When i do a file transfer, 700MB iso file, i get about 28-30 MB/sec. I say that this is a least half of what i was expecting. What is max MB/sec that someone could get? What should i check or change so i can have decent file transfers.

I measured the file transfer using ftp (2 programs) and rcp.

Thank you
Teo



temmelvAsked:
Who is Participating?
 
pseudocyberCommented:
Take a look at your HP switch ports - any errors?  If so, check duplex.
0
 
temmelvAuthor Commented:
Also i forgot to mention the hard disk performance.

hdparam -Tt shows
Timing buffered disk reads
88MB/sec on the Dell and
70MB/sec on the pc


Thank you.
Teo
0
 
temmelvAuthor Commented:
I will, but if i had errors would i be getting 940Mbtis/sec throughput?

0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
pseudocyberCommented:
Possibly.  Duplex mismatch REALLY shows up when doing large file transfers.  Much less when doing "small" testing - such as ping, etc.  As Windows sizes increase there's a much greater impact with frame corruption and TCP retransmission.
0
 
temmelvAuthor Commented:
Both ports are defined 1000FDx

I ran the test a couple of times. No errors.

I got 29MB/sec the first time and 43MB/sec the second time. I guess it is cached.

I did a copy then on new file (400mb rar file) and it gave me 32MB/sec. No errors.

0
 
pseudocyberCommented:
Hmm. the no errors means you don't have an ethernet problem.  For the heck of it, try setting both the NIC, Switch, and NAS to Autonegotiate.
0
 
temmelvAuthor Commented:
How do i set Autonegotiate. The switch port configuration options are 2

1. Mode (10, 100FDx, Auto, Auto-10,Auto-100,Auto-1000)  and
2. flow control (Disable, Enable). Disable is set.



0
 
pseudocyberCommented:
Auto-1000
0
 
temmelvAuthor Commented:
Can you tell me what transfer rates are you experiencing or what a very good transfer rate is?

0
 
pseudocyberCommented:
No not really.  I'm a network guy, not a storage (NAS) guy.  However, if you get 80% of the maximum theoretical throughput with Ethernet, you're doing pretty well.  But it depends on a lot of factors - the interfaces, the cabling, environmental, machine - cpu, memory, disk I/O, etc.

Also different protocols will give you different throuput - because the protocol itself occupies a portion of your throughput.

However, I calculated yours out, based on your numbers, and you're getting around 250Mbps.  I would expect higher.
0
 
temmelvAuthor Commented:
Well i tried Auto-1000. Rebooted both machines.

I got 27,9MB/sec. I then set Auto to both ports rebooted. I got 26,8MB/sec. This is a small difference, i consider this the same.

If i execute again the copy in both situations i get 49,8/sec.
0
 
pseudocyberCommented:
Yeah, I agree.  However, it helps you in that it sort of "clears" the network - so now you can pursue other avenues. :)
0
 
temmelvAuthor Commented:
It seems it's not the network.

I rebooted both machines i did the copy the opposite way. From the Dell 2950 to the pc with a single SATA II driver.

I got 46,5MB/sec. I did this test twice rebooting both machines.

So it has to do with the write performance of the drives. Even though 46,5MB/sec is really crappy performance for a SATA II drive.

I also executed again the copy command giving me the exact same rate as i had in the first place with the pc copying to the dell, that is 49,8MB/sec. So this is cached, but why is it limiting to 49,8MB/sec?
0
 
joolsCommented:
You may need to check what network modules are being used, sometimes linux *may* pick the wrong one. There may also be some configurable options for them as well. Use modinfo to help here.

Also, mii-tool or ethtool will let you know speed/duplex settings and allow you to change them on the host
0
 
pseudocyberCommented:
I think points should be split - but I don't understand you're giving points to the author?

I did a fair amount of troubleshooting showing that it's NOT "gigabit ethernet slow performance".  I think it should count for something.

Thanks,

PC
0
 
pseudocyberCommented:
Edit - points to the questioner.
0
 
temmelvAuthor Commented:
Post ID's
22594999
22595016

Author:pseudocyber

Thank you
0
 
pseudocyberCommented:
Thanks.
0
 
Darr247Commented:
Have you tried disabling flow control on either end?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.