We help IT Professionals succeed at work.

GPO proxy settings not getting applied on IE7

vikasjus
vikasjus asked
on
1,143 Views
Last Modified: 2013-12-08
Hi,

I have IE7 installed on XP Prof. SP3 system. When we configure Proxy IP assignment to user desktops, GP policy wont get applied to IE7 browsers.
GPRESULT shows required rsop results but IE7 is not picking them and stops net surfing.
I have done all GP settings that i could get on net while searching for this problem, but no luck.
I tried uninstalling IE7 and it worked with IE6. For some reason we need to be on IE7. Can some one guide us to resolve this issue?

VJ
Comment
Watch Question

it may be something like google toolbat, or the antivirus is "protecting" you from IE changes.
Make sure you have appropriate .ADM Administrative Template files installed on the computer you use to create / edit your GPOs.

Here: http://www.microsoft.com/downloads/details.aspx?FamilyID=11AB3E81-6462-4FDA-8EE5-FCB8264C44B1&displaylang=en  or here:  http://www.microsoft.com/downloads/details.aspx?FamilyID=92759D4B-7112-4B6C-AD4A-BBF3802A5C9B&displaylang=en
Top Expert 2008

Commented:
have a look here

http://support.microsoft.com/kb/555850
Top Expert 2008

Commented:
the proxy settings in IE7 are done by machine and NOt by user thereforew although teh policies are applied IE7 doesnt use them

to get round this either disable teh key as in teh KB above OR create an Ou for all your computer accoutns and place them in it then apply the proxy gpos to that OU

Author

Commented:
I tried all these .adm replacement and KB 555850. no use of that.
Top Expert 2008

Commented:
well the proxy is not being applied as its taking the machines settings i am 100% confident of that did you try creating the computer ou within ad and adding the gpo to that group?

Author

Commented:
I have created test ou and doing all these R&D under that only as i can not touch production OU's and can not change policy set on that. So it is fresh OU as per you  and in which test machin and test users are pushed.
Top Expert 2008

Commented:
only put the machine not the user in and make it part of the machien configuration gpo not the user

Author

Commented:
u mean ou should have machin and policy define on ou should have gp with define proxy ip under user configuration and Make proxy settings per-machine (rather than per-user) under computer config.
Top Expert 2008

Commented:
thats exactly it, like i said for some reason m$ decided to make proxy settings for IE7 on a per machine basis as opposed to per user

Author

Commented:
Soory It is not working in that manner also
Top Expert 2008

Commented:
I am at a loss then, if you google this fault it is well documented and known difference between IE6 and 7 and the above steps have alklways remedied in teh past I am unsure how else I can proceed with this as its the known resolution?

Author

Commented:
Problem is resolve. It was exclusion that was having ipaddress:port number. Group policy will not be applied if any thing other than ; is entered in proxy ip assignments.
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.