• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 575
  • Last Modified:

Notepad missing from "Open WIth" program list; Double-click on .TXT gives "Access Denied"

I recently noticed that, after creating a .TXT file in Notepad, the saved file can no longer be opened in Notepad simply by double-clicking it in Windows Explorer.  Dialog box with error "Access Denied" pops up.  I can, however, choose to open with Wordpad with no problem.  Also, selecting the .TXT file from within Notepad after Notepad has already been launched works fine.

I checked file associations and found that .TXT files no longer had an associated program.  Tried to set it back to Notepad.exe and found that Notepad is no longer even listed in the "Open With" program list for file associations.  Then I checked to see if Notepad shows up in the "Open With" list from the context menu within Windows Explorer.  Missing there too!

Notepad.exe is in my C:\Windows and C:\Windows\System32 folders, as it should be.  It works fine by itself.  Somehow it has been removed from "Open With" and therefore can no longer be associated with .TXT.  So, I really need two things, to get my association back and to make sure Notepad is once again always an option in "Open With."  I am guessing this is a registry issue, but I am not certain which keys to update -- or if there may be another fix for this.  (FYI, platform is Windows Server 2003 SP2.)

Please let me know your insights!  Thanks!
0
AutomateMyOffice
Asked:
AutomateMyOffice
  • 5
  • 5
  • 3
  • +1
1 Solution
 
Chris JamesCommented:
Did you try to open a folder, then click TOOLS, FOLDER OPTIONS, FILE TYPES Tab

And remove the .txt extension then re add it?
0
 
AutomateMyOfficeAuthor Commented:
Yes.  Tried both Change and Delete/Add.  The problem is that Notepad is no longer an option in the "Open With" list, whether in the File Types tab or in the Windows Explorer file context menu.  (Also, while in the File Types tab, attempting to browse and explicitly select notepad.exe as the associated program does not work either.)  
0
 
Chris JamesCommented:
Did you maybe try restarting your computer after modifying the file extension in the file extensions tab?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Chris JamesCommented:
0
 
AutomateMyOfficeAuthor Commented:
Rebooting has had no effect on the situation.

Thanks for the suggestions and the link, but I am looking for a fix, not a workaround.  I already have a workaround by associating .TXT files with Wordpad.  What I want is for Windows to be back to normal, where I have the choice of Notepad in my "Open With" list for opening ANY file on which I right-click within Windows Explorer, and where .TXT is permanently associated with the Notepad program.  I just need to know if this is a known bug with a patch or registry edit that will get things back to correct and normal operations.
0
 
SysExpertCommented:
I would put a short cut of Notepad and wordpad on the desktop.

CHoose them via select, do a copy, and then paste into the sendto folder ( via right click on Start - Explore - and sendto folder for the user and default user ).

Then you can pick any kind of text file or doc and  right click - send-to, and choose notepad or wordpad.


I hope this helps !
0
 
Chris JamesCommented:
If it is a recent problem, did you by any chance scan your pc with a registry cleaner or spybot?  Try doing a system restore if necessary?
0
 
Chris JamesCommented:
by any chance did the permissions for the text pad application (the exe) get changed to prevent this type of access?

Try checking the security permissions of the EXE by right clicking and going to properties.
0
 
AutomateMyOfficeAuthor Commented:
SysExpert... As workarounds go, that is pretty good and simple and I have put it in place.  Thanks.  (You will definitely share in any awarded points.)

However, I am still looking for an actual fix that will restore the normal "Open With" list.  Something has gone wrong and, at least in this one area, Windows is broken.  Anyone have the location of "Open With" in the registry??
0
 
AutomateMyOfficeAuthor Commented:
I recently had some problems after (foolishly) running a beta version of (otherwise really good) cleanup program Advanced WindowsCare on the server.  To correct the situation, I slipstreamed SP2 into Windows Server 2003 and did an in-place upgrade (repair install).  Not sure if this happened as a result.  I have not run any cleanup or scans after the repair install.
0
 
SysExpertCommented:
1) DO a full backup of system state via NTbackup

2) Try  

sfc/scannow as this should fix lots of system related problems.

 
0
 
AutomateMyOfficeAuthor Commented:
Sorry for neglecting the post.  It seems to be working now -- and I am not sure how or why!  Points to SysExpert for the best workaround.  Thanks for the effort.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 5
  • 5
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now