• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 390
  • Last Modified:

Suddenly, VIsual Interdev is timed out!

I have the development version of my website on my PC. It has been there for a couple of years, without any problem, using Visual Interdev 6.  That was ok until yesterday...
Today, I canget my project under Project Explorer as usual, but when I double-click on any page to open it, I get this ereor message:
"Unable to open web project... Timed out while trying to connect to a server ... on port 80"
I tried to restart IIS, but it changed nothing.
What can I do to get access to my code again?
0
Gite
Asked:
Gite
  • 4
  • 4
1 Solution
 
BadotzCommented:
You can restart IIS and see if that helps

It has been my experience when I get that error, I use Explorer to navigate to "Inetpub\wwwrooot\WEB_NAME" and rename it to "Inetpub\wwwrooot\WEB_NAME_OLD". I then create a new web site, "WEB_NAME" and copy the files in from "WEB_NAME_OLD".

It is a royal p.i.t.a., and one of the reasons I moved to Microsoft Visual Web Developer 2005 Express Edition.
0
 
GiteAuthor Commented:
I had already tried to restart IIS, and that did not solve the problem.
I tried your rename - copy combibnation. but it did not solve the problem either.
I restarted IIS again, but the problem is still there...
0
 
BadotzCommented:
You must delete *all* references to the web site *after* you have copied it to the new name. Delete it from IIS, and make sure it does not exist in Explorer. Do *not* set it up manually in IIS; VID will do that.

If you cannot reuse the original name, try creating a new website with a slightly different name.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
GiteAuthor Commented:
I had forgotten to tell that the same site, on my PC, works ok with Internet Explorer. I only have that problem with Interdev!

Does that change your recommendation?
0
 
BadotzCommented:
I do not understand what you said, sorry. IE is not the issue, VID is.
0
 
GiteAuthor Commented:
I found the problem. I had installed Skype. Unistalling it solved the problem.
Thanks
0
 
BadotzCommented:
Well, I never would have thought of that. Skype, eh? Wow.

I wonder how it screwed up your projects? Unless it changed some IIS setting?

Good to know. Accept your answer as the solution, because this may come in handy for other Poor Souls ;-)
0
 
GiteAuthor Commented:
By default, Skype uses ports 80 and 443. I unchecked them in Skype options, and it now works.
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now