Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

How can we fixe 401.2 Access Denied errors on .Net Framework 2.0 Applications?

Posted on 2008-09-29
3
Medium Priority
?
630 Views
Last Modified: 2013-11-07
We have several websites and Virtual Directories under the websites both external facing and internal facing.  We have begun developing in the .Net Framework 2.0. Our systems are all W2003 Server OS. Our internal applications that were developed on .Net Framework 1.1 are working fine.  The .Net 2.0 Applications are producing the 401.2 Access Denied errors.  Internal Applications are running on the same system whether it is .Net 1.1 or .Net 2.0.  We are seeing this problem in one of our testing environments. I do not see it in our Production nor Virtual Environments.  I have verified that all the settings are the same in each environment.  We are using applicaton pools for the apps, using a domain asp service account and windows integrated authentication.  In the problem environment, I had set the authentication in both the config file and IIS manager to disable the windows authentication and use anonymous.  This worked for a while, but has quit working altogether now.  Anyone have any suggestions?
0
Comment
Question by:TStechsupport
  • 2
3 Comments
 
LVL 25

Accepted Solution

by:
apeter earned 750 total points
ID: 22599300
0
 

Author Comment

by:TStechsupport
ID: 22607629
I have been able to get the application to work again.  Some of the suggestions in the articles was useful.  Final solution, removed the Virtual Directory and all files associated with it.  Verified that IE was not set for "Enable Windows Authentication", re-deployed the Virtual Directory and files. verified that Windows Integrated was set for the VD Security.  All seems to be working again. Thanks for the assistance.
0
 

Author Comment

by:TStechsupport
ID: 22607646
I have been able to get the application to work again.  Some of the suggestions in the articles was useful.  Final solution, removed the Virtual Directory and all files associated with it.  Verified that IE was not set for "Enable Windows Authentication", re-deployed the Virtual Directory and files. verified that Windows Integrated was set for the VD Security.  All seems to be working again. Thanks for the assistance.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This document covers how to connect to SQL Server and browse its contents.  It is meant for those new to Visual Studio and/or working with Microsoft SQL Server.  It is not a guide to building SQL Server database connections in your code.  This is mo…
A long time ago (May 2011), I have written an article showing you how to create a DLL using Visual Studio 2005 to be hosted in SQL Server 2005. That was valid at that time and it is still valid if you are still using these versions. You can still re…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
Screencast - Getting to Know the Pipeline

877 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question