Solved

Forwarded messages to user on BES not going through

Posted on 2008-09-29
10
702 Views
Last Modified: 2012-05-05
Dear Experts,

We have an urgent issue that we were not able to fully resolve.
User has BB 8100c with CIngular. We have an older BES 3.8 and Exchange 2003 Standard. Users stated that not all of his messages are going through to his BlackBerry. Account was removed from BES 3.8 and readded, server was rebooted. BB was then synced with the Desktop Manager on the PC and mail started going through. I sent messages to the user internally as well as externally messages went throught. User has just contacted me stating that the forwarded message to him did go through to his Outlook but not the BB device...
User also receives AOL mail on it. Data plan should be alright since e is still getting some of his other messages. I was told a couple of a couple of things to try.
1 try removing and readding the account on BES and then inserting the PIN manually on BES 3.8 without ever connecting the device to PC.
2 readd the account on BES 3.8, connect the phone to PC (BB Desktop redirector) and sync - this worked for regular sent messages but not the fordarded once (to the best of my knowledge)
User is also able to reply to send messages from BB
3 Resend the books (not sure how to do this on 8100c), remove and add the account on BES.

Please help, this is really urgent and any help would be highly appricated.

0
Comment
Question by:technomic
  • 6
  • 4
10 Comments
 
LVL 11

Expert Comment

by:ALogvin
ID: 22608564
What do you mean by "Forwarded" messages? you mean like you sent me an e-mail, and I forwarded it to a co-worker? There is no difference between a forwarded e-mail and a replied e-mail other than the subject line.

Typically, if a user is not recieving some messages, but is recieving others, it is either a Filter on the BlackBerry, or a Rule in Outlook.

Filter:
On the blackberry, go to the message list, hit the menu button and go to options, then select "Message Filters". ensure that there isnt any wierd ones going on.

Rule:
In Outlook, goto the Tools menu, and hit "Rules and Alerts". ensure there isnt any wierd ones going on there.

If that fails to work, log onto your BlackBerry server, turn on the Messaging Agent logging up to 4 (MAGT), wait till the issue re-occurs, then attach your log, so we can take a look at it.
0
 
LVL 2

Author Comment

by:technomic
ID: 22609584
ALogvin,

At first the only coinsidence between messages that were not delivered to BB was that messages were Forwarded from someone to the user or to mulitple users. Message does go to Outlook though.
Now it doesn't really matter if the message is being forwarded, whether it has the attachment, so there are no similarities between the messages that do go through and the ones that do not.
I found nothing in the filters in BB desktop Manager 4.1.08
Rules: there were some rules that I either disabled or deleted. I also recreated the Outlook profile.
In logs I found this:

[40236] (09/30 00:23:53):{0x77C} {user@mydomain.com} Email Address is user@mydomain.com
[40237] (09/30 00:23:53):{0x77C} {user@mydomain.com} Routing Info is XXXXXXX
[40244] (09/30 00:23:53):{0x77C} {user@mydomain.com} Device ID is XXXXXXX
[40252] (09/30 00:23:53):{0x77C} {user@mydomain.com} Calendar synchronization has been disabled

We contacted the carrier, they did verify that the data plan is OK and has not been changed.
They also had us remove user from BES, add user, then resync with BB desktop manager
When the above didn't work, carrier tech support resent service books and updated the host routing table.

One of the other users just turned in his BB (same model 8700c). None of the other users have that issue, so we were going to wipe the phone that was just turned in, plug -in the SIM from the BB that we have an issue with. Remove/Readd user in BES and see if the issue reappears.

I didn't understand where exactly you wanted me to look for the Filter on the BES or PC BB desktop manager. Neither have anything in the filters...
0
 
LVL 2

Author Comment

by:technomic
ID: 22609819
Sorry, I posted the wrong part of the log

[40434] {user@maydomain.com} Queuing new mail through notification (external). EntryId=6037 (delay processing 32 seconds)
[40724] (09/30 00:22:10):{0x788} {user@maydomain.com} Get record key for this MAPI object, EntryId=6037
[40434] (09/30 00:22:10):{0x788} {user@maydomain.com} Queuing new mail through notification. EntryId=6037 (delay processing 32 seconds). Msgs Pending 0


[40000] (09/30 00:23:53):{0x77C} {user@maydomain.com} Could not retrieve handheld capabilities info
[40236] (09/30 00:23:53):{0x77C} {user@maydomain.com} Email Address is user@maydomain.com
[40237] (09/30 00:23:53):{0x77C} {user@maydomain.com} Routing Info is XXXXXXX
[40244] (09/30 00:23:53):{0x77C} {user@maydomain.com} Device ID is XXXXXXX
[40252] (09/30 00:23:53):{0x77C} {user@maydomain.com} Calendar synchronization has been disabled
0
 
LVL 11

Expert Comment

by:ALogvin
ID: 22609971
based on your logs, I'd say that your BES is seeing the message, and is queuing it to send to the device. If the device is not recieving it, I'd bet you have an issue w/ the Encyption key.

Try regenerating the encyption key on the BB:

Options
Security Options
General Settings
Scroll to the last item, hit the Menu button, and hit "Regenerate Encryption Key"
0
 
LVL 2

Author Comment

by:technomic
ID: 22610030
When we synced it yesterday, it did generate a new pin before the phone was wiped. I will have access to the phone in the am and will try that again.
0
Don't lose your head updating email signatures!

Do your end users still have the wrong email signature? Do email signature updates bore you or fill you with a sense of dread? You can make this a whole lot easier on yourself by trusting an Exclaimer email signature management solution. Over 50 million users do...so should you!

 
LVL 11

Expert Comment

by:ALogvin
ID: 22611501
I think we are getting close! If it was prompting to create a new encyption key (im sure thats what you meant) then this could be the cause!
0
 
LVL 2

Author Comment

by:technomic
ID: 22614510
Yeah. Before the BB was synced with the PC, it prompted to create a new pin andthat pin was expired. I asked the user if the BB was synced before, after it was originally setup and user stated that it was. So once the new PIN was issued, the phone was wiped... I think it`s possible that BB Desktop manager is corrupted or the BB device itself needs a firmware upgrade. Unfortunately, I can't do anything b/c I either don't have access to BB device at all times or I can't sync it when the user is in the office. One thng I did find..... Admin that worked here before had purchased Antair Filter for BB (spam prevention for BB), I dind't find it anywhere on the BES box. Do you know if Antair is hidden somewhere and wouldn't show up under BES anywhere ?
0
 
LVL 11

Accepted Solution

by:
ALogvin earned 500 total points
ID: 22615786
Eeep, never heard of that product before. If you have a BES i wouldnt do SPAM filtering on the BlackBerry system though... do it before it hits exchange.
0
 
LVL 2

Author Comment

by:technomic
ID: 22616564
You absolutely correct about that. I did put in a barracuda, so any mail that hits us goes through it first.  I did look through everywhere, i couldn't find anythign about Antair installed anywhere, so it`s probably not the cause for the issue. I guess it`s possible that it could`ve been used at some point, but it`ss not being used anymore. Nor BES nor BB Desktop manager had any filters (per user or global). I will let you know how today goes.
Thanks again for your help.
0
 
LVL 2

Author Closing Comment

by:technomic
ID: 31501461
Problem solved. Once I had anotehr chance to look at the BlackBerry itself, Antair Spam filter was installed on the device itself. B/c Antair was installed on the phone, it didn't show up in any filters on BES or BB Desktop manager. Removed Antair from BB, wiped the device just in case. Installed newer Desktop manager, upgraded the firmware on the phone, synced the phone and created the mail accounts. Everything is OK now. Thank you for your help.
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Join & Write a Comment

Are you using email marketing software? If not, you're missing out on effortless marketing and the reaching of desired conversion rates through email marketing software.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now