• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 647
  • Last Modified:

Blackberry Enterprise Server issue

Blackberry devices stop responding everyday until I restart the BB services on the BES server.  Any idea why this keeps happening?  Thanks in advance...
0
joeymatesic
Asked:
joeymatesic
1 Solution
 
ALogvinCommented:
Your going to need to give a bit more info.

What version of BES, and what service pack? Exchange 2003 or 2007? Or not Exchange at all?

Look at the event logs on the server, specifically the Application Event logs. They might tell you why, or tip you in the right way.

When the devices stop responding, look at the running services on the server. Which ones that start with "BlackBerry" are not running?
0
 
Kurt_BraeckmansCommented:
does this happens every day at a specific time? or at random?
What are the previous event prior to the failure?
0
 
joeymatesicAuthor Commented:
Exchange 2003 SP1, Blackberry Enterprise Server - Blackberry Manager 4.1.4.15.  All Blackberry services are still running when the Blackberry devices go down and when I restart them the Blackberry devices start working again.  This happens at random times.  Not sure what happens previous prior to the failure.  Event log App error (4 events per minute) ID 40578 Blackberry Messaging A
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
joeymatesicAuthor Commented:
Blackberry event log error
Blackberry-App-Error.bmp
0
 
ALogvinCommented:
I think we are gteting closer! Open up one of those events, and copy what you see here for us.

This warning typically means there is a problem with the MAPI subsystem on your BES connecting with your Exchange box.
0
 
joeymatesicAuthor Commented:
Blackberry Messaging A
Blackberry-messaging-A.bmp
0
 
joeymatesicAuthor Commented:
Hey, Alogvin

     What can I do to resolve the MAPI issue?
0
 
ALogvinCommented:
OK. First log into your BES and run the BlackBerry Server Config utility. Now go to the logging tab, and up your Messaging Agent logs to level 4. Restart your BES, and watch it. Once they start dying again, grab a copy of one of the MAGT logs, zip it, and upload it here. We can check it out and see.
0
 
joeymatesicAuthor Commented:
I can't increase the message level in the Messaging Agent logs.  I right clicked and double clicked but nothing happens.  Here's a snapshot of it.  I also found a MAGT log that I attached so hopefully this will help.  Let me know if there's another way of changing the levels on the Messaging Agent logs.  Thanks
Blackberry-Server-Configuration.bmp
BANYANTS-MAGT-01-20081008-0001.txt
0
 
ALogvinCommented:
It is a number.. you can click on the number 3 and change it to 4.


I can see in the logs that the issue is happening when the logs started, and you restarted your BES at around 10:30AM. Unfortunetly, we have one of those "when you take your car to the mechanic, it runs great" situations. In this log file, the issue didnt reoccur after the reboot... so we cant see what is causing it! Looking at the agent start up, everything seems good... but we need to get a log during the time when it starts.

Here is a log line of the problem:
[40578] (10/08 01:59:06.736):{0x948} CDO helper 00d40a10 - worker thread 000015e8 not responding, Initializing CDO object

Now if you can get the log from the time of one starting, it might point out a cause.

Also, you have 4.1 SP4... do you have any maintenence releases on there? I seem to remember that MR2 fixed a CDO worker thread error... SP6 is the newest Service Pack available.


0
 
ALogvinCommented:
Oops forgot to ask... on your Exchange server, what version is your CDO.DLL file?
Typically, its found here:
C:\Program Files\Exchsrvr\bin\cdo.dll


0
 
joeymatesicAuthor Commented:
The CDO.DLL version is 6.5.7234.20.  I will update to SP 6.0.
0
 
ALogvinCommented:
Updating your BES to SP 6 is a good idea regardless, but your BES is using CDO.DLL version 6.5.6944, which is older than your Exchange box.

I would recommend you get it updated first.

http://www.blackberry.com/btsc/articles/724/KB02937_f.SAL_Public.html

0
 
joeymatesicAuthor Commented:
I've updated the BES to SP 6 and so far it's been 4 days without the Blackberry devices going down.  I'll keep you up to date.  Thanks for your help.
0
 
ALogvinCommented:
GREAT!!! Glad to hear!! Keep us updated! Did you get your CDO updated?

A mismatched CDO may not cause outage issues... but your users may start to have calendar issues with it mismatched.
0
 
joeymatesicAuthor Commented:
Ok, since the SP6 upgrade the BES Server has been good.  I will update the CDO soon.  Thanks for all of your help.
0
 
Delphineous SilverwingGood Ol' GeekCommented:
What is the version of your MAPI32.DLL file (In System32)?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now