Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2007 not receiving internet emails after exch sp1 installed

Posted on 2008-09-30
15
Medium Priority
?
722 Views
Last Modified: 2013-11-30
Dear colleagues,

I am novice in exchange and I have an exchange server 2007 installed behind a firewall configured to have external access from the internet. After intalling exchange sp1 I am not able to receive mails from the internet. Internal mails are working and sending external mails is also working.

Any help is appreciated.
0
Comment
Question by:ch_b
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
15 Comments
 

Expert Comment

by:Damian Motyl
ID: 22606850
Check if receive connector in server hub transport settings is enabled. I had same issue like you after installing  SP1. Have a look if all services are running.

Hope that helps
0
 
LVL 1

Author Comment

by:ch_b
ID: 22606933
I have 3 receive connectors and all are enabled. All exchange services are running except Exch Unified Messaging, exch monitoring and exchange pop3
0
 

Expert Comment

by:Damian Motyl
ID: 22607127
In this case I would check to see if something else is running on port 25.Try to telnet to you mailserver using port 25.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Accepted Solution

by:
Damian Motyl earned 1500 total points
ID: 22607167
https://www.testexchangeconnectivity.com/ - use this to troubleshoot, hope that helps
0
 
LVL 1

Author Comment

by:ch_b
ID: 22607189
port 25 is listenning and i can telnet it. LAN users are able to send and receive mails internally. What i am expecting is something related to the receive connector. Is there a way to test if it is working?
Thank you
0
 

Expert Comment

by:Damian Motyl
ID: 22607394
Can you share informations from the properties of receive connectors?
Check permissions on connectors.
0
 
LVL 1

Author Comment

by:ch_b
ID: 22607592
I used testexchangeconnectivity and got the following result:

 >Attempting to retrieve DNS MX records for domain baldati.com
 >Successfully retrieved one or more MX records from DNS
>Additional Details
 >MX Records Host mailstore1.secureserver.net, Preference 10, Host smtp.secureserver.net, Preference 0

>Testing Mail Exchanger smtp.secureserver.net.
> One or more SMTP tests failed for this Mail Exchanger.
>Test Steps
> Attempting to Resolve the host name smtp.secureserver.net in DNS.
> Host successfully Resolved
>Additional Details
 >IP(s) returned: 208.109.80.149

>Testing TCP Port 25 on host smtp.secureserver.net to ensure it is listening/open.
 >The specified port is either blocked, not listening, or not producing the expected response.
>Additional Details
 >The connection was established but a banner was never received.

and it seams that secureserver MX are returning the wrong IP. What i would like to know if i can directly test the exchange server by IP and not by DNS
0
 
LVL 1

Author Comment

by:ch_b
ID: 22607878
I have 3 receive connectors:
Client ServerName
Default Servername
Inbound SMTP
All are enabled. "Inbound SMTP" FQDN is mail.baldati.com. As for permissions only Anonymous users is checked
0
 
LVL 1

Author Comment

by:ch_b
ID: 22608464
secureserver.net mailbox where i can see all messages before they are pulled from exchange is usually empty. but when i stopped exchange services, messages become queued in my mailbox. This mean that exchange is pulling mails from secureserver.net successfully but exchange clients are not receiving their mails.
0
 

Assisted Solution

by:Damian Motyl
Damian Motyl earned 1500 total points
ID: 22610544
in permissions try to tick exchange users and exchange servers that should sort this out, let me know the outcome
0
 

Expert Comment

by:Damian Motyl
ID: 22610570
http://technet.microsoft.com/en-us/library/aa996395(EXCHG.80).aspx this might help you,bur im 99% sure tha this will sort your problem out
0
 
LVL 1

Author Comment

by:ch_b
ID: 22612397
I have disabled all receive connectors and still able to send and receive email internally. Why?
0
 

Assisted Solution

by:Damian Motyl
Damian Motyl earned 1500 total points
ID: 22612693
Receive Connector controls inbound connections to the Exchange organization, internal emails are being sent within exchange egranization.
Try change permissions in receive connectors properties and let me know.
0
 
LVL 1

Author Comment

by:ch_b
ID: 22612901
First thank you for your help.
About the exchange i set all permissions as mentioned in previous message (exchange users and exchange servers are enabled for all connectors) and still have the problem. What i would like to ask is how can I make sure that the FQDN is working or is not wrong? And why the webmail in secureserver appears empty (this mean that exchange is getting mails but is not deliveing them to mailboxes). And one more thing how can I find messages in exchange queue?
0
 
LVL 1

Author Comment

by:ch_b
ID: 22636283
I have resolved it!!!! I looked in the event viewer and find Warrnings messages - Insufficient system resources. After installing Exchnage SP1 along with Exchange logging has filled partition C (system partition) 50MB free space and exchange was stuck.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
how to add IIS SMTP to handle application/Scanner relays into office 365.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question