Solved

Unable to access PC over Workgroup

Posted on 2008-09-30
37
1,232 Views
Last Modified: 2013-11-16
I have a 2 PC's and 2 laptops in a workgroup. My PC can access all the others and all the others can access each other. They can see my PC, however every time they try to access my PC as user name and password box comes up. I only have one user with no password set. I have Windows Firewall disabled and SPF v5.6 configured to allow all network traffic. I can see no reason why other PC's cannot access mine. Please help.
0
Comment
Question by:Styphon
  • 15
  • 7
  • 4
  • +6
37 Comments
 

Expert Comment

by:ebenswanepoel
ID: 22607146
Is the workgroup name the same and did you enable file and printer sharing?
Also try 'netsh winsock reset catalog' and 'netsh int ip reset reset.log'

if it still does not work try the following:
Map a drive with "connect using a different user name".
Hope ir works
0
 
LVL 3

Author Comment

by:Styphon
ID: 22607248
Yes, the workgroup name is HOMELAN on all of them. I have enabled file and printer sharing.
I've tried the two netsh commands, no joy. I don't understand what you mean "connect using a different user name". There are no other user names in use.
0
 

Expert Comment

by:ebenswanepoel
ID: 22608171
Try this: Uninstall then reinstall "File and Printer Sharing for MS Networks" service for your LAN connection:

If you right click and selec map network drive there is a option to connect using a diffirent user.You can click on the use diffirent user

also try this

Go to Control Panel
Network Connections
Rightclick properties on your LAN connection
General tab
Click File and Printer Sharing for MS Networks
Click Uninstall
click OK and then OK to close window
reboot
Go to Control Panel again
Network Connections
Rightclick properties on your LAN connection
General tab
Click Install
Click Service and click Add..
Select File and Printer Sharing for MS Networks, click OK and then OK to close window.
Try now to brows to it.
0
 
LVL 3

Author Comment

by:Styphon
ID: 22608736
I tried the uninstall and reinstall of "File and Printer Sharing for MS Networks", no effect. I cannot map as a different user because it requires a password, blank passwords are not allowed and I have no password set. On the flip side, if I enter the administrator details it works. However I don't have to do that when connecting to any of the other PC's/Laptops in the work group and I would like to be able to connect to this PC without having to enter any credentials.
0
 

Expert Comment

by:ebenswanepoel
ID: 22612297
was this pc ever part of a domain?
Are all the users admins or standard users if not the same try and make them all admin and try then.
Have a look at this MS Kb
http://support.microsoft.com/kb/301281
0
 
LVL 3

Author Comment

by:Styphon
ID: 22612395

No, the PC was never on a domain. And the users are all administrators. There is only 1 user on each PC/Laptop (other than the Windows Admin account).
I've had a look at that KB. I've done all that. The problem is not they cannot access the shares. The problem is they cannot access the PC to see the shares. When you click on My Network Places and then view all Workgroup PC's, you can see the PC but when clicking on it to try and see the list of shares/printers, it asks you for the login details. You can't even get to see a list of the shares, let alone try to access one. And if you manually type the share details (\\PC_Name\Share_Name) then you get the same result, ask's for your credentials.
0
 

Expert Comment

by:ebenswanepoel
ID: 22612700
What about the Guets account is it enable?

right click My Computer, select Manage
navigate to System Tools, Local Users and Groups
click Users
in the right pane, right click Guest, select Properties
remove the check mark from Account is disabled
click OK

0
 
LVL 3

Author Comment

by:Styphon
ID: 22616561
Guest account is disabled. It's disabled on all of the PC's/Laptops. It shouldn't have to be on for this to work.
I tried enabling the guest account, no effect.
0
 

Expert Comment

by:ebenswanepoel
ID: 22617140
It is defnitly some read/write
What if you create a new acount on the "faulty" pc, login with it and share something and and then try and brows to it from the laptop?
 
0
 
LVL 3

Author Comment

by:Styphon
ID: 22617472
The access can't be anything folder based, otherwise I'd be able to see the shares but not access them. I can't even access the computer to see any shares.
0
 
LVL 3

Author Comment

by:Styphon
ID: 22661668
I've tried refreshing the entire network, no joy.
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22718207
Is this one SP3 and the others SP2? In this case it has picked up some "enhanced" security requirements. Create accounts to match those on the other pc's. You don't need to use them, but if they exist you will have access permission.

Chris B
0
 
LVL 3

Author Comment

by:Styphon
ID: 22718705
All of them are SP3 and all have exactly the same accounts, both root admin and user account.
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22718749
Remove the Sygate firewall as a test.

Chris B
0
 
LVL 3

Author Comment

by:Styphon
ID: 22719363
OK, uninstalled and rebooted, tried to connect and still asked for authentication. Reinstalled and rebooted. No changes.
0
 
LVL 69

Expert Comment

by:Merete
ID: 22801421
Is there a hand below the shared folder, go to C drive my computer look at the folder called shared documents.
try renaming the workgroup and leave it as windows default>> MSHOME. on all computers, reboot all
Another work around, open my computer go to tools folder options>View> scroll down to the bottom disable simple file sharing ( recomended)  apply.
Do this on all computers ok.

In control panel Windows firewall> exceptions> add file and print sharing.
then wait or reboot everyone.
I had similar issues and gave up, xpsp2
what I did instead in.
My documents>create a new folder named it shared folder then shared it giving all users access to change files as well ..apply
And that worked.

Is your network internet access functioning ok?
0
 
LVL 69

Expert Comment

by:Merete
ID: 22801425
Are these computers all xp pro is yours xp home?
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 
LVL 54

Accepted Solution

by:
b0lsc0tt earned 250 total points
ID: 22801427
Is your computer and the others Home or Pro editions?
You probably didn't use Simple File Sharing when you set up sharing on your computer.  This will mean the security settings will by default (I believe) require an authenticated user (or some specific account).  Unless you have  some need for the advanced sharing it may be easier to enable simple file sharing.  The alternative would be to create an Everyone user in the Security area of that share and give that user the permissions.
I believe the option to switch to Simple File Sharing is just a change on the Sharing screen.  I don't have a machine with me now to provide details or confirm this though.  Let me know how it works or if you have a question.
bol
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 22801991
seeing as you do not have a password set on that machine - can you set a password for it instead of it being a blank password - then when it requests you to authenticate use that password instead of just the username without the password.

See if that helps.

Also I presume all the machines are on the same subnet and have the same subnet mask. Also due to the fact that you get an authentication dialog window I presume you can ping that one machine from the other machines.

Also on any firewall software you have ensure you disable it for the time being whilst you are trying to get this to work - once it works then you can re enable the firewall(s) and just forward the relevant ports you need.
0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 22802040
The firewall will have to be told to trust your local subnet,
as b01sc0tt said, unless you have simple file sharing enabled, you will need a password
Have you tried the guest account?
0
 
LVL 2

Expert Comment

by:patmoli
ID: 22802071
I just browsed this question quickly without reading all the comments thouroughly, but in this situation I would set a password on this accounnt and use:

user:pcname\useraccount
pass:password
0
 
LVL 3

Author Comment

by:Styphon
ID: 22802252
Merete - All computers are running XP Pro. The folder is shared (yes there's a hand on the folder symbol). One of the first things I did in setting up this network was remove simple file sharing from all the computers. However, every share has the group Everyone with full control by default on the actual share permissions. then in the security tab Administrators and the owning account (Tony in this case) have Full Controll and Everyone has Modify access.
Windows Firewall is disabled on all computers. I use Sygate Personal Firewall on them all. However for arguments sake I checked and on them, file and printer sharing is on the exceptions list for Windows Firewall.
Internet access is fine.
For this problem, it's not that I can't access this one share, it's any share (including the shared folders & C$). I can't even open the PC to browse the shares.

Everyone else. I didn't realise turning off simple file sharing required authentication. However, the other PC's/Laptops in the work group all have simple file sharing unchecked and they can be accessed fine, no problems. Why only this PC?

Bol - I will enable simple file sharing and then reboot. I'll post back the results soon.

gecko - the whole idea behind this network is that it's completely unpassworded and no authentication is needed. Otherwise there is no point in having this network. The machines all get their IP from the router, which is acting as a DHCP server. Disabling the firewall has no effect, but I will keep it disabled for now.

wylie - The firewall is already configured to allow all network traffic. The guest account has no password and as such is rejected by the authentication window. I did try it.

patmoli - I can type the admin account details in and I can connect fine, but that defeats the whole point of this work group. It shouldn't have any user names or passwords.
0
 
LVL 29

Expert Comment

by:TeRReF
ID: 22802261
Did you try to open a dos box to use this command:

net use

You can find more info about it if you type:

net use /?

0
 
LVL 3

Author Comment

by:Styphon
ID: 22802268
Yea,  I tried the whole net use command. I also setup a reconnecting network shared drive. But it only worked when I put in the admin details (something I didn't want to do).

This has me baffled. I've reset it to simple file sharing, then reset the network name to MSHOME and low and behold it all works. I don't know why one computer didn't need authentication and the other did without simple file sharing. I guess it's another windows mystery.

But it's working, that's what I wanted. Thanks a lot for the help guys.
0
 
LVL 3

Author Closing Comment

by:Styphon
ID: 31501618
Thanks, didn't know that about simple file sharing. Weird how one PC needed authentication where the rest didn't.
0
 
LVL 69

Expert Comment

by:Merete
ID: 22802283
Glad to see you sorted it.
 I do feel a split would have been appropiate since I brought up the simple file sharing first and changing the name to mshome.
but all in all the main thing is you found solutions from our help.
All the best Merete
 
0
 
LVL 3

Author Comment

by:Styphon
ID: 22802301
Sorry, I didn't know you could do a split.
0
 

Expert Comment

by:ebenswanepoel
ID: 22802432
No It was meeeeeeee
0
 
LVL 3

Author Comment

by:Styphon
ID: 22802785
No, you suggested the LAN name, however I have a feeling that it was a coincidence. The solution, I'm sure, was to enable simple file sharing. However it's working now and I'm not willing to test that theory and risk it not working lol.
0
 

Expert Comment

by:ebenswanepoel
ID: 22804363
No, I agree 100%
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 22805040
Styphon,
I'm glad that helped.  I can understand your hesitation to mess with things as they are now working but the workgroup name would not make a difference in this case.  Don't feel you have to stick with the default to get computers to network, especially with simple file sharing.
As far as a split goes I can reopen this question for you if you feel you would've split.  Just let me know and since I am a zone advisor I have the tools to do it.  You could also get it done by using the Request Attention button to get a moderator or admins helps if this happened in another question.
I had not read Merete's post when I posted and am sorry that I inadvertently mentioned the same feature.  I would've given credit had I seen it.  However I believe the suggestions were opposite.  Although you could make this work with simple file sharing disabled (Merete's suggestion I believe) my suggestion was to enable it.  I did that for two reasons.  It seemed the other computers used it and it was the quickest fix I saw.  In a case like this there is nothing wrong with using it and disabling would just cause a little more work and expertise.
Your problem and the login screen you got is actually a predicable result of having disabled simple file sharing on that PC.  It sounded like it was just one computer that no one could access and that should've been the one that wasn't using simple file sharing.  Hopefully that clears up any confusion on why it is working now but let me know if you still have a question or I have misunderstood.  Of course most important is it is working. :)
bol
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 22805045
By the way thanks for the fun question, the grade and the points.  I'm glad I could help.
bol
0
 
LVL 3

Author Comment

by:Styphon
ID: 22805064
Ah, you're right. He was on the right track but you were the one with the complete answer. No point in the hastle now.

All the computers were configured with Simple File Sharing off, which is why I am confused that only one of the PC's was causing problems. As far as I could tell they were all set-up exactly the same... Weird Windows again.
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 22805181
Weird Windows again
LOL.  I can't argue that. :D
He was on the right track
I believe you mean Merete who is actually female.  I am sure you just used "he" in general but figured I would let you know since Merete is a good expert who you will definitely see around here again. :)  I also use "he" as a general pronoun in place of he or she so I am not discouraging that.  Just giving some helpful info.
bol
0
 
LVL 3

Author Comment

by:Styphon
ID: 22805195
Ooops, sorry. Guess I shouldn't generalise. SHE was on the right track, I apologise.

Weird Windows, I'm an IT admin myself (only a year n a half experience tho) so I've had a few weird circumstances come up at work. Oh for them switching to Linux... A pipe dream of mine.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now