Solved

Reconfiguring Cisco 2651XM Router

Posted on 2008-09-30
10
513 Views
Last Modified: 2012-06-27
We currently have a Cisco 2651XM router. It has a dual port VWIC-2MFT-T1 card in slot W1 and a single port WIC-1DSU-T1 in slot W0. The dual port card is currently creating the connections to offices #2 and #3. The single port card is responsible for the connection to office #1. We are adding a 4th office and I need to replace the single port card with another dual port VWIC-2MFT-T1 card. Can someone give me an idea of the configuration that will be necessary as all the serial interface numbers will change when I have 2 dual-port cards in the mix?? These are all strictly data T-1s (no voice). Thanks guys!!
!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

!

ip subnet-zero

!

!

!

!

!

controller T1 0/1

 framing esf

 linecode b8zs

 channel-group 0 timeslots 1-24 speed 64

!

controller T1 0/2

 framing esf

 linecode b8zs

 channel-group 0 timeslots 1-24 speed 64

!

!

!

interface Loopback1

 ip address 10.1.1.1 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.7.13.1 255.255.248.0

 duplex auto

 speed auto

!

interface Serial0/0

 description Link to Office 1

 ip address 10.7.128.14 255.255.255.252

 encapsulation ppp

 service-module t1 clock source internal

 service-module t1 timeslots 1-24

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1:0

 description Link to Office 2

 ip address 10.7.128.9 255.255.255.252

 encapsulation ppp

!

interface Serial0/2:0

 description Link to Office 3

 ip address 192.168.110.1 255.255.255.252

 encapsulation ppp

!

router ospf 2

 router-id 10.1.1.1

 log-adjacency-changes

 network 10.7.8.0 0.0.7.255 area 0

 network 10.7.128.8 0.0.0.3 area 0

 network 10.7.128.12 0.0.0.3 area 0

 network 192.168.110.0 0.0.0.3 area 0

!

router ospf 12

 log-adjacency-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.7.13.6

ip http server

!

!

line con 0

line aux 0

line vty 0 4

 password *******

 login

!

!

end

Open in new window

0
Comment
Question by:wjester
  • 5
  • 2
  • 2
10 Comments
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22608783
Basically just backup your old config and when you insert the new card those old commands that no longer apply should automatically disappear. Then just re-enter the commands for the one that is currently serving office #1. And then enter the new commands for office #4. Since it is the same module as the other 2 port one you are using, I would suggest making sure that the commands for the 1 port card look the same as the commands for the 2 port card.
That should do it! Let me know if you have any questions!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22610936
You'll have to configure the channel groups on the new controller interfaces before you will ge tthe new serial ports to configure with IP addresses.
Then serial 0/0 will go away, to be replaced by serial 1/0:0 and 1/1:0
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22611090
Like I said. :-) Just basicaly copy the commands.
0
 
LVL 7

Author Comment

by:wjester
ID: 22615873
I guess what confuses me is that the duplex card is in slot #1. Shouldn't that make the controller commands reference 1/1 and 1/2?? When I add the new duplex card into slot #0, should it be 0/1 and 0/2??
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 79

Expert Comment

by:lrmoore
ID: 22615948
Odd... I would expect it to be controller 1/0 and 1/1
Cisco has been consistent over the years in their interface numbering.
Slot 0 = 0/0 and 0/1 = Serial 0/0 = WIC in slot 0
Slot 1 = 1/0 and 1/1 = I would expect serial 1/0:0 and 1/1:0

If you replace the single port WIC with a new dual port VWIC, you'll have to re-check all the interface numbering for the controllers..
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22616474
Yes, the slots are referred to as 0 and 1 and so are the cards... The naming goes slot/card:port
With most Cisco stuff he numbers start at 0
0
 
LVL 7

Author Comment

by:wjester
ID: 22638139
when reconfiguring the single port card as a double-port card, how will I change the existing settings:

encapsulation ppp
service-module t1 clock source internal
service-module t1 timeslots 1-24

so that they will work with the new dual port card?? How do I determine what the framing and linecode are??
0
 
LVL 12

Accepted Solution

by:
Pugglewuggle earned 500 total points
ID: 22638503
You don't need to do that - the interfaces will appear as T1 1/1 and T1 1/2.
These are the commands you would need to setup the new T1 1/1 and Serial 1/1:0 that appear. Just do the same thing for T1 1/2 and Serial 1/2:0.
controller T1 1/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
interface Serial1/1:0
description Link to Office X
ip address x.x.x.x x.x.x.x
encapsulation ppp

Cheers!
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22638508
They will have the same linecode. All a linecode is is a value for the type of line attached. It varies between a few values for T1/E1 and others. In your case, just use the existing b8zs if you're connecting an identical T1 line.
Cheers!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Edgemax OS VPN, to Barracuda Link Balancer 7 154
Force VPN connection to use a network adapter 6 68
VLAN question 7 61
The purpose of using BGP 33 72
While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now