Cannot enable Macros in Word 2007

Hi.  We are running Office 2007 in a Citrix PS 4.5 environment.  We have used Group Policy to enable the Trust Bar warning for all macros for Word.  However, when we try to open a file with a macro, we can see the bar, but a window pops up saying:

"The macros in this project are disabled.  Please refer to the online help or documentation of the host application to determine how to enable macros"

After I click on OK, the Trust Bar disappears and I'm unable to enable the macro.

Can anyone help with this?

Thanks.
clcuserAsked:
Who is Participating?
 
GlennHarrisConnect With a Mentor Commented:
The avery template installs itself as a password protected locked addin so we cannot change it's behavior.
0
 
GlennHarrisCommented:
In 2007, you cannot have macros in a .docx file, it needs to be saved as a macro-enabled .docm file extension. Select the Office Button, Save As command, then change the file type to Macro-Enabled
0
 
clcuserAuthor Commented:
Thanks for the response.  Maybe I should provide a little more detail.

The file is a template from Avery.  The user tries to launch it by double-clicking on it and then we get the described behaviour.  How can we apply your solution in this case?

We were able to work around it by copying the macro to the user's profile.

Thanks.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
GlennHarrisCommented:
I'd suggest you try using Office Button > Open > "Avery Template", then Office Button > Save As > Word Template
Before you click save, click on the File Type drop down that says "Word Template" and change it to "Word Macro-Enabled Template"; The file's extension should be dotm not dot or dotx.
0
 
clcuserAuthor Commented:
Unfortunately, that didn't work.  I can't get it to open properly, so when I save it, I'm not saving the template with all the features enabled.  Oh well...
0
 
GlennHarrisCommented:
If you attach the file or provide a url to download it i'll have a look at the issue, my solution should have worked.
0
 
GlennHarrisCommented:
That template works fine on my computer. Make sure before you open the template that you've enabled macros; From the office button, click on the Word Options button. Click Trust Center on the left. Click the Trust Center Settings button toward the right side. Click Enable Macros radio button and check the Trust VBA model checkbox, then re-open the file.

HTH
0
 
clcuserAuthor Commented:
Unfortunately we have Group Policy settings to not enable macros by default.  The setting is "Disable all macros with notification".
0
 
GlennHarrisCommented:
So it sounds like you already knew your answer. If the template has macros and macros are disabled are you asking to hack the group policy? It'd seem easier to request an exception.
0
 
clcuserAuthor Commented:
That brings me back to my issue that I highlighted at the beginning where the trust bar disappears, so I'm unable to enable the macros.

When I open other Word docs that have macros, they are disabled, but the trust bar does not go away and I am able to enable the macro and work with the doc as expected.  
0
 
clcuserAuthor Commented:
Okay.  Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.