Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2573
  • Last Modified:

Age of Empires LAN IP

Playing Age of Empires III (with both expansions, war chiefs and asian dynasties) on a LAN. There are four players, three of which can connect one to the other, but I cannot connect to anyone nor can they to me, whether through the LAN room join, or direct IP join. We can, however, all see each others games.

We are all running on mac's and using leopard. We've tried both wired and wireless, and we are on a Linksys WRT54G router. When I fire up my game, my IP address - in game - is constantly 192.168.2.1, whereas the other three players, in game, have IP's corresponding to their actual computer IP's, such as 192.168.0.10x or .1.10x, etc..

I've attempted changing the third router octet to 0, 1, and 2. All of our macs renew IP's properly, and in game they reflect the proper IP, however my game constantly reads 192.168.2.1....I also tried reinstalling the game, and creating a new profile (with fresh preferences), however the 192.168.2.1 IP still pops up in game, contradictory to my actual computer's IP. The other three players are running the same version as me, and have no issues with this.

Any thoughts as to why this might happen?
0
dandenegre
Asked:
dandenegre
  • 3
  • 2
1 Solution
 
☠ MASQ ☠Commented:
Sounds like the issue is with your machine's networking configuration.
Check if you're  configured to have a fixed IP address or to obtain one automatically from your router.
It's the second option you want.
0
 
dathhoCommented:
Ck your linksys and make sure it's not using the same MAC address as your computer.
0
 
dandenegreAuthor Commented:
Another note: I've tried manual address, dhcp address, and dhcp with manual address - the computer IP updates fine (either manually or automatically, depending on which setting I have). Despite all these tries, the game IP always registers 192.168.2.1. In terms of networking, all the mac's can see each other just fine, and all our IP's are the same - it's only in-game on my machine that is afflicted. Maybe something deeper than just manual/auto IP settings?

I haven't checked the MAC address though...will try next....thx!
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
dandenegreAuthor Commented:
I found the root of the problem - my ethernet interfaces (0 for ethernet, 1 for airport, 2 for....etc) in the network utilities is where the game is drawing the IP from. Ethernet Interface 0, which is my ethernet card, has a 192.168.2.1 IP. My airport has the correct IP, which is Ethernet Interface 1.

Anyone know how to bypass Interface 1, or swap Interface 0 and 1 ?
0
 
dathhoCommented:
Good troubleshooting!

You could try disableing the interfaces you don't want before starting AOE.
0
 
dandenegreAuthor Commented:
I'm not sure what exactly worked...but I was changing the ethernet interface settings - to no avail - and walked away. Three hours later I returned and the phantom IP from en0 (ethernet card) was missing.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now