• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 399
  • Last Modified:

Intermittent Outlook/Exchange Issue- Asking for password

I posted on this before and thought I had it licked. Very intermittently outlook prompts for your username and password, over and over again, you can enter it as many times as you like but it is never happy. If you click cancel and then click on "need pasword" in the lower right it will be happy. We just re-did everything and are running Exchange 2007 on Server 2008. Also I used the "trick" for a single cert for all of the Exchange functions, and my external machine name is different then my internal name, so exchange.xxxx.com and exchange.xxxxxx.local. Please help.
0
nkrueger84
Asked:
nkrueger84
  • 6
  • 4
1 Solution
 
guydemarcoCommented:
Check to see if there is a communication problem with the AD, or if the AD is having issues with 100% CPU usage. Look at the AD logs in event viewer, while you're at it.

Check the NIC settings to make sure they're not going into power-down mode.
0
 
abdulzisCommented:
Also verifiy none of the virtuals directories in IIS 7 are set to anonymous incl OAB, EWS, Autodiscover and UM.
0
 
nkrueger84Author Commented:
No anonymous on anything....so far I do not see any issues on the exchange server or either DC..

Also, in case it matters, everything is now virtualized including Exchange and both DCs...
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
abdulzisCommented:
Does this happen for Outlook 2003 and 2007 clients?
0
 
nkrueger84Author Commented:
We only have 2007 clients
0
 
abdulzisCommented:
plz paste the output of

get-webservicesvirtualdirectory | fl *url*
get-oabvirtualdirectory | fl *url*
get-clientaccessserver | fl *url*
0
 
nkrueger84Author Commented:
[PS] C:\Windows\System32>get-webservicesvirtualdirectory | fl *url*


InternalNLBBypassUrl : https://exchange.xxxx.local/ews/exchange.asmx
InternalUrl          : https://exchange.xxxxx.com/ews/exchange.asmx
ExternalUrl          : https://exchange.xxxxxx.com/ews/exchange.asmx


[PS] C:\Windows\System32>get-oabvirtualdirectory | fl *url*


InternalUrl : https://exchange.xxxxxx.com/OAB
ExternalUrl : https://exchange.xxxxxxx.com/OAB

[PS] C:\Windows\System32>get-clientaccessserver | fl *url*

produced nothing...


Also, FYI, this is a single box installation of Exchange.


0
 
abdulzisCommented:
If you ping exchange.xxxxxxx.com from the workstation, does it resolve to the internal IP or external IP of the CAS? Also do you have any proxy server specified in Internet Explorer options?
0
 
nkrueger84Author Commented:
I have it resolving the internal address of the CAS. No proxy server is specified.
0
 
nkrueger84Author Commented:
I still haven't found anything that looks out of the ordinary to me....
0
 
nkrueger84Author Commented:
In theory I have found the answer over at this blog: http://blog.aaronmarks.com/?p=65 (Thank You Aaron!)

The issue is with changes in IIS7/Server 2008 on which I am running Exchange 2007. Apparently IIS 7 uses kernel mode authentication by default and you need to turn that OFF using the command below:

%systemroot%\system32\inetsrv\appcmd.exe set config /section:system.webserver/security/authentication/windowsauthentication /usekernelmode:false

I just issued the command will post again in a day or day when verified that this takes care of it.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now