• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1831
  • Last Modified:

OWA Access Denied Error

We came in this morning to find OWA refusing to work, after about a year of flawless (ish) use.

Its a Win2k3 server running Exch 2003 with latest SP.
It did have Sharepoint 3 on it, but that was actually running ok, tho had been disabled a few months back.

I tried a few things this morning and nothing seemed to work, so i also uninstalled Sharepoint whilst it was all fecking about.

Im now left with a broke OWA setup, but fully working mail server.
also i cant view public folders thru the exchange manager.

Currently if i view my OWA account i get -
"Parser Error Message: An error occurred loading a configuration file: Failed to start monitoring changes to '\\.\BackOfficeStorage\domainname.co.uk\MBX\andrew' because access is denied."

I've removed and let the owa virtual dirs' get recreated in IIS
I've reinstalled .Net 2, and re reg'd it as per http://support.microsoft.com/?id=883380

I've checked the privileges for asp temp files folder, and network service has full rights

not sure what else to try :./

any ideas?
0
acstua
Asked:
acstua
  • 9
  • 6
  • 2
  • +1
2 Solutions
 
abdulzisCommented:
Use Method 2 in this KB http://support.microsoft.com/kb/883380 to delete Ds2Mb and let virtual directories get recreated.

Also make sure you backup IIS metabase before doing this.
0
 
acstuaAuthor Commented:
ive done that, they get recreated, but exactly the same issue ;\
0
 
abdulzisCommented:
Any errors in app/system log?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
abdulzisCommented:
run get-exchangecertificate | fl

you will find all certificates in the certificate store

look for the self signed certificate and look for the enabled services filed. you will find for what all services the old self-signed certificate was enabled. Enable the new cert for those particular certificates.
0
 
abdulzisCommented:
whoops, sorry wrong post
0
 
acstuaAuthor Commented:
App log has one error -
Eventid 1185
Failed to start monitoring changes to '\\.\BackOfficeStorage\call-assist.co.uk\MBX\andrew' because access is denied.
Application virtual path: '/'
0
 
abdulzisCommented:
What is the Source?
0
 
acstuaAuthor Commented:
Source: ASP.NET 2.0.50727.0
Category: FIle Monitoring
Type: Error
0
 
abdulzisCommented:
Can you try reinstalling SP1 for ASP.NET 2.0?
0
 
acstuaAuthor Commented:
same but now i get an extra warning , as below -


Event Type:      Warning
Event Source:      ASP.NET 2.0.50727.0
Event Category:      Web Event
Event ID:      1310
Date:            30/09/2008
Time:            23:13:04
User:            N/A
Computer:      EXCHANGE1
Description:
Event code: 3008
Event message: A configuration error has occurred.
Event time: 30/09/2008 23:13:04
Event time (UTC): 30/09/2008 22:13:04
Event ID: be2990c4ff484a97b71f55a1ca1458f0
Event sequence: 4
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT-1-128672863804712941
    Trust level: Full
    Application Virtual Path: /
    Application Path: c:\inetpub\wwwroot\
    Machine name: EXCHANGE1
 
Process information:
    Process ID: 2284
    Process name: w3wp.exe
    Account name: NT AUTHORITY\SYSTEM
 
Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: An error occurred loading a configuration file: Failed to start monitoring changes to '\\.\BackOfficeStorage\domainname.co.uk\MBX\andrew' because access is denied. (\\.\BackOfficeStorage\domainname.co.uk\MBX\andrew\web.config)
 
Request information:
    Request URL: http://exchange1/exchange/Andrew/?Cmd=navbar 
    Request path: /exchange/Andrew/
    User host address: 172.21.0.29
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\SYSTEM
 
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\SYSTEM
    Is impersonating: False
    Stack trace:    at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
   at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
   at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
   at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission)
   at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
   at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName)
   at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index)
   at System.Web.Configuration.RuntimeConfig.get_Identity()
   at System.Web.HttpContext.get_ImpersonationToken()
   at System.Web.ClientImpersonationContext.Start(HttpContext context, Boolean throwOnError)
   at System.Web.HttpApplication.ThreadContext.Enter(Boolean setImpersonationContext)
   at System.Web.HttpApplication.OnThreadEnterPrivate(Boolean setImpersonationContext)
   at System.Web.HttpApplication.ApplicationStepManager.ResumeSteps(Exception error)
 
 
Custom event details:

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
 
rikke_vpCommented:
did you try restoring via backup to a previous state?

IIS can sometimes be a pain and the solution dead simple

Rikke
0
 
acstuaAuthor Commented:
i'd rather not as it'd prob be full of all the sharepoint stuff ive tried to get rid of \;
0
 
BrentDevOpsCommented:
FYI: Exchange 2003 is an asp v1 app.. asp 2.0 is not supported.  Make sure all the exchange directories are set for asp v1
0
 
acstuaAuthor Commented:
ive changed it to use v1, now i just get a 404
no errors in the event log anymore
0
 
acstuaAuthor Commented:
this is now working,
i changed to asp 1
and then reset the auth and access control on the virtual directorys to match what they were on a previous image.

i also had asp_isapi mentioned in the wildcard application maps in application config, i took this out.

Thanks everyone for all yer advice

Cheers
Andrew
0
 
BrentDevOpsCommented:
Good to hear!
0
 
acstuaAuthor Commented:
must admit i wasnt sure if ASP 2 was something put on by Sharepoint and if needed

i've still got an issue with public folders under the exmon, but im going to try http://support.microsoft.com/kb/839744 
later this evening, should hopefully clear it up
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 9
  • 6
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now